Features:

  • STARFACE Security Release fixes vulnerability - Update strongly encouraged

    In the context of a blackmail threat, STARFACE gained knowledge of a security vulnerability in versions 6.1, 6.2, 6.3 and 6.4. This vulnerability could possibly be exploited actively in the near future. Therefore, we published a security release that closes the aforementioned vulnerability.
    We strongly encourage you to take the following steps immediately:
    • Please create a backup of your STARFACE telephony systems immediately. Save this backup to an external drive. Ensure that backups are created regularly in the future.
    • Install the security release that matches your STARFACE version. Customers on versions 6.4.0 and 6.4.1 may update to the latest version of 6.4.2 without an update contract.
    • Change all passwords on your STARFACE telephony system precautiously.

    Furthermore, we encourage you to restrict external access to the web user interface for all appliances and virtual machines as least temporarily.

    In addition to these measures, we will start automatic updates of cloud-based telephony systems within the contractual maintenance windows.

    After installing this security release, several modules might cease to work properly, because the module function ?Execute? was modified.



Earlier releases...