Seite 3 von 5 ErsteErste 12345 LetzteLetzte
Zeige Ergebnis 31 bis 45 von 62

Thema: [Spielzeug] Let's Encrypt!

  1. #31
    STARFACE User

    Registriert seit
    11.10.2016
    Beiträge
    69

    Standard

    Jetzt hats auch geklappt.

  2. #32
    STARFACE Expert
    Benutzerbild von nucom
    Registriert seit
    11.12.2012
    Ort
    9443 Widnau
    Beiträge
    1.124

    Standard

    So.

    Habe grade noch eine neue Version Hochgeladen, diese Versucht es erneut, falls der Nonce Ausläuft.

    Jetzt hats auch geklappt.
    Freut mich

    MfG

    Fabian
    Modulhersteller aus der Schweiz
    __________________________________________________ ________
    STARFACE Excellence Partner: Info | Certified Module Creator Kontakt

  3. #33
    STARFACE Newbie
    Registriert seit
    14.04.2017
    Beiträge
    4

    Standard funktioniert perfekt - vielen Dank!

    Hallo,

    hat bei mir per DNS Challenge auch wunderbar funktioniert!
    Vielen Dank - das ist wirklich ein super Modul!

    Bin gespannt ob das automatische Renewal auch funktioniert... Test läuft...

    Grüße
    Michael Sommer

  4. #34
    STARFACE User

    Registriert seit
    21.01.2016
    Beiträge
    9

    Standard

    Hi Fabian

    Erstmal vielen Dank, dass du das sehr nützliche Modul zur Verfügung stellst!
    Bei uns geht zunächst alles durch, ein CSR wird erstellt aber dann wirft der Request eine Exception:

    Code:
    [2018-02-07 19:03:05,034] DEBUG [CreateChallenge] Trying to Authorize Domain: starface.eye.ch 
    [2018-02-07 19:03:06,470] DEBUG [TriggerChallenge] Triggering Challenge 
    [2018-02-07 19:03:07,866] DEBUG [TriggerChallenge] Challenge Succeeded! 
    [2018-02-07 19:03:07,867] DEBUG [RequestCertificate] Trying to Request a Certificate 
    [2018-02-07 19:03:07,868] DEBUG [RequestCertificate] Creating new Keystore 
    [2018-02-07 19:03:07,868] DEBUG [RequestCertificate] Creating new Private Key 
    [2018-02-07 19:03:45,851] DEBUG [RequestCertificate] Loading existing KeyPair from: /home/starface/letsencrypt/CertPK.pem 
    [2018-02-07 19:03:45,856] DEBUG [RequestCertificate] KeyPair Successfully loaded. 
    [2018-02-07 19:03:45,856] DEBUG [RequestCertificate] Loading CSR 
    [2018-02-07 19:03:45,856] DEBUG [RequestCertificate] Creating CSR: 
    [2018-02-07 19:03:45,857] DEBUG [RequestCertificate] Domain:starface.eye.ch 
    [2018-02-07 19:03:45,857] DEBUG [RequestCertificate] Country:Schweiz 
    [2018-02-07 19:03:45,857] DEBUG [RequestCertificate] Organization: EYE Communications AG 
    [2018-02-07 19:03:45,857] DEBUG [RequestCertificate] OrganizationUnit:IT 
    [2018-02-07 19:03:45,857] DEBUG [RequestCertificate] State:Basel-Stadt 
    [2018-02-07 19:03:46,928] DEBUG [RequestCertificate] Trying to Request Certificate 
    [2018-02-08 11:07:37,418] DEBUG [RequestCertificate] org.shredzone.acme4j.exception.AcmeUnauthorizedException: Error creating new cert :: authorizations for these names not found or expired: starface.eye.ch
    	at org.shredzone.acme4j.connector.DefaultConnection.createAcmeException(DefaultConnection.java:397)
    	at org.shredzone.acme4j.connector.DefaultConnection.accept(DefaultConnection.java:207)
    	at org.shredzone.acme4j.Registration.requestCertificate(Registration.java:245)
    	at org.shredzone.acme4j.Registration.requestCertificate(Registration.java:210)
    	at nucom.module.letsencryptv3.certificate.RequestCertificate.execute(RequestCertificate.java:147)
    	...
    Ich habs mehrmals versucht – mit Löschen und 1 Tag Wartezeit dazwischen – immer mit dem selben Ergebnis. Eine Recherche ergab bisher keinen Lösungsansatz. Kennt jemand das Problem resp. weiss Abhilfe?

    Liebe Grüsse
    Martino

    PS: SF und Modul up to date; Produktivumgebung des ACME-Service gewählt

  5. #35
    STARFACE Expert
    Benutzerbild von nucom
    Registriert seit
    11.12.2012
    Ort
    9443 Widnau
    Beiträge
    1.124

    Standard

    Halo eye

    Welche Challenge Art wurde gewählt?

    HTTP/DNS?

    Hast du oben schon mal den Datensatz gelöscht?" (Datensatz löschen)
    Bitte vorher unten die Häkchen bei "Akzeptiere ACME EULA, Challenge Erfüllt" entfernen.

    Danach nochmals versuchen.

    Dieser Fehler kann auch durch einen Any DNS Eintrag (*.eye.ch) verursacht werden.

    MfG

    Fabian
    Modulhersteller aus der Schweiz
    __________________________________________________ ________
    STARFACE Excellence Partner: Info | Certified Module Creator Kontakt

  6. #36
    STARFACE User

    Registriert seit
    21.01.2016
    Beiträge
    9

    Standard

    Hallo Fabian

    Die Challenge ging via DNS und die hat problemlos geklappt. Eine Wildcard für die Domain benutzen wir in unserem Zonenfile nicht. Datensatz löschen auch schon versucht; allerdings ohne die beiden Checkboxen abzuhaken – das haben wir nun gemacht.
    Nach einem erneuten Versuch warf er nun zuerst eine nonce Exception (das wurde ja früher im Thread schon mal besprochen) und hat danach wieder die Challenge erfüllt, das CSR erstellt aber beim selben Punkt wie im Eingangspost erwähnt ("Trying to Request Certificate") die selbe Exception geworfen:
    Code:
    [2018-02-08 12:54:49,250] DEBUG [RequestCertificate] org.shredzone.acme4j.exception.AcmeUnauthorizedException: Error creating new cert :: authorizations for these names not found or expired: starface.eye.ch
    Erneuter Versuch nach Speichern: nonce-Exception kommt nicht mehr aber die erwähnte unauthorized-Exception bleibt hartnäckig.

    Gruss
    Martino

  7. #37
    STARFACE Expert
    Benutzerbild von nucom
    Registriert seit
    11.12.2012
    Ort
    9443 Widnau
    Beiträge
    1.124

    Standard

    Hallo Martino

    Ich konnte es auf meiner 6.4.3.34 nicht nachvollziehen. Dort geht es nach wie vor einwandfrei.

    Hatte sich die Challenge nach dem Löschen des Datensatzes geändert?

    Könntest du Prüfen, ob vor und hinter den Feldern im Modul keine Leerzeichen sind?

    Wenn ich die Fehlerhaften Zeilen zurückverfolge:

    Code:
    conn.sendSignedRequest(getSession().resourceUrl(Resource.NEW_CERT), claims, getSession()); (244)
    int rc = conn.accept(HttpURLConnection.HTTP_CREATED, HttpURLConnection.HTTP_ACCEPTED); (245)
    Den Fehler gibt wirklich der Let's Encrypt Server zirück, die Oben bei 2.Authorisierung eingegebene Domäne stimmt nicht mit der bei 3. Zertifikat Anfordern eingegebenen Zertifikatsdomäne überein. (Oder ist auch keine Überliegende Domäne)

    MfG

    Fabian
    Modulhersteller aus der Schweiz
    __________________________________________________ ________
    STARFACE Excellence Partner: Info | Certified Module Creator Kontakt

  8. #38
    STARFACE User

    Registriert seit
    21.01.2016
    Beiträge
    9

    Standard

    Hallo Fabian

    Danke für deine Mühe! Authorisierungs- und Zertifikats-Domänen stimmen überein (habs im Browser mit dem Inspector nachkontrolliert). Die Challenge hat sich nicht geändert (sie wird ja auch stets erfüllt). Wir hatten testweise das Modul auch deinstalliert, Starface neu gestartet und das Modul wieder eingerichtet und konfiguriert. Nachdem noch eine Exception "No registration exists matching provided key" geworfen wurde, hatten wir auch noch eine neue E-Mail-Addresse für den Account verwendet. Danach waren wir wieder am selben Ort:

    Code:
    [2018-02-14 14:55:26,484] DEBUG [CreateChallenge] Trying to Authorize Domain: starface.eye.ch 
    [2018-02-14 14:55:28,099] DEBUG [TriggerChallenge] Triggering Challenge 
    [2018-02-14 14:55:29,549] DEBUG [TriggerChallenge] Challenge Succeeded! 
    [2018-02-14 14:55:29,551] DEBUG [RequestCertificate] Trying to Request a Certificate 
    [2018-02-14 14:55:29,551] DEBUG [RequestCertificate] Creating new Keystore 
    [2018-02-14 14:55:29,552] DEBUG [RequestCertificate] Creating new Private Key 
    [2018-02-14 14:56:00,835] DEBUG [RequestCertificate] Loading existing KeyPair from: /home/starface/letsencrypt/CertPK.pem 
    [2018-02-14 14:56:00,838] DEBUG [RequestCertificate] KeyPair Successfully loaded. 
    [2018-02-14 14:56:00,838] DEBUG [RequestCertificate] Loading CSR 
    [2018-02-14 14:56:00,839] DEBUG [RequestCertificate] Creating CSR: 
    [2018-02-14 14:56:00,839] DEBUG [RequestCertificate] Domain:starface.eye.ch 
    [2018-02-14 14:56:00,839] DEBUG [RequestCertificate] Country:CH 
    [2018-02-14 14:56:00,839] DEBUG [RequestCertificate] Organization: EYE Communications AG 
    [2018-02-14 14:56:00,839] DEBUG [RequestCertificate] OrganizationUnit:IT 
    [2018-02-14 14:56:00,839] DEBUG [RequestCertificate] State:Basel-Landschaft 
    [2018-02-14 14:56:01,933] DEBUG [RequestCertificate] Trying to Request Certificate 
    [2018-02-14 14:56:03,664] DEBUG [RequestCertificate] org.shredzone.acme4j.exception.AcmeUnauthorizedException: Error creating new cert :: authorizations for these names not found or expired: starface.eye.ch
    Gruss,
    Martino

  9. #39
    STARFACE Expert

    Registriert seit
    23.03.2015
    Beiträge
    337

    Daumen hoch

    Hallo allerseits!

    Erstmal auch von mir vielen Dank für das tolle Modul!

    Ich habe jetzt so ziemlich alles von mir in diverse Clouds verlagert, so auch meine STARFACE.

    Die ist unter

    https://meinname.starface-cloud.com/

    erreichbar.

    Natürlich habe ich auch eine Domain, die heisst

    https://sfcloud.meinefirma.de

    und witzigerweise ziehe ich gerade mit allen meinen Domains von Host Europe zu All-Inkl, die haben ja Let's Encrypt kostenlos integriert, das nutze ich auch schon massiv.

    Gibt es da irgendeine Lösung, dass die Konferenzseite der STARFACE ohne Interaktion Grün wird beim Aufruf durch Kunden?

    Eine Umleitung und einen CNAME-Eintrag habe ich aus Spaß auch schon mal gemacht... Bringt ja aber nichts. Vor allem würde ich auch gerne noch HSTS aktivieren.

    Was natürlich unbedingt nötig ist: Dass STARFACE das in der 6.5 integriert... Oder wartet STARFACE noch auf deren Wildcard-Zertifikate?

    Danke und viele Grüße aus Köln,

    d i r k
    Geändert von d i r k (13.03.2018 um 20:45 Uhr)

  10. #40
    STARFACE Admin
    Benutzerbild von mfehleisen
    Registriert seit
    14.02.2007
    Ort
    71364 Winnenden
    Beiträge
    100

    Standard

    Hi in die Runde,

    habe das Modul gerade bei unserer 6.5er Beta getestet - läuft soweit! - was etwas schade ist (aber das ist wohl bei lets encrypt so) diese Geschichte mit 3 Monaten "Laufzeit" - dann schauen wir mal, aber die Automatische, Monatliche Aktualisierung sollte ja funktionieren ;-)

    Wäre schön, wenn Starface das Thema in eine der kommenden Versionen integrieren würde - AVM macht es mit den Fritzboxen gerade ja auch (aktuelle Labor-Firmware).

    -Matthias
    Starface Excellence Partner & plusnet Exklusive Partner
    Kontakt: 07141-23999-0 (Telefon) / -99 (Fax) / URL: www.ucs-team.de / Mail: info@ucs-team.de
    NGN-Pakete für Starface - www.NGNbundle.de - auch SIP-Trunks für Starface Cloud!

  11. #41
    STARFACE User

    Registriert seit
    25.03.2017
    Beiträge
    7

    Standard

    Doppelpost :-(
    Geändert von HabibA (06.05.2018 um 08:08 Uhr)

  12. #42
    STARFACE User

    Registriert seit
    25.03.2017
    Beiträge
    7

    Standard

    Vielen Dank erstmal für das Modul :-)
    Ich hab es zum Test erstmal in unserer Werkstatt Anlage ausprobiert. Das war bereits letzten Donnerstag, also vor 3 Tagen und seitdem warte ich auf "[2018-05-06 07:54:04,603] DEBUG [Config] Waiting for Pending Challenge "

    Was ich gemacht hab:
    ich hab die DNS pbx.lan.meinefirma.de registriert und die acme txt _acme-challenge.pbx.lan.meinefirma.de erstellt. Die Abfrage des Eintrages sieht wiefolgt aus:

    ; <<>> DiG 9.10.6 <<>> any _acme-challenge.pbx.lan.meinefirma.de
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27519
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4000
    ;; QUESTION SECTION:
    ;_acme-challenge.pbx.lan.meinefirma.de. IN ANY

    ;; ANSWER SECTION:
    _acme-challenge.pbx.lan.meinefirma.de. 59 IN TXT "I_RN6iUXBrurEwjN1y0ZpqeJ5Ga7edC2kXShpbepszA"

    ;; Query time: 29 msec
    ;; SERVER: 192.168.100.14#53(192.168.100.14)
    ;; WHEN: Sun May 06 07:56:29 CEST 2018
    ;; MSG SIZE rcvd: 124
    Der String/TXT entspricht dem in der Konfigurationsseite.

    Edit: Ach und die Ausgabe der Konsole:

    [2018-05-06 07:52:47,681] DEBUG [Moduleupdater.Update] Searching for Version: 6.4.3.34
    [2018-05-06 07:52:47,681] DEBUG [Moduleupdater.Update] 433
    [2018-05-06 07:52:47,681] DEBUG [Moduleupdater.Update] 6.4.3
    [2018-05-06 07:52:47,681] DEBUG [Moduleupdater.Update] letsencrypt/6.4.3/neuste.sfm
    [2018-05-06 07:52:47,681] DEBUG [Moduleupdater.Update] 35fdb39e9f9e1b161eae100dd593ed1c
    [2018-05-06 07:52:47,681] DEBUG [Moduleupdater.Update] Searching for Version: 6.4.3
    [2018-05-06 07:52:47,681] DEBUG [Moduleupdater.Update] 433
    [2018-05-06 07:52:47,681] DEBUG [Moduleupdater.Update] 6.4.3
    [2018-05-06 07:52:47,682] DEBUG [Moduleupdater.Update] letsencrypt/6.4.3/neuste.sfm
    [2018-05-06 07:52:47,682] DEBUG [Moduleupdater.Update] 35fdb39e9f9e1b161eae100dd593ed1c
    [2018-05-06 07:52:47,682] DEBUG [Moduleupdater.Update] Finding out if Update is Required
    [2018-05-06 07:52:47,682] DEBUG [Moduleupdater.Update] Newest Version is: 433
    [2018-05-06 07:52:47,682] DEBUG [Moduleupdater.Update] 433 == 433
    [2018-05-06 07:52:47,682] DEBUG [Moduleupdater.Update] No Update Required
    [2018-05-06 07:52:47,682] DEBUG [Update] false
    [2018-05-06 07:52:47,683] DEBUG [Update]
    [2018-05-06 07:52:47,683] DEBUG [CheckLicense] Prüfe Lizenz...
    [2018-05-06 07:52:47,684] DEBUG [isLicenseactive] isLicenseactive: true
    [2018-05-06 07:52:47,685] DEBUG [CheckLicense] Lizenz ist bereits aktiv. Prüfe, wieviele Tage seit letzter Validierung vergangen sind.
    [2018-05-06 07:52:47,690] DEBUG [CheckLicense] Range: 4/6/18-5/6/18
    [2018-05-06 07:52:47,692] DEBUG [CheckLicense] Lizenz wird noch nicht überprüft.
    [2018-05-06 07:52:47,693] DEBUG [isLicenseactive] isLicenseactive: true
    [2018-05-06 07:52:47,693] DEBUG [Config] Starte ACME Client..
    [2018-05-06 07:52:47,694] DEBUG [Config] Try 1.0 / 10
    [2018-05-06 07:52:47,695] DEBUG [RegisterSession] Generating new KeyPair
    [2018-05-06 07:53:59,389] DEBUG [RegisterSession] Saving Session PrivateKey to: /home/starface/letsencrypt/SessionPK.pem
    [2018-05-06 07:53:59,449] DEBUG [RegisterACMEAccount] Trying to Register: info@meinefirma.de
    [2018-05-06 07:54:01,735] DEBUG [RegisterACMEAccount] Registration Successful.
    [2018-05-06 07:54:01,736] DEBUG [RegisterACMEAccount] Accepting Agreement
    [2018-05-06 07:54:03,277] DEBUG [RegisterACMEAccount] Accepted Agreement
    [2018-05-06 07:54:03,277] DEBUG [RegisterACMEAccount] Saving RegistrationURI
    [2018-05-06 07:54:03,279] DEBUG [CreateChallenge] Trying to Authorize Domain: pbx.lan.meinefirma.de
    [2018-05-06 07:54:04,603] DEBUG [Config] Waiting for Pending Challenge
    Jetzt hab ich die ganze Konfiguration nochmal neu erstellt und gem. obiger Anleitung wieder neu beantragt, aber es will einfach nicht gelingen. Habt ihr da einen Tip für mich?

    LG
    Habib
    Geändert von HabibA (06.05.2018 um 08:07 Uhr)

  13. #43
    STARFACE User

    Registriert seit
    25.03.2017
    Beiträge
    7

    Daumen hoch

    hm... ich weiss nicht wie ich das Überlesen konnte. Wenn ich das richtig verstanden habe nun, dann soll man den Hacken Challenge erfüllt setzen, nachdem man alle Voraussetzungen geschaffen hat? Erst dann wird die Anfrage eingereicht?

    Edit: Ich denke ich habe nun das Problem erkannt. Nachdem ich erstmalig den Hacken Challenge erfüllt gesetzt hatte, einen INVALID kassiert hab und alles nochmal gelöscht habe bekomme ich beim Speichern immer einen neuen TXT String, was ich vorher nicht hatte. Jetzt muss ich noch meine viel zu lange Zeit der Gültigkeit abwarten bis ich den nächsten String eintragen kann. Aber ich glaube dann hab ich es geschafft :-)

    Hat natürllich geklappt. Super Arbeit Danke
    Geändert von HabibA (06.05.2018 um 09:45 Uhr)

  14. #44
    STARFACE Expert

    Registriert seit
    23.03.2015
    Beiträge
    337

    Standard

    So, ich habe es in einem weiteren Anlauf endlich geschafft, Let's Encrypt auf einer STARFACE Cloud 6.5 hinzubekommen...

    Vielen Dank noch mal für das tolle Modul!

    Übrigens habe ich auch wie HabibA heute bestimmt gefühlte dreißig Mal den txt-Eintrag meiner Subdomain geändert, weil ich das System auch nicht direkt auf Anhieb verstanden habe...

    Grüße

    d i r k
    Geändert von d i r k (09.06.2018 um 14:20 Uhr)

  15. #45
    STARFACE User

    Registriert seit
    09.03.2011
    Beiträge
    7

    Standard

    Moin Moin...
    Klappt soweit alles super! Zertifikat wird auch ausgestellt...
    Das Zertifikat wirft mir allerdings aus:

    Certificate - Subject Alternative Name missing
    The certificate for this site does not contain a Subject Alternative Name extension containing a domain name or IP address.

    Certificate - missing
    This site is missing a valid, trusted certificate (net::ERR_CERT_AUTHORITY_INVALID).

    Jemand eine Idee?

Ähnliche Themen

  1. [Spielzeug] Update GUI List/Map
    Von nucom im Forum Community Modules
    Antworten: 0
    Letzter Beitrag: 16.06.2017, 13:31
  2. [Spielzeug] Module Self-Updater
    Von nucom im Forum Community Modules
    Antworten: 8
    Letzter Beitrag: 17.05.2017, 08:48
  3. Let's Encrypt - automatisiert für SF6
    Von hyanak im Forum STARFACE Einrichtung & Administration
    Antworten: 2
    Letzter Beitrag: 17.02.2017, 09:26
  4. (Beta) Let's Encrypt Cert Helper (v38)
    Von DerGerät im Forum Module
    Antworten: 9
    Letzter Beitrag: 08.02.2017, 10:39
  5. HttpGetValue - Let's Encrypt SSL
    Von hyanak im Forum Modul-Designer
    Antworten: 3
    Letzter Beitrag: 27.04.2016, 10:10

Lesezeichen

Forumregeln

  • Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
  • Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
  • Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
  • Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.
  •