Seite 6 von 6 ErsteErste ... 456
Zeige Ergebnis 76 bis 90 von 90

Thema: SIP Trunk der Telekom 15 Minuten Problem

  1. #76
    STARFACE User

    Registriert seit
    23.12.2014
    Beiträge
    13

    Standard

    Hallo Zusammen,

    also das Thema ist mehr als frustrierend, da man von keiner Seite vernünftige Unterstützung erhält.
    Lancom sagt, man solle de VCM nehmen und veweist ansonsten an Starface. Starface-Partner sagt, es läuft nur mit dem Lancom VCM stabil.
    Die Telekom bietet nur Unterstützung an, wenn man den Router auch von der Telekom mitbestellt. War im Angebot des Sip-Trunks zwar enthalten,
    da wir aber bereits einen Lancom an dieser Leitung einsetzten, hatte ich das natürlich gestrichen.
    Als Alternative bieten sie einem einen Telekom TK-Anlage an !!

    Momentan habe ich den SIP-Trunk nur mit dem VCM von Lancom zum Laufen gebracht, ein- wie ausgehend.
    Nachtteil ist allerdings, dass wir jetzt wieder eine 0 vorwählen müssen, sonst nimmt der Lancom das Gespräch nicht an.

    Es wurde bisher auch nur eine unsere Nebennummern mit 2 Kanälen umgestellt, der Hauptanschluss mit 6 ISDN-Leitungen wird uns zum Glück erst Ende Dezember abgeschaltet.
    Ob der auch nach 15 min. stabil ist, kann ich noch nicht sagen, da eingehend nicht viele Gespräche ankommen (4-6 pro Tag) und ausgehend kann ich die Leitung noch nicht verwenden, da wir für die ISDN-Leitungen keine 0 vorwählen müssen.

    Am Telekom SIP-Trunk kann es m.E. auch nicht alleine liegen, denn andere Geräte oder Anlagen kommen damit problemlos klar.
    Wir haben bereits mehrere SIP-Trunks über FritzBoxen angebunden, und auch mit einer Siemens/OpenStage HiPath Anlage läuft die Leitung mehr als stabil.
    Die HiPath Anlage steht auch hinter einem Lancom 1781VA-4G, und hier mussten wir nicht mal ein PortForwarding einrichten, lediglich ausgehende Ports freischalten.

    Wäre für jede weitere Hilfe dankbar.

    Viele Grüße
    Günter

  2. #77
    STARFACE User

    Registriert seit
    22.02.2016
    Beiträge
    38

    Standard

    Zitat Zitat von cargotrans Beitrag anzeigen
    Hallo Zusammen, hallo Norman,

    darf ich mich an dieses Thema noch anhängen, denn wir stehen aktuell vor dem gleichen Problem.
    Starface Advanced an einen LANCOM 1781 Router mit Telekom DeutschlandLAN SIP-Trunk.

    Ich hatte mich im Vorfeld bereits bei LANCOM über die Konstellation erkundigt, und die schickten mir folgende Antwort:

    Generell empfehlen wir den LANCOM als Session Border Controller zu nutzen und den Voice-Call Manager zu verwenden. Diese Option ist beim LANCOM 1781VA-4G normalerweise nicht standardmäßig vorhanden und kann nachgerüstet werden:

    Nähere Informationen zur All-IP Option finden Sie unter folgendem Link:
    https://www.lancom-systems.de/produk...all-ip-option/

    Alternativ besteht die Möglichkeit, dass sich die Telefonanlage direkt beim Provider registriert. Hierfür kann SIP-ALG zur NAT-Überwindung eingesetzt werden. Wenn SIP-ALG auf dem LANCOM aktiviert ist, gelten folgende Bedingungen:

    Der Voice-Call Manager auf dem LANCOM (wenn vorhanden) darf nicht aktiviert sein
    Es darf kein Port-Forwarding im Hinblick auf VoiP eingerichtet sein
    Es dürfen keine Quality of Service Regeln für VoiP konfiguriert sein
    Auf der Telefonanlage darf kein STUN-Server aktiviert sein

    Wenn Sie weder SIP-ALG noch den Voice-Call Manager verwenden möchten, können Sie auf Ihrer Telefonanlage den STUN-Server aktivieren und die entsprechenden SIP- bzw. RTP-Ports auf die Telefonanlage weiterleiten, sofern vorhanden.

    Die genutzten Ports erfragen Sie bitte beim Provider bzw. beim Hersteller der Telefonanlage.


    Ich bin bereits alle Optionen durch, bei mir funktioniert es weder mit dem SIP-ALG, noch mit Port-Forwarding und auch den Lösungen aus dem Fehlerleitfaden von Starface.
    Die Registrierung funktioniert einmalig, so bald ich jedoch versuche auf der Leitung rein zu rufen, fällt die Registrierung aus.

    Norman, kannst Du mir bitte kurz notieren, wie du den SIP-Trunk der Telekom zu Laufen gebracht hast, das wäre echt nett.
    Port-Forwarding hatte ich allerdings gem. unserem Partner nur für die Ports 5060-5061 (UDP/TCP), sowie für die Ports 10000-20000 (UDP) eingerichtet. In den vorherigen Beiträgen erwähnst Du noch die Ports 5060-5069.
    Und welche Lösungen im SIP-Profil geändert werden müssen (Fehlerleitfaden), Punkt 1 bis 5, oder nur einzelne?

    Unser Partner meinte, mit dem Lancom funktioniert es angeblich nur mit dem Call-Manager von Lancom, also der direkten Anbindung über den Lancom-Router.

    Viele Grüße

    Günter
    Hallo Günter,

    mache ich doch gerne.
    Habe von der Starface nochmal die Leitungskonfig angehängt. SIP-ALG ist bei uns ausgeschaltet. Session Timer = Refuse wurde noch eingeschaltet, um das 15 Minuten Problem zu lösen.
    Da das mit dem Port 5060-5069 hat ein Telekom Mitarbeiter durchgeführt, keine Ahnung was das bewirken soll.
    Die oben genannten Ports sind in Ordnung. SIP 5060-5061 RTP 10000-20000 UTP.
    Wir zumindest eine halbwegs fast stabile Verbindung. Gespräche gehen immer noch verloren. Es gibt noch einen anderen Verdacht, in einem Foren Beitrag wird über eine DLINK DGS1210-24p Switch in Verbindung mit YEALINK T46 G gesprochen, diese Konstellation haben wir auch.
    Da wir dort die meisten Gesprächsabbrüche haben, es gibt anscheinend ein Problem mit dem LLDP und YEALINK T46G. Wir haben noch kleine DLINK DGS1210-10p im Einsatz, dort ist es nicht so häufig.
    Der Leitfaden für den Telekomanschluss von Starface ist wichtig, alles dort umzusetzen.
    Damit kannst du mit SSH mal draufgehen und schauen,was die Registrierung so macht.

    Asterisk Telefonanlagenkern

    Command ---.>rasterisk
    sip show registry

    Debuggen
    Sip set debug on
    Log Datei befindet sich in /var/log/asterisk/full
    Sip set debug off – Debug aus.

    Nicht erforderlich nur, wenn du es mal brauchen solltest.
    Asterisk neu starten
    /etc/init.d/asterisk reload

    Ich hoffe, das hilft Dir weiter.
    Viele Grüße Norman
    Angehängte Grafiken Angehängte Grafiken

  3. #78
    STARFACE User

    Registriert seit
    22.02.2016
    Beiträge
    38

    Standard

    Zitat Zitat von cargotrans Beitrag anzeigen
    Hallo Zusammen, hallo Norman,

    darf ich mich an dieses Thema noch anhängen, denn wir stehen aktuell vor dem gleichen Problem.
    Starface Advanced an einen LANCOM 1781 Router mit Telekom DeutschlandLAN SIP-Trunk.

    Ich hatte mich im Vorfeld bereits bei LANCOM über die Konstellation erkundigt, und die schickten mir folgende Antwort:

    Generell empfehlen wir den LANCOM als Session Border Controller zu nutzen und den Voice-Call Manager zu verwenden. Diese Option ist beim LANCOM 1781VA-4G normalerweise nicht standardmäßig vorhanden und kann nachgerüstet werden:

    Nähere Informationen zur All-IP Option finden Sie unter folgendem Link:
    https://www.lancom-systems.de/produk...all-ip-option/

    Alternativ besteht die Möglichkeit, dass sich die Telefonanlage direkt beim Provider registriert. Hierfür kann SIP-ALG zur NAT-Überwindung eingesetzt werden. Wenn SIP-ALG auf dem LANCOM aktiviert ist, gelten folgende Bedingungen:

    Der Voice-Call Manager auf dem LANCOM (wenn vorhanden) darf nicht aktiviert sein
    Es darf kein Port-Forwarding im Hinblick auf VoiP eingerichtet sein
    Es dürfen keine Quality of Service Regeln für VoiP konfiguriert sein
    Auf der Telefonanlage darf kein STUN-Server aktiviert sein

    Wenn Sie weder SIP-ALG noch den Voice-Call Manager verwenden möchten, können Sie auf Ihrer Telefonanlage den STUN-Server aktivieren und die entsprechenden SIP- bzw. RTP-Ports auf die Telefonanlage weiterleiten, sofern vorhanden.

    Die genutzten Ports erfragen Sie bitte beim Provider bzw. beim Hersteller der Telefonanlage.


    Ich bin bereits alle Optionen durch, bei mir funktioniert es weder mit dem SIP-ALG, noch mit Port-Forwarding und auch den Lösungen aus dem Fehlerleitfaden von Starface.
    Die Registrierung funktioniert einmalig, so bald ich jedoch versuche auf der Leitung rein zu rufen, fällt die Registrierung aus.

    Norman, kannst Du mir bitte kurz notieren, wie du den SIP-Trunk der Telekom zu Laufen gebracht hast, das wäre echt nett.
    Port-Forwarding hatte ich allerdings gem. unserem Partner nur für die Ports 5060-5061 (UDP/TCP), sowie für die Ports 10000-20000 (UDP) eingerichtet. In den vorherigen Beiträgen erwähnst Du noch die Ports 5060-5069.
    Und welche Lösungen im SIP-Profil geändert werden müssen (Fehlerleitfaden), Punkt 1 bis 5, oder nur einzelne?

    Unser Partner meinte, mit dem Lancom funktioniert es angeblich nur mit dem Call-Manager von Lancom, also der direkten Anbindung über den Lancom-Router.

    Viele Grüße

    Günter
    Hallo Günter,

    mache ich doch gerne.
    Habe von der Starface nochmal die Leitungskonfig angehängt. SIP-ALG ist bei uns ausgeschaltet. Session Timer = Refuse wurde noch eingeschaltet, um das 15 Minuten Problem zu lösen.
    Da das mit dem Port 5060-5069 hat ein Telekom Mitarbeiter durchgeführt, keine Ahnung was das bewirken soll.
    Die oben genannten Ports sind in Ordnung. SIP 5060-5061 RTP 10000-20000 UTP.
    Wir zumindest eine halbwegs fast stabile Verbindung. Gespräche gehen immer noch verloren. Es gibt noch einen anderen Verdacht, in einem Foren Beitrag wird über eine DLINK DGS1210-24p Switch in Verbindung mit YEALINK T46 G gesprochen, diese Konstellation haben wir auch.
    Da wir dort die meisten Gesprächsabbrüche haben, es gibt anscheinend ein Problem mit dem LLDP und YEALINK T46G. Wir haben noch kleine DLINK DGS1210-10p im Einsatz, dort ist es nicht so häufig.
    Der Leitfaden für den Telekomanschluss von Starface ist wichtig, alles dort umzusetzen.
    Damit kannst du mit SSH mal draufgehen und schauen,was die Registrierung so macht.

    Asterisk Telefonanlagenkern

    Command ---.>rasterisk
    sip show registry

    Debuggen
    Sip set debug on
    Log Datei befindet sich in /var/log/asterisk/full
    Sip set debug off – Debug aus.

    Nicht erforderlich nur, wenn du es mal brauchen solltest.
    Asterisk neu starten
    /etc/init.d/asterisk reload


    Ah, jetzt noch ganz wichtig. Qualify = YES sonst fliegt die Registrierung nach 10 Minuten raus.

    Ich hoffe, das hilft Dir weiter.
    Viele Grüße Norman

  4. #79
    STARFACE User

    Registriert seit
    28.09.2018
    Beiträge
    42

    Standard

    Hallo,

    wir sind auch zum Teil von dem 15 Minuten problem betroffen.
    Wir haben die Starface Compact 6.5.1.9 mit Yealink T46S Telefonen und den Telekom SIP Trunk.

    Problem: hin und wieder werden Telefonate exakt bei 15 Minuten getrennt. Andere Kollegin hat gemeint bei ihr wäre das auch schon mal zu einem früherern Zeitpunkt passiert
    Andere Kollegin meinte wenn sie eine Private Festnetznummer anruft (ins 1&1 Netz) klingt das Gespräch gut - anders wenn sie angerufen wird klingt es verzerrt zum Teil.

    Bin mit meinen Latein so ein bisschen am Ende - muss ich mich abfinden das die Starface erst im Unterbau "geupdated" werden muss damit der Telekom SIP Trunk ordentlich funktioniert oder muss ich den SIP Anbieter wechseln? (ist nur schlecht weil die Laufzeit noch seeehr lange ist)

    session-timer=refuse" in der sip_custom.conf bewirkt bei uns das zuverlässig jedes Gespräch nach 15 Minuten getrennt wird - > habe ich also wieder rausgenommen.

    Starface ist hinter einer Kerio Control
    Server steht auf Hinter NAT auf JA
    Externe feste IP ist drin (automatisch erkannt)
    DNS1 und 2 sind von unserer AD
    Gateway ist die Kerio Control Firewall

    Portfreigaben:
    TPC und UDP 5060 sind auf die IP eingehend begrenzt : 217.0.0.0/13
    TCP und UDP 5061
    und
    UDP 10.000 bis 20.000


    die Registrierung fliegt mir sogut wie nie raus - nur wenn die Telekom mal wieder an den Servern rumspielt.
    Habt ihr vllt noch ideen?

    das Leitungsprofil ist bei mir noch Original wie es die Starface anbietet.

    LG

  5. #80
    STARFACE User

    Registriert seit
    22.02.2016
    Beiträge
    38

    Standard

    Hallo Jeri,
    ich kann Dir sagen, Deine RTP Weiterleitung ist nicht ganz richtig.
    Du musst die Ports vom 10000-65535 UDP öffnen. Gleicher Fehler wie bei uns, Gespräche werden vom Audio ausgehend einfach unterbrochen. Schau dir die Porttabelle der Starface mal an. https://knowledge.starface.de/pages/...ageId=17269634 --> ausgehendes RTP
    Trag das mal in Deine Firewall Forward ein, da wird es gehen
    session-timer=refuse haben wir drin, sonst geht es nicht.
    Oki, ich sehe du hast die neuste Firmware, ich hab noch die 6.4.3.39. Vielleicht ist das mit dem Session Timer in der neuen Firmware gelöst. Qualifiy = yes ist wichtig , wenn Du Nat hast. Sonst geht die Registrierung der Leitung raus.


    Leitfaden: https://knowledge.starface.de/displa...die+Verbindung
    Lösung 2 Verschlüsselung mal auf NO stellen. Habe erfahren, das die Version 11 vom Asterisk noch nicht richtig mit der Verschlüsselung zusammenarbeitet. Wird irgendwann mal behoben, leider.

    Gruß Norman
    Geändert von normi76 (09.11.2018 um 13:18 Uhr)

  6. #81
    STARFACE User

    Registriert seit
    28.09.2018
    Beiträge
    42

    Standard

    danke dir

    okay ich habe gedacht das ausgehendes RTP von der Starface initiiert wird und dadurch kein Portforwading brauch - aber wenn du da positive Erfahrungen gemacht hast stell ich das mal ein.

    was meinst du mit Registrierung der Leitung? wegen Qualify - bisher sind wir nur aus der Leitung geflogen wenn das Internet mal weg ist...

    Verschlüsselung auf NO? Wirklich???

  7. #82
    STARFACE User

    Registriert seit
    22.02.2016
    Beiträge
    38

    Standard

    Hi, Qualify brauchst du, wenn es hinter NAT ist. Bei uns war immer nach 10 Minuten die Leitung tot. Verschlüsselung kannst mal probieren, ob es geht. Ist natürlich immer besser. Ich hab mich am Leitfaden durchgearbeitet um ein stabiles Ergebnis zu bekommen. Du hast Recht normalerweise wird der ausgehende Traffic automatisch durch den Router gehändelt. Wenn ich bei 20000 aufhöre, dann haben die Benutzer Abbrüche das Kunde uns nicht mehr hört. Muss man ausprobieren. Gruß Norman
    Geändert von normi76 (09.11.2018 um 21:12 Uhr)

  8. #83
    STARFACE User

    Registriert seit
    28.09.2018
    Beiträge
    42

    Standard

    Guten Morgen,

    also alle Ports über 20.000 weiterzuleiten denke ich - ist nicht ganz optimal. Da die Ports ja auch von anderen Diensten dynamisch benutzt werden.

    Hat jemand noch andere Idee? Wie gesagt - Qualify ist aus und hinter NAT - habe aber keine Registrierungsprobleme...
    Verschlüsselung auf NO würde ich ungern machen - gibts da ne quelle zu der Aussage von normi76

    Oder gibt es Infos das die Starface 6.6 hier eine Lösung bringt?

  9. #84
    STARFACE Admin

    Registriert seit
    24.04.2015
    Beiträge
    144

    Standard

    Moin,

    versuche mal eingehend auf die Starface UDP 10000-20000 (Portweiterleitung). Ausgehend von der Starface Richtung Internet UDP 1-65535.

    Gruß

    Looser

  10. #85
    STARFACE User

    Registriert seit
    28.09.2018
    Beiträge
    42

    Standard

    aktuell ist unserer Firewall so eingestellt das die Starface ausgehend jeden Dienst / Port benutzen darf.

  11. #86
    STARFACE User

    Registriert seit
    22.02.2016
    Beiträge
    38

    Standard

    Hallo Jeri,
    hier mal ein Link zu Qualify

    https://www.voip-info.org/asterisk-sip-qualify

    der Leitfaden von Starface für den Telekom SIP Trunk zeigt das mit der Verschlüsselung, in Lösung Nummer 2. Ich habe das direkt von der Firma Starface, dass die Verschlüsselung Probleme machen kann und eine neue Asterisk Version soll das beheben.
    Da ich eine Portweiterleitung vom LANCOM Router drin hab und die Ports 20000-65535 freigegeben habe, haben wir keine Ausfälle mehr. Läuft TOP.
    Gruß Norman

  12. #87
    STARFACE User

    Registriert seit
    28.09.2018
    Beiträge
    42

    Standard

    Hi leute,

    also mit den Änderungen wo empfolen werden habe ich das 15 Minuten Problem weg :-) dafür hab ich nun ab Minute 30 nur noch Stille am Telefon (Verbindung wird weiter aufrechterhalten) - ob man mich noch hört weiß ich leider noch nicht.

    So sieht meine Leitungskonfig aus:

    2019-02-05 12_48_30-Window.png

    Hat jemand noch nen Tipp für mich?

    EDIT: liegt das vllt daran das die Encryption auf no ist und der Transport noch auf TLS steht?

  13. #88
    STARFACE User

    Registriert seit
    28.09.2018
    Beiträge
    42

    Standard

    anscheiend hab ich es nun gelöst mit Transport auf TCP und Port 5060..

    hatte heute das erste Gespräch mit mehr als 30 Minuten und es lief ohne Probleme.. Ich beobachte weiter.

  14. #89
    STARFACE Crew

    Registriert seit
    30.11.2015
    Beiträge
    18

    Standard

    Hallo Jeri,

    schau dir mal folgenden KB Eintrag an:

    https://knowledge.starface.de/displa...die+Verbindung

    Den Punk 2 und 3 hast du bereits umgesetzt. Bitte prüfe noch Punkt 1 und 5.

    Des Weiteren sollten die Ports 5060,5061 TCP sowie 10.000 - 20.000 via SNAT oder DNAT erreichbar sein.

    Eine Liste findest du auf folgender Seite:

    https://knowledge.starface.de/pages/...ageId=23988405

    Grüße,

    Jürgen

  15. #90
    STARFACE User

    Registriert seit
    28.09.2018
    Beiträge
    42

    Standard

    Hallo Jürgen,

    ja ich habe Schitt 1-4 gemacht und seitdem sieht es gut aus
    bei der Firewall passt auch alles.

    Danke dir

Ähnliche Themen

  1. Antworten: 70
    Letzter Beitrag: 11.07.2018, 17:55
  2. Telekom Sip-Trunk an Telekom-Lancom
    Von Fragan im Forum Leitungen SIP, NGN, ALL-IP
    Antworten: 2
    Letzter Beitrag: 30.01.2018, 14:32
  3. Telekom SIP-Trunk
    Von rvo im Forum Telekom ALL-IP
    Antworten: 2
    Letzter Beitrag: 05.12.2017, 10:07
  4. Telekom SIP Trunk
    Von SHS im Forum STARFACE Beta Archiv
    Antworten: 2
    Letzter Beitrag: 25.08.2017, 10:53
  5. Antworten: 7
    Letzter Beitrag: 10.01.2017, 18:07

Lesezeichen

Forumregeln

  • Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
  • Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
  • Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
  • Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.
  •