Zeige Ergebnis 1 bis 4 von 4

Thema: Webinterface Login http/https

  1. #1
    STARFACE Expert
    Benutzerbild von nucom
    Registriert seit
    11.12.2012
    Ort
    9443 Widnau
    Beiträge
    1.368

    Standard Webinterface Login http/https

    Hallo Miteinander

    Während ich etwas am Testen war bin ich über einen Bug(Oder Feature? Who knows...) im Webinterface gestolpert..

    Starface Version: 6.5.1.2
    Browser: Firefox Quantum 61.0 (x64)

    Folgendes Phänomen:

    Öffnet man die http, sowie https Version der Starface, und loggt sich via http ein, ist die https Version der Webseite automatisch eingeloggt, und man kann mit beiden, Versionen des Webinterfaces gleichzeitig Arbeiten.

    Wenn man sich zuerst mit https Anmeldet, dann kommt jedoch beim http eine Cookie Meldung.

    Bild: Login via http


    Bild: Login via https


    MfG

    Fabian
    Geändert von nucom (02.07.2018 um 15:01 Uhr)
    Modulhersteller aus der Schweiz
    __________________________________________________ ________
    STARFACE Excellence Partner: Info | Certified Module Creator Kontakt

  2. #2
    STARFACE Crew
    Benutzerbild von TomAnson
    Registriert seit
    11.11.2014
    Ort
    Karlsruhe
    Beiträge
    1.278

    Standard

    Thread nach "Beta Feedback" verschoben
    STARFACE Quality Assurance

    Bug gefunden? Hier melden!
    Featurewunsch oder Verbesserungsvorschlag? Trage es in unserem Feature Request Portal ein!
    Unsere Knowledge-Base für STARFACE findet ihr hier!

  3. #3
    STARFACE Crew
    Benutzerbild von jmeyer
    Registriert seit
    17.09.2013
    Ort
    Karlsruhe
    Beiträge
    357

    Standard

    Hallo,

    solange nicht final geklärt ist, ob es sich hier tatsächlich um einen Bug handelt, habe ich den [BUG] flag aus dem Thread Titel entfernt.

  4. #4
    STARFACE Expert
    Benutzerbild von fwolf
    Registriert seit
    28.12.2011
    Ort
    72622 Nürtingen
    Beiträge
    2.128

    Standard

    Das ist kein Bug sondern einfach ein RFC 2109-konformes Verhalten des Browsers in Bezug auf das Login-Cookie:
    https://www.w3.org/Protocols/rfc2109/rfc2109

    Das Cookie darf zunächst an den "Origin-Server" übermittelt werden -- unabhängig vom Protokoll (das ist nämlich nicht Teil der Spezifikation).

    Wenn das Attribut "Secure" nicht gesetzt wird (siehe Abschnitt 4.3.1 des RFC 2109), darf das Cookie über eine "unsichere" Verbindung gesendet werden.
    Und das Setzen des "Secure" Attributs ist bei HTTP-Verbindungen in modernen Browsern nicht mehr möglich (vgl. https://www.chromestatus.com/feature/4506322921848832 und https://developer.mozilla.org/en-US/...ocument/cookie).
    Geändert von fwolf (02.07.2018 um 19:45 Uhr)
    Grüße,
    Fabian

    STARFACE Excellence Partnerwww.fluxpunkt.deinfo@fluxpunkt.de

    Informationen über Fluxpunkt Module für STARFACE
    Produktupdates, Neuigkeiten & sonstiges gezwitscher: Fluxpunkt bei Twitter

Ähnliche Themen

  1. Weblink in Konferenzeinladung nur http, nicht https
    Von rapsac im Forum STARFACE Einrichtung & Administration
    Antworten: 6
    Letzter Beitrag: 22.11.2017, 07:33
  2. Wie in den Telefonen http auf https umstellen
    Von merylen im Forum STARFACE Einrichtung & Administration
    Antworten: 9
    Letzter Beitrag: 10.02.2010, 14:07
  3. https-Umleitung verhindert Autoprovisioning
    Von merylen im Forum Bugreports
    Antworten: 3
    Letzter Beitrag: 23.11.2009, 23:18
  4. Starface nur über https - update
    Von slu im Forum STARFACE Einrichtung & Administration
    Antworten: 1
    Letzter Beitrag: 19.11.2009, 15:00

Lesezeichen

Forumregeln

  • Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
  • Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
  • Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
  • Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.
  •