Zeige Ergebnis 1 bis 7 von 7

Thema: [Bug] Outlook Connector Exception

  1. #1
    STARFACE User

    Registriert seit
    01.09.2018
    Ort
    52353 Düren
    Beiträge
    11

    Standard [Bug] Outlook Connector Exception

    Kurze Zusammenfassung der Problematik:
    • Outlook Connector zeigt "UCC Client ist nicht verbunden" an, obwohl dieser einwandfrei funktioniert.
    • In Outlook wird kein Inhalt im Protokoll mehr angezeigt und es kann keine Telefonnummer gewählt werden.
    • Das Synchronisieren von Kontakten in Outlook funktioniert jedoch einwandfrei.
      (Anzeige "Kontakte sind synchronisiert, nach dem "Synchronisieren" gedrückt und ein Fortschritt angezeigt wurde)


    Bisher gefundenen Informationen:
    In der "%temp%\Starface GmbH\OutlookConnector\logs\OutlookConnector.log" wird nach dem Start von Outlook eine Exception angezeigt:

    System.Runtime.InteropServices.COMException (0x8004010F): 0x8004010f: MAPI_E_NOT_FOUND
    bei Microsoft.Office.Interop.Outlook.NameSpaceClass.Ge tFolderFromID(String EntryIDFolder, Object EntryIDStore)
    bei OutlookConnector.MapiFolderCache.Initialize(List`1 configuredContactFolders, List`1 configuredAddressLists)

    Sicherlich ist das nur eine Vermutung meinerseits, das dies das Problem ist. Jedoch tritt gleiche Meldung bei mehreren verschiedenen Systemen auf, die alle das gleiche Problem haben.
    Zwei von den betroffenen Rechnern haben Windows 10 (1809) und einer hat Windows 10 (1803), bei den weiteren betroffenen Rechner habe ich nicht mehr nachgeschaut.

    Starface seit April 2014

    STARFACE Advanced v4.1
    ISDN Anlagenanschluss mit 4 Leitungen
    1 SIP-Leitung HFO
    Gigaset N720 DECT
    Yealink T42G / T46G
    Cisco SPA112
    Geändert von M.Brück GmH & Co KG (19.12.2018 um 14:42 Uhr)

  2. #2
    STARFACE Expert
    Benutzerbild von nucom
    Registriert seit
    11.12.2012
    Ort
    9443 Widnau
    Beiträge
    1.335

    Standard

    Hallo M.Brück

    Habt ihr zwischen 32/64 Bit Office gewechselt?

    Oder wurde kürzlich etwas an der Rechtestruktur des Exchange Server gemacht? Spezifische, dass du auf einen früher Angehakten Kontakt-Ordner keinen Zugriff mehr hast?

    Wenn du nun z.b. eine Öffentliche Ordnerstruktur hast, dort gibt es drei Kontaktordner: Privatkunden, Geschäftskunden, Andere. Diese wurden alle Angehakt.
    Jetzt wurde dir jedoch das Recht entzogen, in die Geschäftskunden zu schauen.
    Ergebnis: Der Outlook-Connector funktioniert nicht mehr, da er immer noch Versucht auf den früher Angehakten Kontaktordner zuzugreifen, was nun nicht mehr geht. MAPI_E_NOT_FOUND

    MfG

    Fabian
    Modulhersteller aus der Schweiz
    __________________________________________________ ________
    STARFACE Excellence Partner: Info | Certified Module Creator Kontakt

  3. #3
    STARFACE User

    Registriert seit
    01.09.2018
    Ort
    52353 Düren
    Beiträge
    11

    Standard

    Hallo Fabian,

    Danke für Deine Antwort. Wir haben nichts der gleichen gemacht bzw. geändert.
    Ich und meine 2 betroffenen Kollegen sind uns nur nicht ganz sicher, ob das Problem erst mit dem Windows 10 Update 1809, was aktuell ausgeliefert wird, aufgetreten ist, oder doch schon vorher.
    Wir verwenden in der öffentlichen Ordnerstruktur einen gemeinsamen Ordner für Geschäftskunden Kontakte. Sollte etwas an den Rechten geändert worden sein, so müssten doch sicherlich alle Kollegen in der ganze Firma davon betroffen sein. Das ist nicht der Fall, es sind (mir zurzeit bekannt) 4 Systeme von insgesamt 3 Kollegen (User) betroffen.

    MfG
    Marc
    Starface seit April 2014

    STARFACE Advanced v4.1
    ISDN Anlagenanschluss mit 4 Leitungen
    1 SIP-Leitung HFO
    Gigaset N720 DECT
    Yealink T42G / T46G
    Cisco SPA112

  4. #4
    STARFACE Expert
    Benutzerbild von nucom
    Registriert seit
    11.12.2012
    Ort
    9443 Widnau
    Beiträge
    1.335

    Standard

    Hallo Marc

    Einfache Schritte, die man mal Probieren könnte:

    Die Konfigurationen vom Add-In löschen, damit er sie neu Anlegt (C:\Users\[Benutzername]\AppData\Roaming\STARFACE GmbH\OutlookConnector")
    Das STARFACE Add-In neu einbinden. (Outlook ==> Datei ==> Optionen ==> Add-Ins ==> Verwalten: COM-Add-Ins ==> Los ==> STARFACE Connector auswählen ==> Entfernen ==> OK ==> Los ==> Hinzufügen ==> Pfad: C:\Program Files\STARFACE\Outlook Connector\adxloader(x64).dll wählen==> OK)
    Mit einem anderen Benutzer an einem PC Anmelden, an dem es nicht geht, und schauen ob dort mit deren Outlook-Profil das gleiche Problem auftritt.
    Bei deinem Profil ein anderes Outlook Konto einbinden, und schauen ob die Exception Auftritt
    Au feinem PC-System, auf dem es aktuell geht, das Konto von jemandem einrichten, bei dem es aktuell nicht geht.
    Office Online-Reparatur durchführen

    MfG

    Fabian
    Modulhersteller aus der Schweiz
    __________________________________________________ ________
    STARFACE Excellence Partner: Info | Certified Module Creator Kontakt

  5. #5
    STARFACE User

    Registriert seit
    01.09.2018
    Ort
    52353 Düren
    Beiträge
    11

    Standard

    Hallo Fabian,

    Frohes Neues Jahr, auch wenn es schon fast 2 Wochen alt ist.

    Folgende Punkte von Dir habe ich durchgeführt:
    - Konfiguration vom Add-In löschen -> keinerlei Änderung, weiterhin die genannte Expection in der Log-Datei.
    - Add-in löschen und erneut einfügen -> jetzt habe ich keine Exception oder andere Fehler mehr im Logfile, aber weiterhin "UCC Client ist nicht verbunden".
    - Bei deinem Profil ein anderes Outlook Konto einbinden, und schauen ob die Exception Auftritt -> weiterhin "UCC Client ist nicht verbunden".
    - Office Online-Reparatur durchführen -> weiterhin "UCC Client ist nicht verbunden".


    Zu Deinen anderen Vorschlägen bin ich bisher noch nicht gekommen. Im Augenblick ist beruflich viel los und die Zeit daher sehr knapp.

    MfG

    Marc
    Geändert von M.Brück GmH & Co KG (14.01.2019 um 11:04 Uhr)
    Starface seit April 2014

    STARFACE Advanced v4.1
    ISDN Anlagenanschluss mit 4 Leitungen
    1 SIP-Leitung HFO
    Gigaset N720 DECT
    Yealink T42G / T46G
    Cisco SPA112

  6. #6
    STARFACE Crew
    Benutzerbild von Wolfgang
    Registriert seit
    18.02.2014
    Beiträge
    958

    Standard

    Hallo Marc,

    Findet sich vielleicht im UCC Client Log so etwas?

    19-01-10 09:35:34.219 | 1 | ERROR | | UccAPI.UccServiceHos | CreateWcfServiceHost | Creating / open WCF service host failed. | EXCEPTION:


    System.ServiceModel.CommunicationException: TCP-Fehler (10013: Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulässig) beim Lauschen am IP-Endpunkt=127.0.0.1:50002. ---> System.Net.Sockets.SocketException: Der Zugriff auf einen Socket war aufgrund der Zugriffsrechte des Sockets unzulässig



    Gruß Wolfgang

  7. #7
    STARFACE User

    Registriert seit
    01.09.2018
    Ort
    52353 Düren
    Beiträge
    11

    Standard

    Hallo Wolfgang,

    Entschuldigung für meine später Reaktion auf Deine Antwort, ich war bis Gestern beruflich unterwegs.

    Ich habe / hatte keine ERROR Einträge im Log mehr seit dem ich das AddIn einmal neu eingebunden hatte. (Danke nochmals an Fabian)
    Jedoch hatte ich zu diesem Zeitpunkt immer noch das Problem, das im Outlook Connector keine Anrufliste anzeigte und auch kein Anruf aus einer Email Telefonnummer erkannt hatte.

    Wie Du sicherlich schon bemerkt hast, spreche ich in der Vergangenheit. Denn seit Heute funktioniert der Outlook Connector wieder einwandfrei.
    Ich kann Dir leider nicht sagen, warum oder was das Problem war. (Außer das ich einige MS WinUpdates erhalten habe) Zuerst hat Outlook bzw. der Connector wieder keine Liste angezeigt. Doch urplötzlich kam eine aktuelle Liste der letzten Anrufe (verglichen mit Starface UCC Client) und auch TelNr aus Emails werden wieder erkannt.

    Vielen Dank an alle, die mir so schnell und informell geholfen haben.

    Gruß Marc
    Starface seit April 2014

    STARFACE Advanced v4.1
    ISDN Anlagenanschluss mit 4 Leitungen
    1 SIP-Leitung HFO
    Gigaset N720 DECT
    Yealink T42G / T46G
    Cisco SPA112

Ähnliche Themen

  1. Antworten: 14
    Letzter Beitrag: 06.02.2017, 09:43
  2. Antworten: 4
    Letzter Beitrag: 17.11.2016, 11:38
  3. Outlook Connector aktiv = Outlook langsam
    Von ITC-B im Forum STARFACE Erweiterungen & Integrationen
    Antworten: 7
    Letzter Beitrag: 13.05.2016, 07:21
  4. Outlook 2010 nicht gefunden bei MS Outlook Connector 1.5.8 Beta
    Von Biviol im Forum STARFACE Beta Archiv
    Antworten: 5
    Letzter Beitrag: 18.11.2010, 14:38
  5. [gelöst] Outlook Connector Initialsetup bei jedem Outlook-Start
    Von MHofmann im Forum STARFACE Erweiterungen & Integrationen
    Antworten: 6
    Letzter Beitrag: 28.04.2010, 15:59

Lesezeichen

Forumregeln

  • Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
  • Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
  • Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
  • Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.
  •