Zeige Ergebnis 1 bis 14 von 14

Thema: [BUG?] Voicemails werden nicht per E-Mail gesendet

  1. #1
    STARFACE Expert
    Benutzerbild von nucom
    Registriert seit
    11.12.2012
    Ort
    9443 Widnau
    Beiträge
    1.389

    Standard [BUG?] Voicemails werden nicht per E-Mail gesendet

    Hallo miteinander

    Wir haben aktuell ein Problem bei einem Kunden, dass Voicemails nicht per E-Mail versendet werden, bzw. sie werden in die E-Mail Queue gesetzt, aber nicht gesendet. ([Call36921062])
    Die Test E-Mails können versendet werden, und kommen an.

    Wir haben einen externen, und den Starface internen SMTP-Server Probiert, in beiden Fällen das gleiche Problem. Die Test E-Mails gehen raus, aber die Voicemails nicht.

    Die Starface meldet dann immer einen "Connection Timeout", wenn sie versucht die Voicemails zu senden, aber die Test E-Mails die ich gleich danach wieder sende, klappen.

    Der Connection Timeout tritt aber zumindest beim externen erst auf, während die E-Mail übertragen wird, die Starface kommuniziert also mit dem E-Mail Server.
    Wir verdächtigten danach die Firewall, aber das gleiche Problem tritt ja auch mit dem Starface internen E-Mail Server auf, deshalb kann es das wohl nicht sein.

    Sobald wir die Starface rebooten, gehen dann die Voicemails alle wieder raus, für eine weile zumindest.

    Hat jemand noch eine Idee, was man da Prüfen könnte?
    Der Support ist aktuell lahm (Ticket eröffnet am 08.02.2019, Reagiert am 21.02.2019), und die antworten waren in dem fall nicht gerade hilfreich, und es ist eine Scharfe Anlage in einem Hotel, was das ganze mit den Voicemails etwas Problematisch macht.

    Erster vorgeschlagener Fix:

    Dann vielen Dank für die detaillierte Beschreibung und die Logfiles der Anlage.

    Daraus geht hervor, dass die Voicmail die Timeouts verursacht, wenn die Voicmail "busy" also besetzt signalisiert. Ich vermute stark, dass dieser Fehler von einem falsch generierten Datenbank-Eintrag verursacht wird. Der schnellste und einfachste Weg ist, die Voicemail mit der gesamten Konfiguration zu deaktivieren und eine neue Voicemail mit der identischen Konfiguration anzulegen. Wenn das fehlerhafte Verhalten dann nicht mehr auftritt, können Sie die deaktivierte Voicmail löschen
    Haben wir gemacht. die entsprechende Voicemailbox gelöscht, und eine neue Angelegt.
    Das Problem war immer noch da. Danach kam die Antwort:

    dann überprüfen Sie bitte die Stabilität der Netzwerkverbindungen zu Ihrer VM.
    Lassen Sie mir anschließen bitte die Ergebnisse Ihrer Tests zukommen.
    Weder die Hotelangestellten, noch Gäste haben sich in irgendeiner Weise über die Telefonie beschwert, weshalb wir eine generelle Netzwerkstörung vorerst ausschliessen.

    Jemand eine Idee?

    MfG

    Fabian
    Modulhersteller aus der Schweiz
    __________________________________________________ ________
    STARFACE Excellence Partner: Info | Certified Module Creator Kontakt

  2. #2
    STARFACE Expert
    Benutzerbild von thomas.hertli
    Registriert seit
    30.05.2007
    Ort
    Arisdorf (CH)
    Beiträge
    939

    Standard

    Hallo Fabian

    Ist ggf. noch ein Antispam-Gateway dazwischen, das auch ausgehende Mails prüft und deshalb die Mails wegen des Anhangs gefiltert werden ?
    STARFACE Certified Partner

    Gruss
    Thomas

    hertli ¦ IT
    hertli Informatik+Treuhand

    eMail: briefkasten ( a t ) hertli.ch
    Internet: www.hertli.ch


    Virtuelle Rechenzentren (IaaS, PaaS) mit Standorten in CH + DE, STARFACE-Telefonanlagen, Managed Services, Security

  3. #3
    STARFACE Expert
    Benutzerbild von nucom
    Registriert seit
    11.12.2012
    Ort
    9443 Widnau
    Beiträge
    1.389

    Standard

    Guten Tag Thomas

    Da wir die gesamte IT managen, hatten wir auch temporär sämtliche Sicherheitsfeatures im ganzen Netzwerk, inkl. im Bezug auf die Starface deaktiviert gehabt.
    Jedoch hat das nicht geholfen.

    MfG

    Fabian
    Modulhersteller aus der Schweiz
    __________________________________________________ ________
    STARFACE Excellence Partner: Info | Certified Module Creator Kontakt

  4. #4
    STARFACE User

    Registriert seit
    11.01.2019
    Beiträge
    25

    Standard

    Moin Fabian,

    wir hatten vor einer Weile ein ähnliches verhalten beim Versand von Mails mit "größeren" Anhängen.
    Als workaround könntest Du testen ob folgende Einstellungen Abhilfe schaffen:

    - IPv4 Checksum Offload: disabled
    - large send offload version 2 (IPv4): disabled
    - TCP checksum offload (IPv4): disabled

    VG, fux.chr

  5. #5
    STARFACE Expert
    Benutzerbild von nucom
    Registriert seit
    11.12.2012
    Ort
    9443 Widnau
    Beiträge
    1.389

    Standard

    Halllo Fux

    Danke für deine Idee.

    Wir hatten in der Vergangenheit, zwar nicht mit E-Mails, aber bei Routing/NAT das Problem wenn diese Features eingeschaltet waren.

    Ich werde mal versuchen, ob uns das weiterhilft.

    MfG

    Fabian
    Modulhersteller aus der Schweiz
    __________________________________________________ ________
    STARFACE Excellence Partner: Info | Certified Module Creator Kontakt

  6. #6
    STARFACE Admin

    Registriert seit
    04.05.2018
    Beiträge
    166

    Standard

    Was steht denn unter
    cat /var/log/maillog

  7. #7
    STARFACE Expert
    Benutzerbild von nucom
    Registriert seit
    11.12.2012
    Ort
    9443 Widnau
    Beiträge
    1.389

    Standard

    Hallo bytegetter

    Hier sind die essentiellen Zeilen:

    Jan 19 15:14:46 voip postfix/smtp[32994]: 493248316D: conversation with [SERVER-IP] timed out while sending message body
    Jan 19 15:17:46 voip postfix/smtp[32994]: 493248316D: to=<info@kunden-domain.ch>, relay=[SERVER-IP]:25, delay=194864, delays=194503/0.01/181/180, dsn=4.4.2, status=deferred (conversation with [SERVER-IP] timed out while sending message body)
    Jan 19 15:26:45 voip postfix/qmgr[1831]: 83F2183143: from=<starface_no_reply@kunden-domain.ch>, size=5783, nrcpt=1 (queue active)

    Das füllt einfach den ganzen Log.

    MfG

    Fabian
    Modulhersteller aus der Schweiz
    __________________________________________________ ________
    STARFACE Excellence Partner: Info | Certified Module Creator Kontakt

  8. #8
    STARFACE User

    Registriert seit
    11.01.2019
    Beiträge
    25

    Standard

    Zitat Zitat von nucom Beitrag anzeigen
    Jan 19 15:14:46 voip postfix/smtp[32994]: 493248316D: conversation with [SERVER-IP] timed out while sending message body
    gleiche Fehlermeldung, andere Applikation.
    Netzwerkeinstellungen aktualisieren bzw. ändern wie oben beschrieben hat bei uns zum Erfolg geführt.

  9. #9
    STARFACE Admin

    Registriert seit
    04.05.2018
    Beiträge
    166

    Standard

    Dann kann er den Host nicht mit Port 25 erreichen oder er braucht zu lang.

    Da kurze eMails ja gehen gebe bitte folgendes ein:

    postconf -d | grep timeo

    Wichtig ist hier:
    smtp_data_done_timeout
    smtp_data_xfer_timeout
    smtp_data_init_timeout

    Die Parameter dann in der /etc/postfix/master.cf anpassen
    smtp inet n - n - - smtpd -o smtp_data_done_timeout=380000

    Und dann mit postfix reload den Postfix neuladen.

    Der Kunde hat nur geringe Upload-Bandbreite?

  10. #10
    STARFACE Expert
    Benutzerbild von thomas.hertli
    Registriert seit
    30.05.2007
    Ort
    Arisdorf (CH)
    Beiträge
    939

    Frage Relay-Server // Port

    Zitat Zitat von nucom Beitrag anzeigen
    relay=[SERVER-IP]:25

    Hallo Fabian

    • Hast Du es mal mit einem anderen Port wie 25 versucht ? bsp. 587 ?
    • Ist der Relay-Server berechtigt für die STARFACE Mails weiterzuleiten


    Es gibt Provider (Swisscom bspw.) die akzeptieren keinen Mail-Transport über Port 25.
    STARFACE Certified Partner

    Gruss
    Thomas

    hertli ¦ IT
    hertli Informatik+Treuhand

    eMail: briefkasten ( a t ) hertli.ch
    Internet: www.hertli.ch


    Virtuelle Rechenzentren (IaaS, PaaS) mit Standorten in CH + DE, STARFACE-Telefonanlagen, Managed Services, Security

  11. #11
    STARFACE Expert
    Benutzerbild von nucom
    Registriert seit
    11.12.2012
    Ort
    9443 Widnau
    Beiträge
    1.389

    Standard

    Hallo Thomas

    •Hast Du es mal mit einem anderen Port wie 25 versucht ? bsp. 587 ?
    Der Relay Server ist unser Zentraler Relay Server, für alle Starface-Clouds/VM's, bei denen wir vom Kunden keine Zugangsdaten für ihren Eigenen SMTP-Server erhalten haben. Wir haben es über beide Ports Probiert.

    •Ist der Relay-Server berechtigt für die STARFACE Mails weiterzuleiten
    Wir haben es Testweise mit einer unseren Testdomänen Versucht. Selbst mit korrekt gesetztem SPF, unterbricht es beim Transfer. Ich gehe wirklich von einer Problematik vom Postfix im Zusammenhang mit dem von Fux oben genannten:

    - IPv4 Checksum Offload: disabled
    - large send offload version 2 (IPv4): disabled
    - TCP checksum offload (IPv4): disabled
    Netzwerkkartenfeatures aus.

    Aber eben bei einem 4 Sterne Hotel muss das irgendwann in der Nacht gemacht werden.

    MfG

    Fabian
    Modulhersteller aus der Schweiz
    __________________________________________________ ________
    STARFACE Excellence Partner: Info | Certified Module Creator Kontakt

  12. #12
    STARFACE Expert
    Benutzerbild von nucom
    Registriert seit
    11.12.2012
    Ort
    9443 Widnau
    Beiträge
    1.389

    Standard

    Hallo Miteinander

    Wir haben dementsprechend die Änderungen an den Netzwerkkarten umgesetzt, jedoch ohne Besserung. Das Problem ist nach wie vor Vorhanden.

    Wir werden noch Versuchen einige PCAP's an verschiedenen Orten mitzuschneiden, um zu schauen, ob irgendwelche Nebeneffekte auftreten.

    MfG

    Fabian
    Modulhersteller aus der Schweiz
    __________________________________________________ ________
    STARFACE Excellence Partner: Info | Certified Module Creator Kontakt

  13. #13
    STARFACE Admin

    Registriert seit
    04.05.2018
    Beiträge
    166

    Standard

    Versuch mal die Übertragungsdauer hochzusetzen. Das Problem ist mit postfix bekannt.

  14. #14
    STARFACE User

    Registriert seit
    11.01.2019
    Beiträge
    25

    Standard

    Zitat Zitat von nucom Beitrag anzeigen
    Wir haben dementsprechend die Änderungen an den Netzwerkkarten umgesetzt, jedoch ohne Besserung. Das Problem ist nach wie vor Vorhanden.
    hat die VM eine dedizierte NIC oder kommuniziert sie über ein NIC-Team? Kann man da am Host ggf. zum testen ein(e) andere NIC zuweisen?
    Habt ihr auf der Empfängerseite mal die SMTP Logs geprüft? Ob die Starface da überhaupt anklingelt?

Ähnliche Themen

  1. Voicemails werden seit Version 6 nicht mehr übermittelt
    Von easyfenster im Forum STARFACE Einrichtung & Administration
    Antworten: 3
    Letzter Beitrag: 22.08.2018, 10:33
  2. Antworten: 0
    Letzter Beitrag: 19.07.2018, 15:27
  3. RE-Register wird nicht gesendet (ohne erkennbaren Grund)
    Von gglanzer im Forum Leitungen SIP, NGN, ALL-IP
    Antworten: 0
    Letzter Beitrag: 20.11.2015, 14:32
  4. Mail-Versand nicht möglich, externer Mail-Server (Hetzner, TLS)
    Von universal im Forum STARFACE Installation
    Antworten: 5
    Letzter Beitrag: 10.02.2015, 10:00
  5. ausgehendes externes Analogfax wird nicht mehr gesendet
    Von biomedpark im Forum Bugreports
    Antworten: 0
    Letzter Beitrag: 07.03.2012, 15:11

Lesezeichen

Forumregeln

  • Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
  • Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
  • Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
  • Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.
  •