Zeige Ergebnis 1 bis 10 von 10

Thema: STARFACE UCC Client V. 6.6.0.210 mit Sennheiser MP Pro 1 UCC

  1. #1
    STARFACE User

    Registriert seit
    14.03.2019
    Beiträge
    5

    Standard STARFACE UCC Client V. 6.6.0.210 mit Sennheiser MP Pro 1 UCC

    Hallo Zusammen,

    da dies mein erster Beitrag in diesem Forum ist, möchte ich mich kurz vorstellen:
    Ich arbeite in einer kleinen, auf Archivierung spezialisierten, Firma im medizinischem IT-Bereich und bin dort für die Betreuung und Umsetzt von Kundenprojekten, ebenso wie für den Support zuständig.

    Wir setzen STARFACE seit Mitte des letzten Jahres produktiv ein und haben bisher versucht über die Firma, über welche wir das Produkt erworben haben, Support zu erhalten.
    Leider gestaltet sich dies sehr schweirig, da wir mit folgender Thematik aktuell allein gelassen werden, obwohl die besagt Firma schon einen Kontakt mit dem STARFACE-Support hatte, welcher danach angeboten hatte das Problem nach einem "Clean-Install" des UCC Clients an die Entwicklung bei STARFACE weiterzugeben:

    Wir nutzen hauptsächlich den UCC Client für Windows - aktuell in der Version 6.6.0.210.
    Als Headsets haben wir das ofiziell von STARFACE unterstüzte Sennheiser MB Pro 1 UCC mit dem USB-Bluetoothdongle Sennheiser BTD 800 USB im Einsatz.
    Da die Kollegen lieber Bluetooth als DECT am Kopf tragen, fiel die Auswahl auf dieses Headset.

    Folgende Firmware Versionen sind installiert:
    Sennheiser BTD 800 USB = 2.2.2.0
    Sennheiser MB Pro 1 = 1.1.18.0

    Der UCC Client läuft bei uns unter Windows 10 Pro (1809).

    Nun zu den eingentlichen Symptomen:
    Bei ausgehenden Anrufen kommt es vor, dass das Gespräch auf bedein Seiten stumm bleibt, obwohl man im UCC Client sieht, dass die Verbindung aufgebaut wurde (Uhrzeit im Call Manager läuft).
    Bei eingehenden Anrufen tritt dieses Verhalten ebenso auf.
    Betroffen sind interne und externe Rufnummern.
    Bei manchen Usern scheint das Problem häufig aufzutreten, bei manchen wiederum tritt es nahezu nie auf.
    Wenn man am selben PC ein Headset mit 3,5 Klinken-Anschluss benutzt, tritt das Problem nie auf.
    Während die Fehlersituation besteht, kann man jederzeit in Windows eine Soundwiedergabe starten, diese wird ohen Verzögerung abgespielt und ist am Headset zu hören.
    Ebenso verhält sich das Mikrofon.
    Zudem ist die Steuerung des UCC Clients mit dem Schalter am Headset dann nicht mehr möglich.

    Die erweiteren Logs aus dem UCC Client wurden von unserem Betreuer, ebenso wie vom STARFACE-Support ergebnislos analysiert.

    Folgenden Workarounds müssen nach der Fehlersituation angewandt werden:
    - Auflegen und kurz warten, danach nochmals Wählen (dies hilft manchmal)
    - UCC Client beenden, USB-Dongle am PC ziehen und das Headset ausschalten, danach den USB-Dongle wieder einstecken und das Headset starte, warten bis sich dieses Verbunden hat und dann den STARFACE UCC Client starten (hilft fast immer)

    Meine Vermutung:
    Es gibt ein Problem mit der Ansteuerung der Headsets aus STARFACE heraus, dort ist glaube ich das senncomsdk in der Version 6.0.8011.0 integriert.
    Es könnte sein, dass die voreilige Installation der Sennheiser Software "Headsetup" und "HeadsetupPro" DLLs getauscht hat, oder Systemkonfigurationen vorgenommen haben, welche nun zu Probleme führen.
    Die Probleme bestehen jedoch auch nach einer Deinstallation dieser Komponenten und einer erneuten "sauberen" Installaltion des UCC Clients.

    Ist hierzu irgendetwas bekannt, bzw. können Sie den Fehler eventuell nachstellen?


    Viele Grüße,
    MBPro1UCC-User
    Geändert von MBPro1UCC-User (21.03.2019 um 21:22 Uhr) Grund: Anhang entfernt da Preisgabe von persönlichen Daten // Tom

  2. #2
    STARFACE User

    Registriert seit
    05.02.2019
    Beiträge
    13

    Standard

    Hey,
    hab zwar keine Hilfe zu dem Beitrag, aber du solltest mal den Anhang löschen. Hast gerade einige Telefonnummern und E-Mails von euren Kunden veröffentlicht. Euer Datenschutzbeauftragter wird sich freuen

  3. #3
    STARFACE Crew
    Benutzerbild von TomAnson
    Registriert seit
    11.11.2014
    Ort
    Karlsruhe
    Beiträge
    1.216

    Standard

    Hi,

    ich habe dir dein Anhang entfernt da sie sensible persönliche Daten enthält

    Wenn du Logeinträge veröffentlichst, stelle bitte sicher dass du keine persönlichen Daten veröffentlichst die du nicht veröffentlichen solltest.


    Tom
    STARFACE Quality Assurance

    Bug gefunden? Hier melden!
    Featurewunsch oder Verbesserungsvorschlag? Trage es in unserem Feature Request Portal ein!
    Unsere Knowledge-Base für STARFACE findet ihr hier!

  4. #4
    STARFACE Crew
    Benutzerbild von Wolfgang
    Registriert seit
    18.02.2014
    Beiträge
    958

    Standard

    Datenschutz-Einstellungen für das Mikrofon prüfen.
    Kaspersky Antivirus im Einsatz?

  5. #5
    STARFACE User

    Registriert seit
    14.03.2019
    Beiträge
    5

    Standard

    Danke fürs Löschen!

  6. #6
    STARFACE User

    Registriert seit
    14.03.2019
    Beiträge
    5

    Standard

    Hallo Wolfgang,

    Datenschutz-Einstellungen sind soweit in Ordnung, (Option Zulassen, dass Apss auf Ihr Mikrofon zugreifen) ist aktiv. Jedoch wirkt diese Funktion bei Windows Desktop-Anwendungen lt. Microsoft nicht, sondern sollte nur für Store-Apps gelten.
    Nein ein Kaspersky AV ist nicht im Einsatz.

    Grüße

  7. #7
    STARFACE Crew
    Benutzerbild von Wolfgang
    Registriert seit
    18.02.2014
    Beiträge
    958

    Standard

    Ja. in de Auflistung der zugelassenen Apps finden sich nur die UWP Anwendungen / Windows Store Apps.

    Wenn gemäß Datenschutz-Einstellungen das Mikrofon nicht zugelassen ist, kann der Client nicht über Windows API das Mikrofon öffnen.

    Wenn der Client sich mit dem Sennheiser Headsetup verbinden konnte, ist dies auch am System Tray Symbol von Headseutp zu sehen, es zeigt dann einen grünen Kreis.


    Ein gehender Call mit einem Sennheiser Headset sieht ungefähr so im Client log aus:

    Sound Device öffnen (je nach Konfiguration steht dort auch nicht Wavemapper sondern der Name des Gerätes):

    pjsua_app.c .......Turning sound device ON
    pjsua_aud.c .......Opening sound device (speaker + mic) PCM@16000/1/20ms
    wmme_dev.c ........init_player_stream
    wmme_dev.c ........init_waveformatex
    wmme_dev.c ........formatId: 0, tag: 0x1, channels: 1, samples/sec: 16000, block align: 2, avg bytes/sec: 32000, bis/sample: 16
    wmme_dev.c ........Open WaveAPI Sound player "Wave mapper" wmme_uDeviceID=-1
    wmme_dev.c ........Pause wave out
    wmme_dev.c ........Create buffers
    wmme_dev.c ........WaveAPI Sound player "Wave mapper" initialized (format=PCM, clock_rate=16000, channel_count=1, samples_per_frame=320 (20ms))
    wmme_dev.c ........init_capture_stream
    wmme_dev.c ........init_waveformatex
    wmme_dev.c ........formatId: 0, tag: 0x1, channels: 1, samples/sec: 16000, block align: 2, avg bytes/sec: 32000, bis/sample: 16
    wmme_dev.c ........Open WaveAPI Sound recorder "Wave mapper" wmme_uDeviceID=-1
    wmme_dev.c ........Create buffers
    wmme_dev.c ........WaveAPI Sound recorder "Wave mapper" initialized (format=PCM, clock_rate=16000, channel_count=1, samples_per_frame=320 (20ms))
    wmme_dev.c ........WMME playback stream started
    wmme_dev.c ........WMME capture stream started


    ++++++++++++
    SupportInfo:
    Sennheiser: Set outgoing call 0,
    ------------

    19-03-15 11:38:49.454 | 6 | TRACE | | UccAPI.SennheiserDev | SendXmlString | <?xml version="1.0" encoding="utf-8"?>
    <ReqOutgoingCall xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <SFID>0</SFID>
    <ReqID>4</ReqID>
    <CallID>0</CallID>
    <CallerName></CallerName>
    </ReqOutgoingCall>



    19-03-15 11:38:49.454 | 10 | TRACE | | UccAPI.SennheiserDev | OnReceivedData | Received message from Sennheiser SDK: <?xml version="1.0" encoding="utf-8" ?>
    <AckOutgoingCall xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <ReqID>4</ReqID>
    <SFID>0</SFID>
    <CallID>0</CallID>
    <ReturnCode>0</ReturnCode>
    </AckOutgoingCall>



    ++++++++++++
    SupportInfo:
    Sennheiser: Set outgoing call accepted 0,
    ------------


    19-03-15 11:38:49.469 | 6 | TRACE | | UccAPI.SennheiserDev | SendXmlString | <?xml version="1.0" encoding="utf-8"?>
    <ReqOutCallAccepted xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <SFID>0</SFID>
    <ReqID>5</ReqID>
    <CallID>0</CallID>
    </ReqOutCallAccepted>


    19-03-15 11:38:49.469 | 10 | TRACE | | UccAPI.SennheiserDev | OnReceivedData | Received message from Sennheiser SDK: <?xml version="1.0" encoding="utf-8" ?>
    <AckOutCallAccepted xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <ReqID>5</ReqID>
    <SFID>0</SFID>
    <CallID>0</CallID>
    <ReturnCode>0</ReturnCode>
    </AckOutCallAccepted>




    Wenn der Ruf über das Headset beendet wird, sieht das so aus:

    19-03-15 11:40:46.640 | 10 | TRACE | | UccAPI.SennheiserDev | OnReceivedData | Received message from Sennheiser SDK: <?xml version="1.0" encoding="utf-8" ?>
    <EvtCallEnded xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    <SFID>0</SFID>
    <CallID>0</CallID>
    <HeadsetPath>\\?\HID#VID_1395&amp;PID_740A&amp;MI_ 00&amp;Col04#8&amp;2527b042&amp;0&amp;0003#{4d1e55 b2-f16f-11cf-88cb-001111000030}</HeadsetPath>
    </EvtCallEnded>



    ++++++++++++
    SupportInfo:
    Sennheiser: Call ended 0
    ------------


    ++++++++++++
    SupportInfo:
    Sennheiser: Hangup call 0
    ------------

    Du kannst ja mal schauen, was du im Log findest.



    Gruß Wolfgang

  8. #8
    STARFACE User

    Registriert seit
    14.03.2019
    Beiträge
    5

    Standard

    Hallo Wolfgang,

    meine letzte Information vom STARFACE-Support war, dass das Headset ohne Sennheiser-Software funktionieren sollte. Deshalb habe ich HeadSetup und HeadSetupPro deinstalliert.
    Wenn man nun den UCC Client startet, öffnet dieser im Hintergrund den Prozess Senncom.sdk, welcher im UCC Client integriert ist.

    Die Frage ist, ob die vormailge Installation der Sennheiser-Software eventuell für das Senncom.sdk Probleme verursacht.

    Was ich sagen kann, ist, dass auch mit installierter Sennheiser-Software die selben Probleme auftreten.

    Gibt es im UCC Client ein genaues LOG, welches die Headset-Ansteuerung über das Senncom.sdk betrifft?

    Grüße

  9. #9
    STARFACE Crew
    Benutzerbild von Wolfgang
    Registriert seit
    18.02.2014
    Beiträge
    958

    Standard

    Log: Siehe meine vorherige Antwort. Diese Ausgaben findest Du in der Datei %temp%\STARFACE GmbH\UccClient\logs\UccClient.log

    In der aktuellen Version ist die Antwort: Sowohl als auch.

    Die Sennheiser-Integration im Windows Client funktioniert mit und ohne Headsetup Pro.
    Der Client installiert das Sennheiser SDK und initialisiert dieses beim Start. Das SDK hat einen automatischen Fallback auf Headsetp Pro, wenn dieses installiert ist.
    Wenn Headsetup Pro installiert ist, kommuniziert der Client mit Headsetup Pro.
    Wenn Headsetup Pro nicht installiert ist, kommunziert der Client mit dem SDK.

    Gruß Wolfgang

  10. #10
    STARFACE User

    Registriert seit
    14.03.2019
    Beiträge
    5

    Standard

    Hallo Wolfgang,

    vielen Dank für die Info, ich werde morgen das HeadSetupPro nochmals installieren und mir dann die LOGs ansehen.
    Konnte leider die letzten Tage nicht antworten, da ich nicht im Büro war.

    Grüße

Ähnliche Themen

  1. Antworten: 13
    Letzter Beitrag: 20.02.2019, 18:29
  2. Sennheiser Softphone SDK Prozess hohe CPU Last
    Von alung im Forum STARFACE Benutzerfrontend
    Antworten: 3
    Letzter Beitrag: 18.12.2015, 13:14
  3. Starface UCC UCC Client für Mac - v6.6.0.0.13
    Von Goulasch im Forum STARFACE Erweiterungen & Integrationen
    Antworten: 2
    Letzter Beitrag: 15.10.2015, 15:58
  4. STARFACE 6.0 UCC Client für Mac – v6.0.0.13
    Von tboelz im Forum STARFACE Erweiterungen & Integrationen
    Antworten: 0
    Letzter Beitrag: 31.07.2015, 12:15
  5. STARFACE 6.0 UCC Client für Mac – v6.0.0.12
    Von tboelz im Forum STARFACE Erweiterungen & Integrationen
    Antworten: 2
    Letzter Beitrag: 29.07.2015, 11:25

Lesezeichen

Forumregeln

  • Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
  • Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
  • Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
  • Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.
  •