Seite 1 von 2 12 LetzteLetzte
Zeige Ergebnis 1 bis 15 von 22

Thema: Dial plan ads 0 to "local" outgoing call

  1. #1
    STARFACE User

    Registriert seit
    16.02.2009
    Beiträge
    29

    Standard Dial plan ads 0 to "local" outgoing call

    I have almost everything running now apart from the Dial Plan ads a "0" to every outbound local number in the country.

    so number 0045 6128 0700 gets converted to dialing 061280700?

    International dialing works fine... only local dialing does not work.

    how do I correct that.

    and sorry all the stupid questions.... :-)

  2. #2
    STARFACE Expert
    Benutzerbild von Torsten
    Registriert seit
    07.01.2008
    Beiträge
    528

    Standard

    hi klarsen,

    if 0045 is the prefix for the country you are in, then yes, STARFACE will convert the 0045 to a 0 since it recognizes that it does not have to dial an international number.

  3. #3
    STARFACE User

    Registriert seit
    16.02.2009
    Beiträge
    29

    Standard

    but how do i stop that? we do not have (0)'s in front of the numbers in DK

  4. #4
    STARFACE Expert
    Benutzerbild von Torsten
    Registriert seit
    07.01.2008
    Beiträge
    528

    Standard

    Ah ok, now I get your problem.

    You can do that by setting up some more Call-Rules.

    You allready have a rule for all numbers starting with 0, correct?
    Now all you have to do is add 9 more rules. One rule für numbers starting with 1, onr rule for numbers starting with 2 .... and so on.

    This way you do not have to dial a 0 in front of every number.

  5. #5
    STARFACE User

    Registriert seit
    16.02.2009
    Beiträge
    29

    Standard

    hmm think we are misunderstanding eachother.

    I have a 0045 dial plan / which as far as I know should let me dial 0045 6128 0700 - and Starface will then select the 0045 outbound defined line.

    But when I dial "0045 6128 0700" - the number is "decoded" by starface to:

    Transmitting (no NAT) to 87.54.25.114:5060:
    ACK sip:061280700@musimi.dk SIP/2.0
    Via: SIP/2.0/UDP 81.7.145.180:5060;branch=z9hG4bK450f1304;rport
    From: "Larsen Kasper" <sip:46931698@musimi.dk>;tag=as738c0d5c
    To: <sip:061280700@musimi.dk>;tag=71f7ae5f309317ddcbc6 8bbdd2fee19f.23e0
    Contact: <sip:46931698@81.7.145.180>
    Call-ID: 4cfd395240b08ede530b8f0743b238e5@musimi.dk
    CSeq: 103 ACK
    User-Agent: STARFACE PBX
    Max-Forwards: 70
    Content-Length: 0

    so 061280700 - which is "allmost" correct - but where does the EXTRA 0 come from in the beginning of the number?

    I have tried creating a "6" rule but without any change. Still dechipers the number to 061280700. But that is not a number we can dial in denmark. We only got 8 digits / and none with 0 in front...

  6. #6
    STARFACE Expert
    Benutzerbild von Torsten
    Registriert seit
    07.01.2008
    Beiträge
    528

    Standard

    Hm.... maybe some basic questions first:

    - where is your STARFACE located? (country)
    - how are your settings in Configuration -> Routing within the STARFACE?
    - if you have "Cost optimized routing configured, how did you configure it?

  7. #7
    STARFACE User

    Registriert seit
    16.02.2009
    Beiträge
    29

    Standard

    Box is located in Denmark - uses only VOIP lines for.

    Routing is set to "COR Route"

    Routes so far

    6 : route via dk Voip (to test the 61280700 number)
    0044: Route via SipGate UK
    0045: Route via dk voip
    00971: Route via dk voip


    And the 0044/00971 rules works fine - 0044 dials out via sipgate - and 00971 dial out via dk voip.

    Only problem is "local calls" get a zero set in front of the number.

    I have Lines/General Configuration/Country set to germany since Denmark does not exsist. (and prefix set to none)

  8. #8
    STARFACE Expert
    Benutzerbild von Torsten
    Registriert seit
    07.01.2008
    Beiträge
    528

    Standard

    Hi klarsen, I think we are getting closer to the solution


    Could you try to set the country from germany to united states?

    Background:
    If Germany is chosen, we will set the defined "area code" in front of every outgoing call (default for Germany).

    If you choose United States this should be ignored, so when you dial the 61280700 there should not be a leading 0 added by the STARFACE.
    Geändert von Torsten (19.02.2009 um 15:48 Uhr)

  9. #9
    STARFACE User

    Registriert seit
    16.02.2009
    Beiträge
    29

    Standard

    hmm quite not there yet. I set country = united states but still same problem.

    if i dial 61280700 (trying to catch the "6" dial plan rule I get this:

    SIP Debugging Enabled for IP: 87.54.25.114:5060
    -- Executing AGI("SIP/zipi-08e41128", "agi://localhost/initdial.agi") in new stack
    -- AGI Script Executing Application: (Set) Options: (__SFCLIDNUM=931698)
    -- AGI Script Executing Application: (Set) Options: (__SFCLIDINTNUM=100)
    -- AGI Script Executing Application: (Set) Options: (__SFCLIDNAME=Larsen Kas per)
    -- AGI Script Executing Application: (noop) Options: (---[info]---Call from : (name) Larsen Kasper (num) 931698 (intern) 100 )
    -- AGI Script Executing Application: (Set) Options: (LANGUAGE()=en)
    -- AGI Script Executing Application: (Set) Options: (CDR(userfield)=1453)
    -- AGI Script Executing Application: (noop) Options: (---[Error]---skipping callerid because line is null )
    -- AGI Script Executing Application: (noop) Options: (---[Info]---Call outgo ing for account 1000 to 61280700 )
    -- AGI Script Executing Application: (ResetCDR) Options: ()
    -- AGI Script Executing Application: (Set) Options: (EXTEN=04661280700)
    -- AGI Script agi://localhost/initdial.agi completed, returning 0
    -- Executing Hangup("SIP/zipi-08e41128", "0") in new stack
    == Spawn extension (international, 61280700, 2) exited non-zero on 'SIP/zipi-0

    Where this part leaves me "baffeled" Options: (EXTEN=04661280700)

    so it tries to put but a 0 + a 46 (the local area code) into the dialled number.

    If i try to dial "004561280700" it still appends a zero before the number.

    It is something in the dial plan - because dialing **1*61280700 or **1*004561280700 - correctly calls the number without any parsing it seems.

    Best regards

    Kasper

  10. #10
    STARFACE Expert
    Benutzerbild von Philipp
    Registriert seit
    08.01.2007
    Ort
    Karlsruhe
    Beiträge
    1.782

    Standard

    Hi,

    sry, "united states" seems not to be the correct setting.
    For testing purpose:
    Can you change your country area code from "0045" (?) to e.g. "001" or "00358".
    Just for testing, if it works I'll tell you why

  11. #11
    STARFACE User

    Registriert seit
    16.02.2009
    Beiträge
    29

    Standard

    Hi,

    do you want me to change all (both main config page AND on each phone number - or just on the phone number part in the lines definition?

    best

  12. #12
    STARFACE User

    Registriert seit
    16.02.2009
    Beiträge
    29

    Standard

    That works .. but that is kind of logic - since now outbound dialing will try to dial 004561280700... :-) since it looks at it as international number.

    But only works if i dial 004561280700 - not if i try to use the "6" dial rule and just dial 61280700.

    best

  13. #13
    STARFACE Expert
    Benutzerbild von Philipp
    Registriert seit
    08.01.2007
    Ort
    Karlsruhe
    Beiträge
    1.782

    Standard

    can you give us an asterisk trace when you dial "only" 61280700?

  14. #14
    STARFACE User

    Registriert seit
    16.02.2009
    Beiträge
    29

    Standard

    yes :-)

    sf*CLI> sip debug peer 46933131
    SIP Debugging Enabled for IP: 87.54.25.114:5060
    -- Executing AGI("SIP/zipi-08e72a10", "agi://localhost/initdial.agi") in new stack
    -- AGI Script Executing Application: (Set) Options: (__SFCLIDNUM=931698)
    -- AGI Script Executing Application: (Set) Options: (__SFCLIDINTNUM=100)
    -- AGI Script Executing Application: (Set) Options: (__SFCLIDNAME=Larsen Kas per)
    -- AGI Script Executing Application: (noop) Options: (---[info]---Call from : (name) Larsen Kasper (num) 931698 (intern) 100 )
    -- AGI Script Executing Application: (Set) Options: (LANGUAGE()=en)
    -- AGI Script Executing Application: (Set) Options: (CDR(userfield)=1471)
    -- AGI Script Executing Application: (noop) Options: (---[Error]---skipping callerid because line is null )
    -- AGI Script Executing Application: (noop) Options: (---[Info]---Call outgo ing for account 1000 to 61280700 )
    -- AGI Script Executing Application: (ResetCDR) Options: ()
    -- AGI Script Executing Application: (Set) Options: (EXTEN=04661280700)
    -- AGI Script agi://localhost/initdial.agi completed, returning 0
    -- Executing Hangup("SIP/zipi-08e72a10", "0") in new stack
    == Spawn extension (international, 61280700, 2) exited non-zero on 'SIP/zipi-0 8e72a10'
    sf*CLI>

    this ... Options: (EXTEN=04661280700) still baffels me...

  15. #15
    STARFACE User

    Registriert seit
    16.02.2009
    Beiträge
    29

    Standard

    bumping for attention ! :-)

Ähnliche Themen

  1. Anzeige der Umleitung anderer User
    Von netaccess im Forum STARFACE Benutzerfrontend
    Antworten: 19
    Letzter Beitrag: 30.03.2010, 13:49
  2. Open up Home Edition to microenterprise and small business use, please
    Von SoyaWaxJim im Forum Off-Topic & Smalltalk
    Antworten: 2
    Letzter Beitrag: 22.07.2008, 18:44
  3. Removing 00 before sending call to VoIP provider
    Von oramaavis im Forum STARFACE setup & administration
    Antworten: 8
    Letzter Beitrag: 30.06.2008, 12:26
  4. Unterschied Starforce Home / PBX
    Von rok°! im Forum Off-Topic & Smalltalk
    Antworten: 7
    Letzter Beitrag: 16.06.2008, 17:17

Lesezeichen

Forumregeln

  • Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
  • Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
  • Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
  • Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.
  •