Seite 2 von 2 ErsteErste 12
Zeige Ergebnis 16 bis 19 von 19

Thema: Android-Client reagiert nicht (eingehend / ausgehend)

  1. #16
    STARFACE Crew
    STARFACE User

    Registriert seit
    02.03.2018
    Ort
    Karlsruhe
    Beiträge
    12

    Standard

    Hallo h.k.

    gehe ich richtig in der Annahme, dass wenn man den Haken bei "im Hintergrund ausführen" beim Autostart nicht setzt, dass dann die App nach dem Neustart im Vordergrund aufploppt?

    Gruß,
    Aaron

    //Edit: Hab es gerade einen Kollegen mit Huawei Gerät testen lassen, selbst mit "Im Hintergrund ausführen" deaktiviert kommt die App nach dem Start nicht in den Vordergrund. Schade. An der Stelle ist die UI von Huawei verwirrend, die Option für Hintergrund ist bei Autostart und nicht bei Batterieoptimierungen... ¯\_(ツ)_/¯
    Geändert von Aaron (25.09.2020 um 10:39 Uhr)

  2. #17
    STARFACE User

    Registriert seit
    02.03.2020
    Beiträge
    26

    Standard

    Hallo Aaron,

    sehr komisch.
    Vorallem, da ein Anruf per Klingeln und per Vibration signalisiert wird; die Anzeige jedoch nicht erfolgt.

  3. #18
    STARFACE Crew
    STARFACE User

    Registriert seit
    02.03.2018
    Ort
    Karlsruhe
    Beiträge
    12

    Standard

    Hallo h.k.

    doch, aus Entwicklersicht macht das schon Sinn, dass alle möglichen UI-Elemente erst beim offiziellen Start der App erstellt und geladen werden. Dass man Apps nach dem Reboot automatisch starten lassen kann ist wohl auch nur bei Huawei so (oder eben durch Drittanbieter-Apps).

    Ich wollte nochmal Danke sagen, dass du uns darauf hingewiesen hast. Der Fall wurde intern aufgenommen um einpriorisiert zu werden.

    Bis das gelöst ist, wird man mit einem Huawei Gerät leider damit leben müssen, oder einen der folgenden Workarounds verwenden:
    1) Nach dem Neustart des Gerätes die App einmal manuell aufmachen, denn sobald das passiert ist, funktioniert alles wie gewohnt.
    2) Die App aus dem Autostart entfernen, dann denkt man auf jeden Fall daran einmal die App manuell zu öffnen.
    3) Wenn man nach dem Neustart das erste Mal angerufen wird (man hört es am Klingelton) in die App gehen, dort gibt es ein Banner "zum Anruf zurückkehren" und man kann den Anruf dann annehmen. Hiermit wurde die App auch einmal manuell geöffnet, jeder weitere Anruf hat wieder einen Anruf-Screen.

    Sobald der Fehler gefixt ist, würde ich mich in diesem Thread nochmal melden.

    Gruß,
    Aaron

  4. #19
    STARFACE User

    Registriert seit
    02.03.2020
    Beiträge
    26

    Standard

    Hallo Aaron,

    nichts zu danken. Ich finde den Ansatz mit dem Forum und dem Gedankenaustausch super

    Wenn mans weiß, dann ist das ein Workaround, der machbar ist: einfach beim Gerätestart kurz die App starten und damit sagen, dass man da is.

    Viele Grüße

Ähnliche Themen

  1. Mobile Android Client verbindet nicht
    Von gho im Forum STARFACE UCC Clients & Mobile Clients
    Antworten: 2
    Letzter Beitrag: 03.09.2020, 17:13
  2. Easybell mit SRTP ausgehend ok - eingehend keine Verbindung?
    Von slu im Forum STARFACE Einrichtung & Administration
    Antworten: 4
    Letzter Beitrag: 13.05.2019, 16:25
  3. IVR reagiert nicht bei GSM Anrufen
    Von stoffel im Forum STARFACE Module
    Antworten: 18
    Letzter Beitrag: 15.01.2019, 11:57
  4. Antworten: 2
    Letzter Beitrag: 10.04.2018, 20:23
  5. Print to Fax reagiert nicht
    Von rothsching im Forum Bugreports
    Antworten: 4
    Letzter Beitrag: 07.07.2017, 09:34

Lesezeichen

Forumregeln

  • Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
  • Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
  • Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
  • Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.
  •