Zeige Ergebnis 1 bis 6 von 6

Thema: Snom 370 mit FW 7.3.23

  1. #1
    STARFACE User

    Registriert seit
    19.06.2009
    Beiträge
    5

    Standard Snom 370 mit FW 7.3.23

    Hallo,

    offenbar geht das Adressbuch von der Starface nicht mehr mit Snom 360/370 mit FW 7.3.23. Vorher mit 7.1.x kein Problem, jetzt 500 Bad Server response.

    Das ganze scheint mir auf folgendes hinauszulaufen (wir haben ein LDAP-Backend auf OpenLDAP):

    GET /phone/showAddressBook;jsessionid=5FE4CCF3D7804F5A5EEDE9F 773E88E52?giveFolder=ou=shared,ou=contacts,ou=Addr esses,dc=eonas,dc=de&accountId=1000 HTTP/1.1

    Host: 10.1.0.9

    Accept: */*

    Accept-Language: en-us

    Connection: Keep-Alive

    Keep-Alive: 5

    User-Agent: Mozilla/4.0 (compatible; snom370-SIP 7.3.23)



    HTTP/1.1 500 Internal Server Error

    Server: Apache-Coyote/1.1

    Content-Type: text/html;charset=UTF-8

    Content-Language: de

    Transfer-Encoding: chunked

    Date: Wed, 24 Jun 2009 13:55:01 GMT

    Connection: close



    Der Request zuvor war noch ok:

    GET /phone/showAddressBook?phoneName=Helmut HTTP/1.1

    Host: 10.1.0.9

    Accept: */*

    Accept-Language: en-us

    Connection: Keep-Alive

    Keep-Alive: 5

    User-Agent: Mozilla/4.0 (compatible; snom370-SIP 7.3.23)



    HTTP/1.1 200 OK

    Server: Apache-Coyote/1.1

    Set-Cookie: JSESSIONID=5FE4CCF3D7804F5A5EEDE9F773E88E52; Path=/

    Content-Type: text/xml;charset=utf-8

    Content-Length: 357

    Date: Wed, 24 Jun 2009 13:55:01 GMT



    <?xml version="1.0" encoding="UTF-8"?>

    <SnomIPPhoneMenu>

    <Title>STARFACE Addressbook</Title>

    <MenuItem>

    <Name>Kontakte</Name>

    <URL>http://10.1.0.9:80/phone/showAddressBook;jsessionid=5FE4CCF3D7804F5A5EEDE9F 773E88E52?giveFolder=ou=shared,ou=contacts,ou=Addr esses,dc=eonas,dc=de&amp;accountId=1000</URL>

    </MenuItem>

    </SnomIPPhoneMenu>




    Mit freundlichen Grüßen,
    Helmut Manck

  2. #2
    STARFACE User

    Registriert seit
    19.06.2009
    Beiträge
    5

    Standard

    Gibt wohl eine NPE im Adressbuch:

    [2009-06-24 15:59:45,527] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/].[AddressBook] Servlet.service() for servlet AddressBook threw exception
    java.lang.NullPointerException
    at de.vertico.starface.phone.userinterface.AddressBoo k.service(AddressBook.java:155)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:729)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:269)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:188)
    at de.vertico.starface.persistence.hibernate.Hibernat eSessionRequestFilter.doFilter(HibernateSessionReq uestFilter.java:48)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:215)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:188)
    at de.vertico.starface.filters.PhoneAuthFilter.doFilt er(PhoneAuthFilter.java:246)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:215)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:188)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:172)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:127)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:117)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:108)
    at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:174)
    at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:875)
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt ocol.java:665)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:528)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:81)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:689)
    at java.lang.Thread.run(Thread.java:595)

  3. #3
    STARFACE User

    Registriert seit
    08.04.2008
    Beiträge
    32

    Standard

    Hallo,

    danke fuer die Fehlermeldung. Wir werden uns das Problem naeher anschauen.

    Gruesse

  4. #4
    STARFACE Admin

    Registriert seit
    25.08.2007
    Beiträge
    199

    Standard

    Hatte exakt das selbe Problem. Nutze das Postgres Adressbuch der STARFACE. Den Fehler konnte ich nur beheben mit dem Einspielen der alten Firmware 7.3.14.

  5. #5
    STARFACE Newbie
    Registriert seit
    09.09.2008
    Beiträge
    1

    Standard

    Ist hier schon eine Lösung in Sicht? Wir haben eben erst den ganzen Betrieb mit > 50 Telefonen auf 7.3.23 aktualisiert, möchte lieber nicht wieder downgraden, wenn möglich.

  6. #6
    STARFACE Expert
    Benutzerbild von Torsten
    Registriert seit
    07.01.2008
    Beiträge
    528

    Standard

    Hallo zusammen,
    wir haben den Fehler inzwischen finden können und auch schon einen Fix dafür geschrieben.
    Dieser Fix befindet sich im Moment noch bei uns im Stresstest und wird mit dem nächsten STARFACE-Update ausgerollt.

Ähnliche Themen

  1. Snom 370 Wildes Message und Leitungsgeblinke
    Von udo im Forum Hersteller Informationen & Hardware Kompatibilität
    Antworten: 2
    Letzter Beitrag: 30.06.2009, 09:19
  2. Konferenzstart vom Snom 370 aus
    Von Frank Straub im Forum STARFACE Einrichtung & Administration
    Antworten: 2
    Letzter Beitrag: 11.03.2009, 09:56
  3. besetzte Leitung am Snom 370 per LED zeigen?
    Von rok°! im Forum Hersteller Informationen & Hardware Kompatibilität
    Antworten: 4
    Letzter Beitrag: 15.07.2008, 14:51
  4. Snom 370 startet neu wenn Starface-Dienste neu gestartet werden.
    Von thomas.hertli im Forum Hersteller Informationen & Hardware Kompatibilität
    Antworten: 1
    Letzter Beitrag: 29.05.2008, 08:12
  5. SNOM 370 - angemeldeten Benutzer auf Display anziegen
    Von galao im Forum STARFACE Einrichtung & Administration
    Antworten: 4
    Letzter Beitrag: 07.01.2008, 20:23

Lesezeichen

Forumregeln

  • Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
  • Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
  • Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
  • Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.
  •