Autoprovisionierung - Dokumentation

  • Gibt es irgendwo eine detaillierte Dokumentation, wie die Autoprovisionierung funktionieren sollte? Ich habe hier eine Starface Light mit aktivierter Autoprovisionierung (Haken bei MAC-Adressen-Beschränkung raus) an einem Switch mit 1 Snom360 und 1 Snom 370 (beide Firmware 7.3.14). Wenn ich die Telefone neustarte, passiert nix. Wenn ich im Starface-Menü ein Firmware-Update anstossen will, passiert nix.


    Die offizielle Dokumentation ist leider wenig hilfreich, und im Wiki ist auch nur der Fall beschrieben, wie man One-Touch Konfiguration macht, wenn Zero-Touch nicht funktioniert.

  • Vorab ein paar Fragen:
    Die Telefone befinden sich im gleichen Netzwerksegment wie die STARFACE?
    Die Autoprovisionierung ist aktiv?



    "Jetzt updaten" ist nur für bereits konfigurierte Telefone möglich, ein Snom-Restart sollte aber das gleiche bewirken.

    Yours sincerely / Gruß,
    OH

  • Was sagt denn das Logfile (autoprov) im Bereich Server-> Log-File.


    Hier bitte mal auf die höchste Stufe stellen und danach Autoprov deaktivieren+aktivieren.


    Das einzige was noch in der Dokumentation fehlt ist:


    Der Mechanismus funktioniert über Multicast, SF registriert einen Listener für Multicast auf port 5060, die Telefone senden beim Start einen Multicast-Provisioning request, der dann beantwortet wird.


    Durch einen Factory-Reset der Telefone könnte man Config-Probleme ausschliessen.

    Yours sincerely / Gruß,
    OH

  • Code
    [2009-12-22 11:07:06,824] INFO  de.vertico.starface.phonesetup.autoprov.listener.SIPMulticastListener #stopMulticastListener()[235] Auto provisioning - SIPMulticastListener stopped 
    [2009-12-22 11:07:33,049] DEBUG de.vertico.starface.phonesetup.autoprov.listener.SIPMulticastListener #run()[163] Auto provisioning - Starting Multicast Listener... 
    [2009-12-22 11:07:33,050] INFO  de.vertico.starface.phonesetup.autoprov.listener.SIPMulticastListener #startMulticastListening()[273] Auto provisioning - Multicast Listener started


    Factory-reset habe ich schon gemacht. Hier ein Auszug aus netstat -paun:

    Code
    udp        0      0 0.0.0.0:5060                0.0.0.0:*                               2290/asterisk
    udp        0      0 0.0.0.0:4569                0.0.0.0:*                               2290/asterisk
    udp        0      0 0.0.0.0:4570                0.0.0.0:*                               2378/iaxmodem
    udp        0      0 192.168.200.31:123          0.0.0.0:*                               1905/ntpd
    udp        0      0 127.0.0.1:123               0.0.0.0:*                               1905/ntpd
    udp        0      0 0.0.0.0:123                 0.0.0.0:*                               1905/ntpd
    udp        0      0 :::5060                     :::*                                    2028/java


    tcpdump port 5060 zeigt keine Pakete an, wenn die Snoms neugestartet werden.

  • Der Prozess ist wie im WIKI beschrieben zweistufig.


    1. Schritt: Das Telefon erhält am Beginn des Bootprozesses per SIP Multicast den Provisioning Server konfiguriert.


    Dies kannst du im Web Interface der Telefone gegenprüfen. Schlägt dieser Schritt fehl kann eine weitere Provisionierung logischerweise nicht erfolgen. Du kannst diesen Schritt per "One Touch Provisioning" substituieren.


    2. Schritt: Die Telefone melden sich per HTTP / HTTPS am Starface Provisioning Server und erhalten ihre Zugangsdaten.


    Welcher der beiden Schritte hängt bei dir?


    Bitte prüfe außerdem, ob die Funktion "Umleitung auf HTTPS erzwingen" aktiv ist und deaktiviere diese, bis die Telefone auf Firmware v7.3.23 sind.


    Viele Grüsse,
    Martin

  • Dass keine Packete ankommen ist schlecht :(


    Mögliche Ursachen:


    - Das Snom schickt gar keine -> hier würde ich mal ein manuelles Firmwareupgrade empfehlen, man weiss ja nie :)


    -Die Packete kommen nicht an, d.h. irgendwas in Deinem Netzwerk frisst sie.

    Yours sincerely / Gruß,
    OH

  • meine Erfahrung:
    Bei Cisco muss Activate Port Fast aktiviert sein. hierzu auch starface wiki.


    Das blöde ist sobald der SIP-Multicast nicht durch das Netz bei der Starface ankommt. Dann kann die auch nicht antworten ;-(.


    Hat mich auch geärgert. Aber zum Glück kann man es ja bei den Switchen einstellen.

    STARFACE PRO ;-D
    installierte Module:
    - reverseloopup Online
    - dbox2 Call Monitor
    - Call-Through
    - Memo an mich


    Router: Fritzbox
    Dect: FRITZ!Fon 7150

  • Es liegt tatsächlich am Switch, denn wenn die Telefone direkt an der Anlage hängen, funktioniert es problemlos. Jetzt muss ich nur noch herausfinden, wie ich bei nem 3Com Superstack Switch dieses Portfast aktiviere.


    Besten Dank für die kompetente Hilfe.

  • Okay, einen kleinen Wermutstropfen gibt es doch noch: neu ausgepackte Telefone muss man trotzdem einmal anfassen, da anscheinend erst Telefone mit Firmwares ab Version 7 unterstützt werden. Leider haben aber alle neu gekauften Telefone die 6.5.13 drauf. Unterstützt Snom erst ab einer bestimmten 7ner Version den Multicast-Mechanismus? Oder wäre es theoretisch möglich, auch die Telefone mit 6er Firmwares einzubinden?

  • Hi,
    die STARFACE würde in deinem Fall die Telefone auch direkt mit der neuen firmware betanken.


    Also den Schritt von 6.5.13 auf 7.3.14 machen und dann auf die von uns empfohlene 7.3.23 updaten.


    Wenn also alles so klappt wie es von uns vorgesehen ist, macht die STARFACE auch das Firmwareupdate komplett.

  • Ja, dann scheint da noch was zu klemmen. Ich habe jetzt zwei neue Snom360 ausgepackt und direkt angehängt, und da geht gar nix. Werde nach den Ferien noch auf diesen Thread zurückkommen.


    Frohe Festtage!

  • Leider haben wir gerade keine fabrikneuen Telefone...


    Verstehe ich nicht. Wie ist denn nun der Zustand der Telefone? Und die Ausgabe von Systeminformation der Telefone?


    Viele Grüsse,
    Martin

  • So wie ich es verstehe, kann er es nicht sagen, da er alle Telefone in Benutzung hat und kein "Fabrikneues" mehr auf Lager mit dem er Testen könnte wie sich die SF verhält.


    netaccess:


    Hast Du ggf. 2 Netzwerkinterfaces an der SF? Ich hatte da auch Probleme mit der Autoprov solange ich beide Interfaces aktiv hatte.


    Gruß
    Markus

    Wer fragt ist ein Narr - für 5 Minuten.
    Wer nicht fragt ist ein Narr - sein Leben lang.

  • Nein, nur 1 Netzwerkinterface, ist ne Professional Appliance. Hab es auch schon auf einer light und einem selbstgebastelten Server versucht, war überall ähnlich.


    Leider haben wir immer noch keine unausgepackten Telefone hier...anscheinend sind ein paar raus, während ich in den Ferien war.


    Ich werde die Geschichte nächsten Monat noch mal in Angriff nehmen.

  • Okay, ich habe nun einen Switch gefunden, mit welchem es absolut zuverlässig funktioniert, und zwar einen 3Com 2426-PWR Plus.


    Was ich nun noch wissen müsste, ist, wie man eigene Snom-Konfigurations-Optionen in die Telefone bekommt, wenn möglich so, dass Sie beim nächsten Starface-Update nicht gleich wieder überschrieben werden. Wir benötigen nämlich noch die Einstellungen:


    - Advanced/Network/NTP time server: <IP der Anlage>
    - Advanced/Behaviour/Auto Dial: 5sec
    - Advanced/Behaviour/Transfer on Onhook: on
    - Advanced/SIP/RTP/Retry interval after failed registration: 10sec


    Auch eine Logik um die Funktionstasten zu verteilen wäre wünschenswert.


  • Was ich nun noch wissen müsste, ist, wie man eigene Snom-Konfigurations-Optionen in die Telefone bekommt, wenn möglich so, dass Sie beim nächsten Starface-Update nicht gleich wieder überschrieben werden. Wir benötigen nämlich noch die Einstellungen:


    Das Template liegt in

    Code
    /var/lib/tomcat5/webapps/localhost/starface/WEB-INF/filetemplates/snomConfig/phone.xml


    Änderungen sind nicht updatesicher und müssen mit großer Sorgfalt durchgeführt werden. Viele Dinge dort hängen unmittelbar mit JAVA Code zusammen und erschließen sich nicht durch "angucken", auch wenn es auf den ersten Blick so aussieht. Dies trifft insbesondere auch Firmware Updates.



    Auch eine Logik um die Funktionstasten zu verteilen wäre wünschenswert.


    Wir arbeiten hier an einem veränderten Konzept, was auch für Soft Label Telefone ein tolles Verhalten (z.B. bei Nutzeranmeldung) ermöglicht. Dies ist jedoch nicht spruchreif. Bis auf Weiteres müssen Funktionstasten per "Tasten aufs Telefon kopieren" vom Nutzer aktiviert werden.


    Viele Grüsse,
    Martin

  • Zum originalen Post:


    Wir haben hier im Lab dieselbe Thematik reproduzieren können.


    SNOM Telefone (snom 320, snom 360) <= v7.3.14 denken zwar, dass sie den Multicast versenden, tatsächlich kommt dieser jedoch nicht im LAN an. Hier ist es mit einem DES-1228P von D-Link mit aktivem Spanning Tree reproduzierbar.


    Ab Firmware Version v7.3.23 und höher wird der Multicast korrekt ins LAN übertragen. Ebenso wird der Multicast korrekt übertragen, wenn Spanning Tree im DES-1228P komplett deaktiviert wird. Ein "Disable" auf dem Port des Telefons genügt nicht!


    Es sind definitiv nur bestimmte Switches betroffen, welche erschließt sich uns leider nicht. Korrekt funktioniert hier Cisco (mit Portfast), HP, Allied Telesis sowie jeder x-beliebige ungemanagte Switch.


    SNOM prüft diesen Fall, mal sehen ob es einen Work-Around gibt. Bis dahin kann ich leider bei betroffenen Endgeräten / Switches nur empfehlen, den Multicast Mechanismus zum Umgehen und wie im WIKI beschrieben die Settings URL händisch zu setzen http://wiki.starface.de/index.…ning_Server_Konfiguration, oder aber Spanning Tree im Switch vorübergehend zu deaktivieren (bis die Telefone auf v7.3.23 upgedated sind).


    Viele Grüsse,
    Martin

    Edited 2 times, last by mkoenig ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!