Starface nach Update keine eingehende Anrufe möglich

  • Guten morgen,


    Wir haben ein Problem und vielleicht kann uns jemand dabei helfen.


    Ausgang war eine Starface mit V6.7, ein und ausgehende Anrufe funktionierten. 2 Sip Telefone TS42 Yealink (Bürotelefone), 1 Analoges Telefon (Notfalltelefon).


    Wir haben die Starface auf V7.3 Upgedatet und danach war es nicht mehr möglich von extern anzurufen. Ausgehende Anrufe funktionieren. Eingehende Anrufe bekommen die Meldung das diesem Telefon

    kein Benutzer zugeordnet ist was aber in den Einstellungen unter Benutzer der fall ist (Telefon wurde Benutzer mit Lizenz zugewiesen)


    Die Log "Support" zeigt folgende Meldung:


    [2023-07-07T15:49:11,171] [ 0004 ] ********* Call created **********

    [2023-07-07T15:49:11,171] [ 0004 ] Starting call routing : SIP/0049621XXXXXXXX-00000004 dial number 00XXXXXXXX CallerId [number=0049XXXXXXXXXX]

    [2023-07-07T15:49:11,228] [ 0004 ] Routing call "CallerId [dialedNumber=00XXXXXXXX, number=0049XXXXXXXXXX]" to number 00XXXXXXXX over service OutgoingService

    [2023-07-07T15:49:11,228] [ 0004 ] CallLeg: 3a52e619-8de4-44c1-b09f-f478820cef99

    [2023-07-07T15:49:11,231] [ 0004 ] Found lines for STATIC routing

    [2023-07-07T15:49:11,231] [ 0004 ] - SIP/0049621XXXXXXXX

    [2023-07-07T15:49:11,234] [ 0004 ] Relevance check in "Call Filter" on callstage onOutgoingCalls

    [2023-07-07T15:49:11,364] [ 0004 ] Channelstate is UP | SIP/0049621XXXXXXXX-00000004

    [2023-07-07T15:49:17,866] [ 0004 ] OutgoingService: Someone with no accountid tried to place an outgoing call

    [2023-07-07T15:49:17,868] [ 0004 ] Got dialstatus DialReturnCodes(hc=CALL_REJECTED, ds=UNKNOWN, cr=UNKNOWN)

    [2023-07-07T15:49:17,872] [ 0004 ] Hangup Cause: CALL_REJECTED | SIP/0049621XXXXXXXX-00000004

    [2023-07-07T15:49:17,872] [ 0004 ] ********* Call finished *********


    Kennt jemand das Problem oder hat dafür eine Lösung ?


    Mfg Luvj

    Edited once, last by Luvj ().

  • Hallo Luvj


    Habt ihr die Module geupdatet?

    Eventuell funkt das Modul "Call Filter" dazwischen, denn von 6.7 auf 7.X hat sich eingies getan, so dass wenn Module nicht geupdatet wurden, diese gar nicht Mehr funktionieren, oder komische Phänomen hervorrufen.


    Ansonsten, schonmal probiert den Benutzer vom Telefon mit *79 abzumelden, und dann mit *77[Interne Rufnr.] neu anzumelden'


    MfG


    Fabian

  • Habe dies nun überprüft, Module sind up to Date und abmeldung/anmledung am Telefon funktioniert ohne Probleme.

    Call Filter ist der Onbound Call Filter von O-Byte. Das Problem besteht mit oder ohne diesen Filter. Im Log vom Call Filter ist auch keine Fehlermeldung



    Habe nun in der PBX log folgendes gesehen


    [2023-07-12 09:56:48,621] VERBOSE[2944][C-00000007] netsock2.c: Using SIP RTP TOS bits 184

    [2023-07-12 09:56:48,621] VERBOSE[2944][C-00000007] netsock2.c: Using SIP RTP CoS mark 5

    [2023-07-12 09:56:48,621] VERBOSE[2944][C-00000007] res_rtp_asterisk.c: 0x7eff7010f890 -- Strict RTP learning after remote address set to: xxx.xx.xxx.xx:32294

    [2023-07-12 09:56:48,622] VERBOSE[11900][C-00000007] pbx.c: Executing [00xxxxxxxx@Telekom_-_Kabel_Zuhause-incoming:1] Set("SIP/0049621xxxxxxxx-00000006", "channelname=Telekom_-_Kabel_Zuhause-incoming") in new stack

    [2023-07-12 09:56:48,622] VERBOSE[11900][C-00000007] pbx.c: Executing [00xxxxxxxx@Telekom_-_Kabel_Zuhause-incoming:2] Set("SIP/0049621xxxxxxxx-00000006", "lineconfigid=1009") in new stack

    [2023-07-12 09:56:48,622] VERBOSE[11900][C-00000007] pbx.c: Executing [00xxxxxxxx@Telekom_-_Kabel_Zuhause-incoming:3] Goto("SIP/0049621xxxxxxxx-00000006", "Telekom_-_Kabel_Zuhause-incoming-manuell,00xxxxxxxx,1") in new stack

    [2023-07-12 09:56:48,622] VERBOSE[11900][C-00000007] pbx_builtins.c: Goto (Telekom_-_Kabel_Zuhause-incoming-manuell,00xxxxxxxx,1)

    [2023-07-12 09:56:48,622] VERBOSE[11900][C-00000007] pbx.c: Executing [0054589522@Telekom_-_Kabel_Zuhause-incoming-manuell:1] Goto("SIP/004962154589522-00000006", "incoming,00xxxxxxxx,1") in new stack

    [2023-07-12 09:56:48,622] VERBOSE[11900][C-00000007] pbx_builtins.c: Goto (incoming,00xxxxxxxx,1)

    [2023-07-12 09:56:48,622] VERBOSE[11900][C-00000007] pbx.c: Executing [00xxxxxxxx@incoming:1] Goto("SIP/0049621xxxxxxxx-00000006", "calling,00xxxxxxxx,1") in new stack

    [2023-07-12 09:56:48,622] VERBOSE[11900][C-00000007] pbx_builtins.c: Goto (calling,00xxxxxxxx,1)

    [2023-07-12 09:56:48,622] VERBOSE[11900][C-00000007] pbx.c: Executing [00xxxxxxxx@calling:1] GotoIf("SIP/0049621xxxxxxxx-00000006", "0?4") in new stack

    [2023-07-12 09:56:48,622] VERBOSE[11900][C-00000007] pbx.c: Executing [00xxxxxxxx@calling:2] AGI("SIP/0049621xxxxxxxx-00000006", "agi:async,,1009,,,,,,,,,,,,,,") in new stack

    [2023-07-12 09:56:48,667] VERBOSE[3857] manager.c: Manager 'actionasterisk' from 127.0.0.1, hanging up channel: SIP/0049621xxxxxxxx-00000006

    [2023-07-12 09:56:48,667] VERBOSE[11900][C-00000007] pbx.c: Spawn extension (calling, 00xxxxxxxx, 2) exited non-zero on 'SIP/0049621xxxxxxxx-00000006'

    [2023-07-12 09:56:48,667] VERBOSE[11900][C-00000007] pbx.c: Executing [h@calling:1] NoOp("SIP/0049621xxxxxxxx-00000006", "HC 21") in new stack

    [2023-07-12 09:56:48,667] VERBOSE[11900][C-00000007] pbx.c: Executing [h@calling:2] Goto("SIP/0049621xxxxxxxx-00000006", "_exit_,0") in new stack

    [2023-07-12 09:56:48,668] VERBOSE[11900][C-00000007] pbx_builtins.c: Goto (calling,_exit_,0)

    [2023-07-12 09:56:48,669] NOTICE[3857] manager.c: Request to hangup non-existent channel: SIP/0049621xxxxxxxx-00000006

    [2023-07-12 09:56:53,234] NOTICE[2944] chan_sip.c: -- Registration for 'xxxxxxxxxxxxx@sf.starface-connect.com' timed out, trying again (Attempt #6)

    [2023-07-12 09:56:53,404] NOTICE[11887] chan_sip.c: Failed to authenticate on REGISTER to 'xxxxxxxxxxxxx@sf.starface-connect.com' (Tries 3)




    chan_sip.c: -- Registration timed out


    Damit kann ich leider nichts anfangen aber scheint als würde eine Registration nicht funktionieren. Ports und IP der Starface sind unverändert und im Router freigegeben (also 5060 5061)


    Mfg Luvj

  • Ich würde mich damit direkt an den STARFACE Support wenden falls du ein STARFACE Partner bist, falls nicht, kontaktiere deinen STARFACE Partner, damit sie ein Ticket eröfnnen.


    Wenn etwas mit der Registrierungvom Connect-Trunk seit dem Update nicht mehr stimmt, sollte dies durch den Support zuerst korrigiert werden, bevor weiter nach Problemen gesucht wird.


    MfG


    Fabian

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!