Telekom CompanyPro "Probably a DNS error for registration to"

  • Hallo Zusammen,


    wir haben bei Kunden mit CompanyPro Anschlüsse, die von alten Anschlüssen umstellen mussten, wie viele das Problem, dass die Starface keine Einwahl mehr hin bekommt. Die Starface meldet:

    [2024-02-09 11:07:18,385] WARNING[38221] chan_sip.c: Probably a DNS error for registration to xxxxx, trying REGISTER again (after 20 seconds)


    Wie habt ihr bei euch die Leitungskonfig für CompanyPro Anschlüsse? Selbst mit dem SIP-Helper bekommen wir aktuell keine Einwahl mehr zustande.

    • New
    • Official Post

    Hallo,

    Die Fehlermeldung, die du erhältst, deutet darauf hin, dass es Probleme mit der DNS-Auflösung gibt, wenn deine Starface-Anlage versucht, sich bei deinem SIP-Trunk-Anbieter (in diesem Fall CompanyPro) zu registrieren. Dies kann mehrere Ursachen haben, und ich werde einige Schritte vorschlagen, die du zur Fehlerbehebung durchführen kannst.


    1. Überprüfen der DNS-Einstellungen

    Stelle sicher, dass die DNS-Server korrekt konfiguriert sind. Es könnte hilfreich sein, zu überprüfen, ob die Starface-Anlage die DNS-Server erreichen kann und ob diese korrekte Antworten liefern. Du könntest versuchen, die DNS-Server temporär auf öffentliche DNS-Server wie Google (8.8.8.8 und 8.8.4.4) oder Cloudflare (1.1.1.1) umzustellen, um zu sehen, ob das Problem dadurch behoben wird.


    2. SIP-Helper/ALG deaktivieren

    In einigen Fällen können SIP-Helper oder ALG (Application Layer Gateway) in Netzwerkgeräten wie Routern oder Firewalls Probleme mit SIP-Registrierungen verursachen. Wenn möglich, deaktiviere diese Funktionen auf deinem Router oder deiner Firewall, um zu sehen, ob das das Problem löst.


    3. Statische IP-Adresse verwenden

    Wenn möglich, konfiguriere die SIP-Trunk-Registrierung mit einer statischen IP-Adresse anstelle eines Hostnamens. Dies umgeht DNS-Probleme, da keine Namensauflösung erforderlich ist. Du musst dies mit deinem SIP-Trunk-Anbieter abklären, um sicherzustellen, dass sie statische IP-Adressen unterstützen.


    4. Netzwerküberwachung und -diagnose

    Verwende Netzwerkdiagnosetools wie ping, traceroute oder dig (für DNS-Anfragen), um zu überprüfen, ob es Verbindungsprobleme oder Latenz bei der Erreichbarkeit der SIP-Trunk-Server gibt.


    5. Aktualisierung der Firmware

    Stelle sicher, dass deine Starface-Anlage auf dem neuesten Stand ist. Firmware-Aktualisierungen enthalten oft Korrekturen für bekannte Probleme, einschließlich solcher, die Netzwerk- und Registrierungsprobleme betreffen können.


    6. Kontakt zum SIP-Trunk-Anbieter

    Wenn das Problem weiterhin besteht, wende dich an deinen SIP-Trunk-Anbieter (CompanyPro). Es ist möglich, dass sie kürzlich Änderungen an ihrer Infrastruktur vorgenommen haben, die Auswirkungen auf die Registrierung haben könnten, oder dass sie spezifische Einstellungen für ihre Dienste empfehlen können.


    Wenn diese Schritte das Problem nicht lösen, wäre es hilfreich, mehr Details zu deiner Konfiguration zu haben, einschließlich der genauen Einstellungen, die du für den SIP-Trunk und die Netzwerkkonfiguration verwendest.

    STARFACE AI-Bot


    Bitte bewerte meine Antwort, wenn sie hilfreich war <3 falls nicht :thumbdown: Danke!


    Die Beiträge des AI-Bots sind ohne zusätzliche menschliche Prüfung veröffentlicht. Wir bitten um euer Verständnis, dass es dabei zu unerwarteten Antworten oder Empfehlungen kommen kann. Weitere Hinweise in diesem Beitrag.


    STARFACE GmbH | Adlerstraße 61 | 76137 Karlsruhe | www.starface.com

  • Welche Starface Version Meinard? Am Freitag hatten wir das Problem noch auf eine Großstörung der Telekom geschoben. Als es am Samstag Vormittag immernoch nicht ging kam mir das etwas komisch vor. Ich "durfte" also im Endeffekt am Wochenende mehrere 8.0.0.11 wegen des gleichen Fehlers updaten. Dabei kam auch eine neue Version der SIP-Helper-Krücke mit und am Ende funktionierte wieder alles. Woran es nun exakt gelegen hat weiß ich nicht. Danke Starface!

  • Selbes Fehlerbild auch hier an einer Compact SIP Appliance mit Version 8.0.0.12. Das Update steht noch aus.


    Ich habe mir sogar die Mühe gemacht und die DNS-Server-Kette verfolgt und am letzten Ende lande ich bei der Telekom. Trotzdem kann der Host tel.t-online.de nicht aufgelöst werden. Ich vermute auch hier ein Problem seitens der Telekom. Das IP Helper Modul habe ich auch mal installiert und geupdatet, aber nun nur mit Standardeinstellungen laufen. Vielleicht kann mir jemand bestätigen, ob die für einen Company Pro 100 Anschluss auch reichen?


    Habe jetzt erstmal ein Fallback über SF Connect gebaut und hoffe, dass die Telekom das bald korrigiert

    Viele Grüße


    Alexander Brüske


    --



    Geschäftsführer:


    Dipl. Inf. Sven Braun

    Nägelseestraße 12

    79288 Gottenheim


    Tel 07665-80830 0

    Fax 07665-80830 99


    http://www.braun-its.de

    Edited once, last by Alexander Brueske ().

  • Fehler hat sich dann heute morgen verflüchtigt und ich habe dann noch die AuthUser-Methode beim Kunden angewandt und der Kunde konnte wieder telefonieren. Also scheinbar primär ein Telekom-Problem

    Viele Grüße


    Alexander Brüske


    --



    Geschäftsführer:


    Dipl. Inf. Sven Braun

    Nägelseestraße 12

    79288 Gottenheim


    Tel 07665-80830 0

    Fax 07665-80830 99


    http://www.braun-its.de

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!