Rückkoppelung in der Telefonie

  • Liebe Community,

    ich hoffe, dass uns jemand bei folgendem Problem helfen kann.

    Wir haben bei einem unserer Kunden eine Onprem Starface Pro TK-Anlage (Hardware Version 6) im Einsatz, bei der es sowohl bei internen als auch bei externen Gesprächen zu Rückkopplungen in der Audioübertragung kommt.

    Beschreibung des Problems:

    Während eines Gespräches, häufiger bei internen Gesprächen, hört man sich nach ca. 10 bis 15 Sekunden selbst. Es handelt sich um eine Art Echo, das in der Regel sehr leise ist, ab und zu aber auch lauter wird. Der Fehler tritt sporadisch auf :(

    Was wir bisher getestet haben und als Fehlerquelle ausschließen können:

    1. Fehlverhalten tritt mit verschiedenen UCC-Client-Versionen, verschiedenen Headsets auf verschiedenen Windows-Rechnern (Windows 10 und 11) auf.

    2. Fehlverhalten tritt auch bei Gesprächen auf, die über Tischtelefone (Yealink T-54W zu Yealink T54-W) geführt werden.

    3. Das Fehlverhalten tritt sowohl bei ISDN- als auch bei SIP-Verbindungen auf. (Der Kunde hat gleichzeitig auf SIP + Rufnummernportierung umgestellt).

    4. Fehlverhalten tritt auch auf, wenn ich mich mit meinem Starface-Benutzer (wir nutzen selbst eine Starface-Cloud) an einem der Rechner im Unternehmen des Kunden einlogge und mit einem Benutzer aus dem Unternehmen telefoniere.

    5. Fehlverhalten tritt nicht auf, wenn ich mich mit meinem Starface-User (Starface-Cloud) an einem der Rechner im Unternehmen des Kunden einlogge und ein externes Gespräch führe.

    6. Das Fehlverhalten tritt auch dann auf, wenn ich die Starface-TK-Anlage am Router (der Kunde hat einen Lancom 1781EF+ als Gateway im Einsatz) zusammen mit einem neu installierten Client über einen separaten Switch an einem separaten Port anschließe.


    Mit Punkt 5 und 6 schließe ich das Netzwerk als mögliche Fehlerquelle aus. (Meine Vermutung war zunächst, dass das Netzwerk das Problem ist).

    Fazit:


    Also immer dann, wenn die Starface des Kunden ins Spiel kommt, tritt das Fehlverhalten auf. Deshalb deutet für mich alles auf die Starface hin. Da ich bereits alle möglichen Kreuztests durchgeführt habe, bin ich mit meinem Latein am Ende. Hat jemand von Euch mal solch ein Fehlverhalten gehabt und konnte die Ursache ausfindig machen?

    Bin auf alle Fälle für jeden Tipp von Euch dankbar! :)

  • Während eines Gespräches, häufiger bei internen Gesprächen, hört man sich nach ca. 10 bis 15 Sekunden selbst. Es handelt sich um eine Art Echo, das in der Regel sehr leise ist, ab und zu aber auch lauter wird. Der Fehler tritt sporadisch auf

    Ist das Echo aktuell oder das Audio das 10-15 Sekunden vorher entstanden ist?

    Wie ist denn die Hardware Auslastung der Anlage bei einem Gespräch?

  • Hi slu,

    vielen Dank für die Unterstützung. Ich bin kein Linux-Experte aber die Auslastung scheint in Ordnung zu sein. Es sind insgesamt 17 User auf der Starface angelegt. Während der Überprüfung haben zwei Mitarbeiter telefoniert. Fehlverhalten auch da vorhanden gewesen. Ich poste Dir dazu mal was htop mir meldete:

    image.png
    -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Und was der Befehl top meldete:

    top - 15:52:11 up 7 days, 3:21, 1 user, load average: 0.04, 0.21, 0.17
    Tasks: 187 total, 1 running, 186 sleeping, 0 stopped, 0 zombie
    %Cpu0 : 0.0 us, 0.0 sy, 0.0 ni,100.0 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
    %Cpu1 : 0.0 us, 0.0 sy, 0.0 ni,100.0 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
    %Cpu2 : 0.0 us, 4.8 sy, 0.0 ni, 71.4 id, 0.0 wa, 23.8 hi, 0.0 si, 0.0 st
    %Cpu3 : 10.0 us, 15.0 sy, 0.0 ni, 75.0 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
    KiB Mem : 1910420 total, 71064 free, 1561736 used, 277620 buff/cache
    KiB Swap: 3129340 total, 2913276 free, 216064 used. 131084 avail Mem

    PID PPID USER PR NI VIRT RES SHR S %CPU P %MEM SWAP TIME+ COMMAND
    1393943 1381696 root 20 0 54324 4332 3752 R 16.7 3 0.2 0 0:00.06 top -b -n 1
    1207 1 root 20 0 486332 8772 3420 S 5.6 0 0.5 9288 129:05.00 /usr/libexec/platform-python -Es /usr/sbin/tuned -l -P
    895343 1 tomcat 20 0 5046232 868528 15076 S 5.6 3 45.5 52792 21:22.48 /usr/bin/java -Djava.util.logging.config.file=/opt/tomcat/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager+
    1 0 root 20 0 238576 5376 3224 S 0.0 2 0.3 940 5:05.59 /usr/lib/systemd/systemd --system --deserialize 19
    2 0 root 20 0 0 0 0 S 0.0 2 0.0 0 0:00.66 [kthreadd]
    3 2 root 0 -20 0 0 0 I 0.0 0 0.0 0 0:00.00 [rcu_gp]
    4 2 root 0 -20 0 0 0 I 0.0 0 0.0 0 0:00.00 [rcu_par_gp]
    5 2 root 0 -20 0 0 0 I 0.0 0 0.0 0 0:00.00 [slub_flushwq]
    7 2 root 0 -20 0 0 0 I 0.0 0 0.0 0 0:00.00 [kworker/0:0H-events_highpri]
    10 2 root 0 -20 0 0 0 I 0.0 0 0.0 0 0:00.00 [mm_percpu_wq]
    -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    Zu Deiner Frage "Ist das Echo aktuell oder das Audio das 10-15 Sekunden vorher entstanden ist?"

    Das Echo ist ca. 1 Sekunde zeitversetzt. Also kurz nachdem man etwas gesagt hat, hört man das Gesagte ein zweites Mal. Mit den 10-15 Sekunden meinte ich, dass das Fehlverhalten nach etwa 10-15 Sekunden beginnt. Es ist also nicht sofort da, sondern kommt erst in der Mitte des Gesprächs.

    Um sich das besser vorstellen zu können, kann man folgendes machen: Man ruft sich über Starface z.B. auf dem eigenen Handy an und legt es neben sich, so dass, wenn man etwas sagt, das Mikrofon des Handys das Gesagte aufnimmt und man sich dann über das Headset hört.

    PS - Die Mitarbeiter sitzen nicht im selben Raum und sind über zwei Stockwerke verteilt, dass man sich dadurch doppelt hört, kann demnach nicht der Fall sein.

    VG

  • Könntest du mal unter Admin ==> Systemstatus ==> Diagnose ein Diagnosepaket erstellen?

    "Start" drücken.
    Anruf mit Echo erzeugen
    "Stop" drücken
    Herunterladen.

    Könntest du mir dieses per PN Zustellen, ich würde das gerne mal ansehen.

    Bitte nicht ins Thread Posten, es enthält eine Menge an Informationen die den Kunden/IP Strukturen ect. Preisgeben.

    MfG

    Fabian

  • Load hat die Anlage nicht viel, aber der RAM ist voll und es wandert schon was in den Swap.

    War das die Last unter einem Gespräch mit dem Echo?

    Hi slu, ja, bei diesem Anruf haben zwei Mitarbeiter intern einen Anruf getätigt, bei dem es zu dem fraglichen Fehler gekommen ist.
    Aber auch nach dem Anruf war die Speicherauslastung nicht wesentlich anders und ziemlich gleich.

    JFYI - Ich bin FabianZ's Anweisung gefolgt und habe während des Echos ein Diagnosepaket erstellt und per PN an FabianZ geschickt. Vielleicht wissen wir bald mehr...

    Wichtiger Hinweis - Der Fehler ist diesmal bei mir aufgetreten. Also ein externer Anruf zum Kunden und ich als Anrufer habe mich selbst gehört. Der betroffene Kunde hat das Echo in dieser Aufnahme nicht selbst gehört. (Mein Headset ist aber in Ordnung und nicht die Fehlerquelle).

    Danke und VG

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!