Starface hinter Fritzbox - die einfache Lösung

  • Moin,


    habe mich gestern endlich mal rangetrau meine Fritzbox zu patchen um das elende 5060-Thema aus der Welt zu schaffen. Es ist einfacher als gedacht!


    Folgende Konfiguration:


    Konfig.jpg


    FritzBox (7390 - aber im Prinzip gilt das für alle anderen Modelle gleichlautend) hat keine eigene Telefoniefunktion mehr, sondern diese an die Starface abgetreten. Bleibt also der Internetzugang und die Aufgabe als DECT-Basis. Da die FritzBox bekanntermassen sich alles was auf Port 5060 passiert unter den Nagel reisst, ist es erstmal nicht möglich VoIP-Verkehr durch die FritzBox zur Starface zu routen. Die hier immer wieder zu lesende Empfehlung lautet 5061 als alternativen Port in der Starface zu verwenden, was allerdings zu haufenweise Konfigurationsaufwand in den Endgeräten führt und damit tendenziell auch Fehler birgt.


    Als einfache Alternative habe ich die Einstellungen zum Port 5060 in der FritzBox auf 5061 umgebogen. Dazu den FBEditor (ein kleines Java-Programm, das auch auf dem Mac läuft) laden und die config-Dateien der FritzBox einlesen. Alle Stellen mit 5060 finden und auf 5061 umbiegen. Fertig. Danach kann ich passende Portfreigaben für 5060 TCP/UDP sowie RTP und den Starface-Client erstellen und meine iPhones als normale Nebenstellen über meinen DynDNS Eintrag oder ggf. eine fixe IP an die Starface anbinden :)


    screenshot 2012-01-03 um 11.17.14.jpg


    Gruß Stefan

  • Moin,


    ganz so einfach scheints dann doch nicht zu sein (möglicherweise auch div. FW-Updates der FB geschuldet … ?). Aktuell kämpfe ich damit das ich zwar von außen mich auf die Starface verbinden kann. Initiierte Gespräche auch durchgestellt werden - sprich: die Nebenstelle klingelt, aber es kommt kein Ton an. Kann mir irgendwer eine Idee liefern, in welche Starface-Logs ich da mal einen Blick werfen sollte, um zu sehen was da passiert (oder eben nicht passiert), resp. hat jemand eine Idee, was ich dafür wie per WireShark mitschneiden sollte.


    Ich komme aktuell mit zwei Konfigurationen zu identischen Ergebnissen: einmal mit einem iPhone/Bria welches sich von außen in die wie oben beschriebene SF einwählt. Zum zweiten mit einer zweiten FritzBox eines HomeOffices. Dort ist als VoIP-Provider die DynDNS-Adresse der SF eingetragen und die Credentials eines Telefons (Verbindung wird in der SF mit grün quittiert) und an der FritzBox hängt ein GigaSet DE410 IP Pro als Nebenstelle. Sprich: die HomeOffice-FB ist ohne die 5060/5061 Modifikation ausgestattet, weil wirklich VoIP-Anlage, die FB in der Zentrale ist wie oben beschrieben gepatched um die Durchleitung zu ermöglichen.


    VPN zwischen den FritzBoxen würde ich gerne vermeiden, weil bei mir der hinter der Zentral-FB stehende OS X Server dafür zuständig ist. Arbeitet einfach deutlich geschmeidiger mit Mac-Clients als die FB als VPN-Server.


    Gruß Stefan

  • Moin,


    ganz so einfach scheints dann doch nicht zu sein (möglicherweise auch div. FW-Updates der FB geschuldet … ?). Aktuell kämpfe ich damit das ich zwar von außen mich auf die Starface verbinden kann. Initiierte Gespräche auch durchgestellt werden - sprich: die Nebenstelle klingelt, aber es kommt kein Ton an. Kann mir irgendwer eine Idee liefern, in welche Starface-Logs ich da mal einen Blick werfen sollte, um zu sehen was da passiert (oder eben nicht passiert), resp. hat jemand eine Idee, was ich dafür wie per WireShark mitschneiden sollte.


    Das klingt erstmal nach einem klassischen NAT Problem. Ist in der STARFACE eine "Externe Adresse" hinterlegt, die im SIP signalisiert werden kann? Das Szenario mit SIP Servern hinter NAT funktioniert so, dass die Router/Firewall (hier die Fritz!Box) den Layer3 per Portforwarding sicherstellt, und die STARFACE muss sich um Layer4+ kümmern. Dies bedeutet, dass im SIP nach extern nicht die tatsächliche (private) IP der Anlage genutzt wird, sondern die Öffentliche. Auch die Option "Hinter Nat" muss aktiviert werden


    Darüber hinaus müssen für RTP entsprechend auch die Ports 10000-20000 per Portforwarding weitergeleitet werden.


    Viele Grüsse

  • Bingo - NAT war's. Hatte die SF auch mal testhalber in die DMZ gestellt um Portprobs auszuschliessen. Mit aktivierter NAT-Option in den Settings und den im wiki beschriebenen Port-Forwards (die waren vorher schon korrekt drin) anstelle des DMZ ging's dann.

  • also heisst das, einfach nur den port 5060 auf 5061 in der FB umbiegen und dann in der SF "hinter NAT" auf ja stellen? und dann kann ich ohne probleme die SF hinter der FB nutzen?

    Gruß
    Marcel

  • Das geht nur leider nicht... Bitte an AVM als Wunsch an die Softwareentwicklung melden! Ebenso an Starface!


    Grüße,


    d i r k

    Beste Grüße & bleibt gesund


    d i r k

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!