iSoftPhone unreliable, trying to setu ZoIPer

  • Dear Forum, after using iSoftPhone for a while as the SIP client on my mac, and after having it stuck more time daily for no obvious reason, I'm continuing to search for a SIP client to use with Starface while waiting for a new release of X-Lite which is not yet supported on Leopard.
    Latest is ZoIPer. Small, simple, looking good, having option for both SIP and IAX accounts.


    There is little to configure but with SIP I entered
    Domain: the IP of my starface server
    Username: the telephone name of the SIP phone configured in Starface
    Password: the password of the SIP phone configured in Starface


    However I get this message in the ZoIPer log when I try to register it


    15:21:29: Registering user 'zsoltXllite@192.168.1.111'
    15:21:29: Rejected registration for 'zsoltXllite@192.168.1.111' with cause 'service or option unavailable'


    If I got for IAX account type, the options are:
    Server Hostname/IP: the IP of my starface server
    Username: the telephone name of the SIP phone configured in Starface
    Password: the password of the SIP phone configured in Starface
    Caller ID Name: zsoltXllite
    Caller ID Number: 222


    Here I get a message:
    15:30:49: Registering user 'zsoltXllite@192.168.1.111'
    15:30:49: Rejected registration for 'zsoltXllite@192.168.1.111' with cause 'facility rejected'


    Where should I start to troubleshoot this?


    Thanks
    Zsolt

  • I found SJPhone to work fine with OSX Leopard and Starface. So far is stable. So to troubleshoot zoiper is not so urgent, or necessary any more, but if you want, then let me know.
    Zsolt

  • We tried Zoiper too but we got the same result on Leopard: "cause 'service or option unavailable' ".
    The Invite packet is not send to STARFACE Server, so we're sure that the problem is the Soft-Client in combination with Leopard.


    Regards,
    Philipp

    Gruß / Regards
    Philipp

  • The we stick to SJPhone, so far it is OK, if I run into problems I will post it here.
    Thanks for reply
    Zsolt

  • Hi Zmagyar,
    could you please write to us at mac_support@xdsnet.de?
    We would be more than happy to help you resolve the problem with iSoftPhone.


    For example what version of iSoftPhone are you using?
    Could you please also send us the crash log?
    ~/Library/Logs/CrashReporter/iSoftPhone.crash.log where ~ is the user's home folder.


    The console log might also provide some information:
    - open Console (Applications/Utilities)
    - clear the console
    - try to launch iSoftPhone
    - copy and paste Console contents into mail - send us


    Best Wishes,
    iSoftPhone Support

  • Hi may, it does not work for me, it registers (the last version didn't) but when I place an outgoing call I get in de zoiper debug log this
    15:47:14: Line 1 : outgoing call to '287467'
    15:47:14: Line 1 : failed (bearercapability notavail)
    and ti does not even arrive to the astersik, as there is no log entry there


    If I try to dial from Starface, it rings once but then in the zoiper log I get:
    15:46:35: Line 1 : ringing 'Starface-dialer <STARFACE>'
    15:46:35: Line 1 : rejected (service or option not implemented)
    or once I got
    15:49:26: Line 1 : ringing 'Starface-dialer <STARFACE>'
    15:49:26: Line 1 : rejected (service or option not implemented)
    15:49:26: No line found in onCallFailure.


    In the asterisk log I get:
    -- Got SIP response 415 "Unsupported Media Type" back from 192.168.50.10


    Any idea?

  • Quote

    -- Got SIP response 415 "Unsupported Media Type" back from 192.168.50.10


    probably there exists a codec problem with your Soft-Client. You have to configure the codecs which should be used per line, so please check if you have configured the codecs PCMA / PCMU for your preferred SIP line.


    Regards
    Philipp

    Gruß / Regards
    Philipp

  • You were right, the PCMA and PCMU codecs were not selected by default, I added them and now it works. Thanks. I promissed however to iSoftphone team that I will test theirs now, so at the moment Zoiper has to wait, but it is good to know that there are alternatives.
    Thanks
    Zsolt

  • May, the saga goes on...
    OK, now I can register and it works after I set the codecs manually, but
    Today I decided to give it a try for real, and after a while it unregisters itself.
    There is nothing in the asterisk log, but in the zoiper debug log there is this:
    10:51:39: Rejected registration for 'zsoltXllite@192.168.1.111' with cause 'bearercapability notauth'
    any idea?
    Thanks
    Zsolt

  • I'm sorry, but

    Code
    bearercapability notauth

    doesn't say anything to us.
    Maybe there are some support informationen directly from zoiper.


    We will test zoiper by ourselves - perhaps we get the same error message as you got.


    Regards
    Philipp

    Gruß / Regards
    Philipp

  • hi Zoa, I'm glad somebody showed up from attractel as the product look quite nice but the site does not show to much support info. Anyway, for the start, I can't adjust the speaker level. The mic level works fine but the speaker is always the same no matter I move the slider left right. I guess for this you do not need the sniffer log. The version is the latest AFAIK 2.01 417, OS is Leopard all the latest patches.
    Let me know if you need more.
    I'm interested for zoiper as it is intel native while the SJPhone is not, so if we nail down all the bugs then I guess we might move alltogether to it.
    Thanks in advance for your help
    Zsolt

  • Hello,


    Can you email me the audio card you are using ? Do you have any usb headset you could try it with ? (To see if it depends on the audio card)

  • Hi Zoa,


    The last two weeks I was quite busy, but fixing all issues with the SIP client is the utmoast interst to me. And although I appreciate the forums, if anyhow possible I would really like to go fast with you and communicate directly over the email. Once we cleared out all the issues I would be more then happy to summarize it down in this forum. Is this an option to you?


    The current issues we have are:
    - sound level
    - occasional echo
    - on some macs the client does not want to register
    - the busy line is not recognized correctly
    sending logs over the forum wold not be very convenient.
    Let me know your thoughts. You can reach me directly at zmagyar@orchestra.de

  • Dear All, considering I started this thread I just want to conclude it. Mr.Zoa did not come back to me, but nevertheless in the mean time there was one update to zoiper (2.02) and this one works fine.
    Apart from X-Lite which I think is still in beta, this is the only Intel native SIP client on Mac. I'm using it daily for several months already and is working fine. The only feature I miss is concall option, but it is available in the paid version. In addition you can always use Starfact to make the concall for you, so it is not a big deal. If you use USB headset, make sure it is plugged in _before_ you start zoiper as later it will not want to switch to it.
    SOme users are using SJPhone and that one is workng fine too, just is not intel native
    The busy tone problem was not Zoiper problem, it was a Starface problem and is fixed in version 3
    FYI
    zsolt

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!