Telefon Hintergrundbilder

  • Nachdem hier im Forum einige Module aufgetaucht sind, die das Setzen von Hintergrundbildern auf einzelnen Endgeräten unterstützen, wünsche ich mit diesem Modul viel Spaß.

    Ich hatte bisher auf eine Veröffentlichung verzichtet um bestehende kommerzielle Module nicht zu untergraben...

    Endgeraete_Firmenlogo_v16.sfm

    Unterstützt werden Endgeräte folgender Hersteller:
    * Alcatel
    * OpenStage
    * Panasonic
    * snom
    * tiptel
    * Yealink

    Nach dem Hochladen von Bildern im Modul und dem Übernehmen oder Speichern der Modulkonfiguration ist ein Diensteneustart notwendig. Anschließend werden die hochgeladenen Bilder im Modul selbst und nach einem Neustart der Endgeräte auf diesen sichtbar.

    Endgeräte Firmenlogo.jpg

  • Moin,

    für das Alcatel Temporis IP800 ist eine Dateigröße von 320 x 160 px hinterlegt. Lt. Gerät sind da aber nur maximal 236 x 82 px erlaubt. Entsprechend passiert da nach dem Dienstneustart auch nix, resp. kann ich das erzeugte .dob-Bild auch nicht direkt ins Telefon laden :-o

    Gruß Stefan

  • Hi Stefan,

    vielen Dank für den Hinweis!

    Die 320x160px habe ich aus dem Datenblatt des Telefons. Vermutlich ist die physikalische Auflösung des Displays höher, als der Bereich, der für Hintergrundbilder zur Verfügung steht. Ich werde das in der nächsten Modulversion anpassen.

  • Moin,


    Die 320x160px habe ich aus dem Datenblatt des Telefons. Vermutlich ist die physikalische Auflösung des Displays höher, als der Bereich, der für Hintergrundbilder zur Verfügung steht.

    würde ich auch vermuten, allerdings wird selbst die vorgegebene Auflösung dann noch gestaucht:

    vorlage.png

    darstellung.jpg

    Möglicherweise passiert das aber schon bei der Umwandlung von BMP in dieses obskure .dob-Format.

    der Vollständigkeithalber:

    temporis-ip-800-logo-size.png

    Gruß Stefan

  • Der im Modul angegebene Link zum Konvertieren von BMP zu DOB referenziert nicht mehr auf die Seite, die einen möglichen Konverter enthält. Gibt es hier eine weitere Möglichkeit BMP zu DOB zu konvertieren?

    AP - FG

  • Hallo Fabian,

    würde nochmals die Frage eines Vorredners aufnehmen.

    Wie sieht es mit eines Updates im Bezug auf das Yealink T48G aus?
    Haben eine ganz neue Anlage und hatte voller Freude dein Modul importiert und gesehen, dass Yealink Modelle nur bis zu 46 unterstützt werden.
    Gibt es von deiner Seite aus schon ne Idee bis wann eine neue Version kommen wird?


    Vielen Dank schonmal im Voraus für das super Modul!

    Lg
    Matze

  • Das wird ein "Fluxpunkt"-Shop, der den ganzen Vorgang einer Modulbestellung automatisieren soll. Der Shop erzeugt gleich die Lizenzen, so dass der Kunde keine Wartezeit mehr hat. Außerdem wird es möglich sein, Testlizenzen auszustellen.

    EDIT: Ach ja, und die neuen Module werden Redundanzanlagen besser unterstützen und nicht mehr anhand der Hardware ID lizenziert, was im Falle eines Anlagentauschs oder einer Neuinstallation Probleme macht ;)

  • Hi Fabian,

    ich versuch grad mit deinem Modul ein Logo auf ein OpenStage 40 zu laden. Leider ladet er die Datei nicht, was ich nicht ganz versteh.
    Es hat die richtige Größe 144 x 32 Pixel und ist im BMP-Format gespeichert. (Dienste werden neugestartet sowie Telefon)

    OS 60 und 80 ändert er ohne Probleme, nur beim 40 macht er Mucken.
    Lustigerweise wenn ich das Orignallogo vom Starface-Wiki rauflade nimmt er es.

    Hat hier wer eine Idee, woran das liegen kann.

    Thx

  • Im Moment werden fast Module generalüberholt und im Zuge der Einführung eines neuen Shopsystems direkt aus diesem heraus herunterladbar sein. Ich hoffe, dass das bis Mitte Februar steht.

    Wie siehts es denn mit eurem fluxpunkt. Store aus?
    Auf eurer Seite finde ich nichts und erwähnt wird das auch nirgends. Wollte mich mal schlau machen denn der Februar ist ja schon fast rum ;)

    LG
    Matthias

  • Moin,

    würde ich auch vermuten, allerdings wird selbst die vorgegebene Auflösung dann noch gestaucht:

    vorlage.png

    darstellung.jpg

    (...)
    Gruß Stefan

    Ich weiß der Post ist schon alt, aber das Telefon hat keine Quadratischen Pixel [sic!]. Sondern Rechteckige Pixel. Deswegen ist das Bild auch "gestaucht". Sachen gibt's in China, die gibt's sonst nur selten.

    Frag mal Barbara Mauve wie viel Spaß sie hatte damals das Starface Logo hierfür zu feinzutunen ;)

    Edited once, last by mkoenig (July 28, 2015 at 2:36 PM).

  • Hallo zusammen,

    vielen Dank für das Modul.

    Ich habe es importiert und ein Bild hochgeladen.
    Dieses wird auch im Modul angezeigt.

    Nur leider passiert nach Diensteneustart und Telefonneustart gar nichts.
    Telefone sind "Yealink T46G".
    Das Bild direkt im Telefon hochladen und aktivieren funktioniert einwandfrei.

    Vielleicht hat jemand ein Tipp für mich?

    Danke für die Hilfe :)

  • Das Bild wird nur ersetzt und aktiviert, wenn es nicht schon eine Datei mit dem Namen "t46g.jpg" auf dem Telefon gibt. Lösch die Grafik auf dem Telefon und starte eine Auto Provisionierung, dann lädt sich das Telefon deine Grafik.

    Viele Grüße,

    Andreas Stein
    IT Fabrik Systemhaus GmbH & Co. KG

    STARFACE Excellence PLUS Partner

  • Danke für den Tipp :)

    Allerdings heißt die Grafik bei mir nirgends t46g.jpg weder auf meinem Telefon noch im Modul auf der Starface.

    Ist das vielleicht der Fehler, muss die Datei im Modul t46g.jpg heißen, stand das irgendwo?

    Ich werde es testen und berichten.

    Gruß
    TD

  • Bitte das Telefon einmal auf Werkseinstellungen zurücksetzen (lange die OK-Taste drücken) und schauen, ob das Bild dann erscheint. Das Bild erscheint nicht, wenn im Telefon explizit ein anderes Bild ausgewählt wurde. Das Modul ersetzt lediglich die Bilddatei auf der STARFACE. Übernommen werden die Bilder als nur, wenn die Endgeräte die Datei neu abrufen.

  • Aloha!

    ich habe das selbe Problem.
    Ist eine Lösung bekannt? Ist der Dateiname relevant?

    Hi Fabian,

    ich versuch grad mit deinem Modul ein Logo auf ein OpenStage 40 zu laden. Leider ladet er die Datei nicht, was ich nicht ganz versteh.
    Es hat die richtige Größe 144 x 32 Pixel und ist im BMP-Format gespeichert. (Dienste werden neugestartet sowie Telefon)

    OS 60 und 80 ändert er ohne Probleme, nur beim 40 macht er Mucken.
    Lustigerweise wenn ich das Orignallogo vom Starface-Wiki rauflade nimmt er es.

    Hat hier wer eine Idee, woran das liegen kann.

    Thx

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!