Starface Fritzbox 7490 _ username mismatch

  • Hallo Zusammen,


    Ich versuche eine STARFACE PBX Server Compac hinter einer Fritzbox 7490 zu betreiben.
    Nach einigen Stunden im Internet und dem Durchlesen diverser Foreneinträge ist das der Stand der Dinge:

    • Ausgehende Anrufe funktionieren
    • Eingehende Anrufe gehen jedoch nur, wenn ich bei der Fritzbox genau ein Telefoniegerät für alle Rufnummern einrichte und analog dazu genau eine Leitung in der Starface


    Wenn ich mehrere Telefoniegeräte einrichte (für jede Rufnummer eins) mit entsprechender Leitung in der Starface und jeweils einem eigenen Provider, bekomme ich folgende Nachricht:

    Code
    [Mar 23 11:49:23] WARNING[2772][C-00000015] chan_sip.c: username mismatch, have <623>, digest has <625>
    [Mar 23 11:49:23] NOTICE[2772][C-00000015] chan_sip.c: Failed to authenticate device <sip:*******@fritz.box>;tag=D1539F2A7608E03E
    [Mar 23 11:49:57] WARNING[2772][C-00000016] chan_sip.c: username mismatch, have <623>, digest has <626>
    [Mar 23 11:49:57] NOTICE[2772][C-00000016] chan_sip.c: Failed to authenticate device <sip:*******@fritz.box


    Irgendwas funktioniert also mit der Username-Zuordnung nicht. Der Eintrag digest ist der korrekter Username in der entsprechenden Leitung. Es scheint aber so, als ob die Fritzbox nicht den dort eingerichteten Username nimmt, sondern einen anderen. Ich habe mehrfach geprüft, ob ich die Telefoniegeräte in der Fritzbox vielleicht falsch eingerichtet habe bzw. dort eine falsche Nummernzuordnung vorgenommen habe, doch das ist nicht der Fall.


    Weiß irgendjemand Rat?

  • Wenn ich mehrere Telefoniegeräte einrichte (für jede Rufnummer eins) mit entsprechender Leitung in der Starface und jeweils einem eigenen Provider, bekomme ich folgende Nachricht:

    Code
    [Mar 23 11:49:23] WARNING[2772][C-00000015] chan_sip.c: username mismatch, have <623>, digest has <625>
    [Mar 23 11:49:23] NOTICE[2772][C-00000015] chan_sip.c: Failed to authenticate device <sip:*******@fritz.box>;tag=D1539F2A7608E03E
    [Mar 23 11:49:57] WARNING[2772][C-00000016] chan_sip.c: username mismatch, have <623>, digest has <626>
    [Mar 23 11:49:57] NOTICE[2772][C-00000016] chan_sip.c: Failed to authenticate device <sip:*******@fritz.box


    Irgendwas funktioniert also mit der Username-Zuordnung nicht. Der Eintrag digest ist der korrekter Username in der entsprechenden Leitung. Es scheint aber so, als ob die Fritzbox nicht den dort eingerichteten Username nimmt, sondern einen anderen. Ich habe mehrfach geprüft, ob ich die Telefoniegeräte in der Fritzbox vielleicht falsch eingerichtet habe bzw. dort eine falsche Nummernzuordnung vorgenommen habe, doch das ist nicht der Fall.


    Weiß irgendjemand Rat?


    Auf Grund der selben Hostadresse landen die eingehenden Anrufe im falschen Leitungs-Kontext.
    Ich gehe davon aus, das du ein Providerprofil für alle Fritz!Box-Leitungen verwendest, das ist Voraussetzung.


    Dort einfach den Haken bei Leitungsübergreifende Nummernerkennung setzen und die Fritz!Box Leitungen einmal umbenennen, sonst wird die Änderung im Profil nicht auf die Leitungen übernommen.


    Fritz beansprucht den Port 5060. Gerne möchte ich die SF umstellen auf 5061. Dazu gibt es Anleitungen. Die funktionieren aber nicht.


    Ist hier nicht das Problem. SIP Pakete werden ja korrekt an die STARFACE geforwarded.


    • Kill den Telefoniedienst der Fritz!Box: entfern' alle Rufnummern, deaktiviere SIP, start die Fritz!Box neu. Fertig, Port 5060 kann man jetzt forwarden.
    • 5061 ist ja jetzt auch anderweitig belegt (SIP/TLS).


    61200996.jpg

  • DerGerät
    Interessant, danke. Hast du denn auch eine Idee, die SF auf Port 5061 umzustellen? Ich brauchte eigentlich das, da ich SIP auch über Fritz nutzen muss.


    Wenn ich die SF nach Anleitung auf 5061 umstelle, kann ich keine Telefone mehr registrieren, da die Firewall in der SF das dann nicht mehr zulässt.

  • DerGerät
    Interessant, danke. Hast du denn auch eine Idee, die SF auf Port 5061 umzustellen? Ich brauchte eigentlich das, da ich SIP auch über Fritz nutzen muss.


    Wenn ich die SF nach Anleitung auf 5061 umstelle, kann ich keine Telefone mehr registrieren, da die Firewall in der SF das dann nicht mehr zulässt.


    Ich würde davon abraten den SIP Port an der STARFACE zu verändern. Zumal 5061/tcp für SIP/TLS reserviert ist. Schalt' einfach sauber den Telefoniedienst der Fritz!Box ab, dann hast du keine Probleme mehr.
    Eine entsprechende Anleitung findet sich hier im Forum. Die Essenz: Alle Telefoniegeräte in der FB löschen, alle Rufnummern und VoIP Account löschen, FB neustarten. Dann kannst du auch 5060/udp forwarden.


    Das Firewallproblem lässt sich durch eine Datenbankanpassung verändern, kann mir aber nicht vorstellen, das eine Änderung des SIP Ports deiner STARFACE auf dauer gut geht.

  • Ich würde davon abraten den SIP Port an der STARFACE zu verändern. Zumal 5061/tcp für SIP/TLS reserviert ist. Schalt' einfach sauber den Telefoniedienst der Fritz!Box ab, dann hast du keine Probleme mehr.
    Eine entsprechende Anleitung findet sich hier im Forum. Die Essenz: Alle Telefoniegeräte in der FB löschen, alle Rufnummern und VoIP Account löschen, FB neustarten. Dann kannst du auch 5060/udp forwarden.


    Das Firewallproblem lässt sich durch eine Datenbankanpassung verändern, kann mir aber nicht vorstellen, das eine Änderung des SIP Ports deiner STARFACE auf dauer gut geht.


    Ja, das ist richtig, offenbar ist es keine gute Idee, die SF auf 5061 umzukonfigurieren. Ich bin deshalb wieder zurück auf 5060.
    Das Firewallproblem sollte sich durch eine Datenbankanpassung verändern lassen, wie in der Anleitung beschrieben. ABER: Trotz genauer Vorgehensweise nach Anleitung besteht das Firewallproblem. Vielleicht ist das von der SF-Version abhängig.


    Allerdings: SF auf 5060 und Fritz mit SIP auf 5060 geht trotzdem völlig einwandfrei. Die SF sucht sich einen anderen (hohen) Port automatisch um SIP-Leitungen anzubinden. Das läuft problemlos.


    Den SIP-Dienst in der Fritz abzuschalten ist sicher die sauberste Lösung. Aber:


    Nachteil 1: Ich habe eine SIP-Leitung ohne Zugangsdaten, die sich nur mit Fritz verbindet. Das Problem sollte zukünftig behobeb sein, wenn Zwangsrouter nicht mehr zulässig sind. Ich weiss nur noch nicht, ob das dann auch für alte Verträge gilt, oder ob man einmal kündigen muss, um in den Genuss zu kommen.


    Nachteil 2: Mir ist es gar nicht so unrecht, dass sich eine einzige SIP-Leitung mit der Fritz verbindet. Riesenvorteil: Wenn irgendetwas mit der SF nicht stimmt, kann man immer noch telefonieren. Zugegeben: Das kommt extrem selten vor, da die SF sehr, sehr ssauber läuft. Aber trotzdem, sei es ein Hardwareproblem.


    Einziger Haken der momentanen Konfig: Wir kommen von außen nicht auf die SF. Wir brauchen das momentan nicht, deshalb kein Problem. Wenn es doch gebraucht wird, großes Problem, da die SF kein IPv6 kann.

  • Vielen Dank schon mal für die Rückantworten! Ich war über Ostern nicht zu erreichen, deshalb bisher noch keine Rückmeldung von mir. Ich habe derzeit ein ganz anderes Problem, nämlich dass die Starface nach einem Neustart nicht mehr zu erreichen ist und die LED dauerhaft rot leuchtet. Sobald ich das gelöst habe, werde ich die hier vorgeschlagenen Hinweise ausprobieren und Rückmeldung geben.

  • Auf Grund der selben Hostadresse landen die eingehenden Anrufe im falschen Leitungs-Kontext.
    Ich gehe davon aus, das du ein Providerprofil für alle Fritz!Box-Leitungen verwendest, das ist Voraussetzung.


    Dort einfach den Haken bei Leitungsübergreifende Nummernerkennung setzen und die Fritz!Box Leitungen einmal umbenennen, sonst wird die Änderung im Profil nicht auf die Leitungen übernommen.


    Ja, ich hatte bereits für jede Fritz!Box-Leitung ein eigenes Providerprofil erstellt und dort auch bei Leitungsübergreifende Nummernerkennung einen Haken gesetzt. Trotzdem tritt der Fehler auf. Ich hab hier einen Screenshot meiner Einstellungen:


    star01.PNG

  • Okay, hab's selber gelöst, indem ich jetzt die Fritz!Box an den S0 angeschlossen hab und an der Starface eine Leitung als ISDN-Anschluss extern eingerichtet habe. Fax läuft weiterhin über die Fritz!Box.
    Ein wenig spät, aber hier auch noch mal meine Versionen, falls mal jemand auf den Thread stößt:
    Starface 6.1 und Fritzbox 7490


    Danke für die Antworten.

  • Ich hatte mich ebenfalls schon mit diesem Fehler rumärgern dürfen.
    Mit folgenden Einstellungen konnte ich dies nun zum Laufen bringen:


    Starface-FritzBox-Profil.png


    Hier noch die Schritte, die bei mir zum Erfolg führen:


    1. Für jede Rufnummer, die an der FritzBox ankommt und die Starface weitergeleitet werden soll, muss ein internes IP-Telefon erstellt werden.
    2. In der Fritzbox neues Telefon-Endgerät hinzufügen: IP-Telefon.
    3. PW vergeben
    4. Rufnummer einstellen, die mit dem Account verknüpft werden soll. (i.d.R. eine Nummer pro IP-telefon)
    5. Profil nach obigen Einstellungen in der Starface erstellen (1 Profil für alle Leitungen!).
    6. Anmeldedaten (z.B. Benutzername=620, PW=620) in die Starface eintragen.
    7. Als Rufnummer, die in der FritzBox verknüpfte Rufnummer eintragen, nicht die interne (z.B. 620). Damit ist es in der Starface übersichtlicher, welche ext. Rufnummer wie verwendet wird.
    8. Speichern.
    9. Verbindung sollte grün sein.


    Hinweise:


    - Werden Einstellungen am Profil geändert, muss JEDE Leitung einmal umbenannt werden, z.B. nur ein Zeichen dazu oder geändert, und dann Speichern, damit diese Leitung die Werte aus dem Profil übernimmt. Das Profil ist nur eine Schablone, es wird nicht aktiv verwendet.
    - Wenn mehrere Rufnummern zwischen Starface und FritzBox via SIP verbunden werden müssen, muss für jeder Leitung das gleiche Profil mit der Option „Leintungsü…Nummernerkenn.“ verwendet werden, da es sonst sein kann, dass Rufe nicht zu den entsprechenden Zielen gelangen.
    - insecure sollte „port,invite“ sein, da ansonsten Authentifizierungsfehler bei eingehenden Rufen passieren können.
    - nat sollte leer sein, damit die globale NAT-Einstellung unter Server greifen kann.
    - canreinvite wird nur „no“ unterstützt.
    - qualify sollte „no“ sein, da ansonsten zuviele Registrierungsversuche an die FritzBox gehen und diese dann für 15min dicht macht. (Registrierungs Time-Outs).
    - fromuser „???????“ verwendet den Benutzernamen der SIP-Leitung.


    Ich hoffe, es kann dem einen oder anderen behilflich sein.


    PS: Bitte korregiert mich, falls ich mit einer Beschreibung falsch liegen sollte.


    Viel Erfolg!

  • Hallo zusammen,


    hat jemand mit der 6.3 und einer 7490 in aktuellster Version eine Vorlage für ein VoIP-Profil?


    Viele Grüße
    klerfrq

  • Also so wie ich das sehe, wird hier der falsche Benutzer übergeben. Du hast ja im o.g. Log die ausgehende die Meldung, dass der Benutzername falsch ist und hast diesen "geschwärzt".


    Solltest du die Fritz!Box nutzen, müsste der Benutzername z.B. 620@fritz.box sein, usw. - selbiges müsste auch bei "fromuser" eingetragen werden und - nach meiner Kenntnis - für jede Leitung konfiguriert werden. Hast du also ein virtuelles Telefon in der FritzBox über 620 mit Rufnummer 123456 und ein virtuelles Telefon in der FritzBox mit User 621 und der dortigen Rufnummer 234567 laufen, dann müsstest du den o.g. Providereintrag zwei mal hinzufügen. Einmal müsste bei "fromuser" 620 drin stehen und einmal 621.


    Also nochmals kurz und knackig:


    fromuser: Benutzernummer, der in der FritzBox zugewiesen ist
    fromdomain: IP-Adresse der FritzBox (oder bei korrekter DNS-Auflösung eben fritz.box)


    Und das muss für jedes in der FritzBox hinterlegte Telefonprofil separat gemacht werden. Am Besten legst du ein Providerprofil "620" an, trägst bei fromuser: 620 und bei fromdomain: fritz.box ein und nennst das Providerprofil "FritzBox 620". Dann legst du ein weiteres (sofern mehr als eine Nummer genutzt wird) an mit 621, usw.


    Die sinnvollste Variante - der Routerzwang ist ja jetzt offiziell gefallen - ist aber trotzdem die SIP-Daten vom Provider jetzt zu erfragen, die Telefoniefunktionen der FritzBox vollständig abzuschalten und dann die Leitungen direkt in der Starface einzutragen.
    Ganz wichtig: es darf dann auf der FritzBox KEIN Telefon oder Fax mehr angeschlossen sein; sonst leitet die FritzBox die Anrufe nicht mehr zuverlässig durch.



    Ergänzung:
    Das hier hilft dir vielleicht weiter:
    support.starface.de/attachment/1689/


    Als Host ist die IP der FritzBox einzutragen.


    Quelle: http://support.starface.de/for…3319&viewfull=1#post13319

    Viele Grüße,
    Christopher

    Edited 2 times, last by cmuschitz ().

  • Hallo,


    hab ebenfalls das Problem mit einer KDG 6490 aktuelle Firmware (6.50) ...ausgehend klappt soweit immer, eingehend naja mittlerweise sporadisch...


    Zur Konfig


    Internet -> FB -> pfSense (Wan) -> pfSense (Lan) ->Starface


    Ich hab mit dem SF-Support geschrieben, den Log Lan-Seitig in der pfSense gelogt, dann Wan-Seitig....nuja was soll man sagen...die FB scheint hier den 5060 einfach nicht richtig oder nur teilweise weiter zu leiten....


    Ich finde dies als echtes Problem, und auch irgendwie traurig, dass seitens SF noch keiner mal auf die Idee gekommen ist dort bei AVM (OEM-Support) nachzufragen (kann mich natürlich täuschen) ...


    Mit Grüßen
    Daniel



    NACHTRAG: kann sein das ich mich täusche....aber früher, das heißt bis vor einem Monat konnte man doch keine Portfreigabe 5060 eintragen in die FB...da erschien doch sofort eine Meldung....
    hab jetzt 2 FB´s 6490 mit UDP 5060 konfiguriert und scheinen auch aktiv zu sein...aber irgendwie will das noch nicht ganz so...teilweise gehen die Anrufe hinter der FB ein und teilweise nicht...:confused:

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!