Ekiga on Linux

  • Hello everybody


    I am trying to use Ekiga softphone on Ubuntu but so far with little success. When I try to use "standard sip" phone type, I get registration green light, however, incoming calls from outside VoIP line rings the phone but does not connect. Therefore I tried to define new phone type "ekiga" (suspected codec issue) but phone fails registration immediately. Therefore I would like to ask if anybody knows what are settings for "standard sip" phone (they are not visible) - i could use them for creating Ekiga phone type.


    thanks in advance


    Orama

  • Further investigation shows STARFACE rejects Ekiga REGISTER request with following SIP debug:



    This happens as soon as I switch phone type from Standard Sip to Ekiga (self defined). Any help would be highly appreciated.

  • Hello oramaavis,
    i'm using ekiga too. It's working with type 'standard sip' The settings are: host=dynamic and qualify=yes


    Please let us know, if it works out or You need more information i.e. settings in ekiga.

    $df # root hat immernoch Platz
    Filesystem 1K-blocks Used Avail Capacity Mounted on
    /dev/ad0a 7984374 7750796 -405170 106% /
    devfs 1 1 0 100% /dev

  • it seems something with the authentification user-name is not correct.
    Can You post the part sip.conf? so i can diff it to the one here?

    $df # root hat immernoch Platz
    Filesystem 1K-blocks Used Avail Capacity Mounted on
    /dev/ad0a 7984374 7750796 -405170 106% /
    devfs 1 1 0 100% /dev

  • Thanks Martin,


    I did manual diff of entries between "standard sip" and "ekiga" and found that my mistake was that I had set defaultip=dynamic. As soon as I removed it, Ekiga registered fine.


    However, I am still unable to connect inbound call from outside world. As soon as I click "Answer" button on Ekiga, remote side disconnects. Remote side is http://www.didww.com which forwards DID numbers to STARFACE over SIP. Here is SIP debug at the time of call connect:



    Any ideas, please?

  • Hi,


    since your Provider is not in the list, you needed to create a new provider what values did you insert in the settings?



    greetings


    Jochen

    Quote

    Im Leben eines jeden Büromenschen gibt es drei einschneidende Ereignisse: Erstens einen Wechsel des Vorgesetzten, zweitens den Tod der Topfpflanze und drittens eine neue Telefonanlage.

  • Jochen,


    are you referring to entry in sip.conf file? It is like this:


  • But I think in that case the incoming call would not ring in Ekiga, right? In my case it rings, but when I click "Answer" button, it briefly displays codec it will use (GSM or ULAW depending on what I set as first priority) and immediately disconnects.


    regards
    Orama

  • With the parameter "allow" you configure the Codecs which are allowed. Normally you configure a voip-provider like this:


    disallow = all
    allow = ulaw,alaw,gsm


    If there are still errors, please empty the parameters "defaultip" and "permit"

    Gruß / Regards
    Philipp

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!