Starface Update bricht ab

  • Hatte ich bei uns auch schon gehabt.
    Ich weiß leider nicht mehr ganz genau was ich dann gemacht hatte.
    Ich glaube, ich hatte nochmal auf jetzt suchen geklickt und dann das Update installiert.
    Ich hatte dann den Eindruck, dass das Update bereits runtergeladen war, 100% kann ich das aber nicht sagen.

    MfG Martin

  • Die gleiche Fehlermeldung hatte ich auch Mal.
    Geholfen hat nur ein Neustart der Appliance, sodass ich das Update nochmal von Vorne beginnen konnte (diesmal ohne Trennung von Download und Installation).

  • Danke!

    Download und Installation ohne Trennung funkt bei uns nicht, bei dieser Konstelation bricht das ganze nach etwa 1 Stunde ab..., daher versuchte ich mit Trennung.

    Nun werde ich versuchen den Server neu zu starten und dann die ganze Prozedur erneut getrennt zu starten, mal schauen ob was wird.

  • hatte ich auch schon paar mal..

    habe die Updaten-Daten auf der SF gelöscht und dann nochmals gestartet - dann klappte es..

  • hallo!

    habe nun Server neu gestartet und Update herundetgeladen, das hat auch geklappt wie vorher, nur nach dem ich Update installieren wollte, kam das hier:

    Starfase Update_Fehler.jpg

    ... habe schon zwei mal Update per USB ISO Stick installieren müsste, finde das aber nicht normal, ständig per USB ISO Stick Update zu installieren, sollte doch auch normal über Weboberfläche möglich sein Update zu installieren, besonders wie z.Bsp. nach heutiger E-Mail (13 ★★★ STARFACE Security-Release behebt Sicherheitslücke – Update dringend empfohlen.) wo man schnell reagieren müsste, und bei mir kommt immer sowas...

    ...aus der Log Datei habe noch folgendes, ist natürlich nur einige auszüge, alle ist viel zu viel hier zu platzieren, habe paralell auch an Support den Log-File gesendet, hoffentlich kann jemand weiter helfen,?

    [2017-05-09 10:23:22,634] ERROR de.vertico.starface.update.UpdateController ending step3: installUpdateserver (failed)
    [2017-05-09 10:25:36,692] ERROR de.vertico.starface.helpers.firewall.Chain An ExecuteException was thrown while executing the command [iptables, -N, ATTACKER-DETECTION]
    org.apache.commons.exec.ExecuteException: Process exited with an error: 1 (Exit value: 1)

    Edited 2 times, last by rievik (May 9, 2017 at 11:08 AM).

  • Welcher Zeitraum ist zwischen dem Beginn des Installations vom UpdateServer und des Abschlusses? Das müsste wenige Zeilen vor den Zitierten stehen.

  • Hallo Tom,

    habe weitere Zeilendie davor standen kopiert, würde das helfen?, das ist aber auch nur ein Bruchteil davon was im Logfile drin steht...

    [2017-05-09 09:05:33,753] ERROR de.starface.ch.processing.ami.impl.AmiAgiConnectionService class java.net.ConnectException in AMI Connection refused
    [2017-05-09 09:05:33,760] ERROR de.starface.ch.processing.ami.impl.AmiEventConnectionService class java.net.ConnectException in AMI Connection refused
    [2017-05-09 09:05:33,849] ERROR de.starface.ch.processing.ami.impl.AmiActionCommandConnectionService class java.net.ConnectException in AMI Connection refused
    [2017-05-09 09:05:35,758] ERROR de.starface.ch.processing.ami.impl.AmiAgiConnectionService class java.net.ConnectException in AMI Connection refused
    [2017-05-09 09:05:35,765] ERROR de.starface.ch.processing.ami.impl.AmiEventConnectionService class java.net.ConnectException in AMI Connection refused
    [2017-05-09 09:05:35,854] ERROR de.starface.ch.processing.ami.impl.AmiActionCommandConnectionService class java.net.ConnectException in AMI Connection refused
    [2017-05-09 09:05:52,935] ERROR de.starface.ch.processing.ami.impl.AmiActionCommandConnectionService class org.asteriskjava.manager.TimeoutException: Sending Command: sip show extendedpeers
    [2017-05-09 09:23:50,605] ERROR de.starface.core.component.monitoring.VMSensor Heap memory runs short. 205422216 of 227278848
    [2017-05-09 10:17:29,287] ERROR de.vertico.starface.helpers.AsteriskUtils An ExecuteException was thrown while executing the command [stop, faxgetty-ttyIAX1]
    org.apache.commons.exec.ExecuteException: Process exited with an error: -559038737 (Exit value: -559038737)


    [2017-05-09 10:17:55,623] ERROR de.vertico.starface.update.UpdateController file /usr/share/starface-database/starface-db.sql from install of starface-database-6.4.2.11-1.el6.1.sf.noarch conflicts with file from package starface-database-6.4.1.12-1.el6.1.sf.noarch


    [2017-05-09 10:23:22,546] ERROR de.vertico.starface.update.YumHelper An ExecuteException was thrown while executing the command [yum, -y, install, updateserver]

  • Hallo noch mal,

    da ich bis jetzt keine Update über Weboberfläche zum laufen bringen konnte, versuche jetzt auf mir schon bekannte Weise, über USB Stick mit ISO File.

    nun sieht das ganze wie folgt aus, den ganzen Tag versuche ISO Stick aus dem File Starface-06.04.02.12-20170509-171005_x86_64 zu erstellen, mit vorherigen Versionen, d.h. 6.4.1.12 klappte das problemlos, aber mit der Datei 6.4.2.12 geht das gar nicht, zu einem wird Stick unter Windows nicht immer erkannt, hier muss ich immer wieder über cmd formatieren, sonst keine Chance USB zum laufen zu bringen, zu anderem wenn ich doch hinbekomme die Datei zu entpacken und auf den Stick über USB Image Tool aufzuspielen, verhält sich Installation ganz anders, es kommt unter anderem Meldung (Error Downloading kickstart file) cdrom:/ks/ks_unatt.cfg wobei CD Rom habe ich nicht (Starface Light), somit versuchte weiter über Optionen die zum Auswahl stehen, z.Bsp. über Festplatte, und irgendwann nach dem man root Passwort neu vergibt, was bis jetzt nie der Fall war, brach die Installation doch ab, warum auch immer...

    nun habe ich keine Ahnung was hier falsch läuft, und werde lieber vorherige Version 6.4.1.12 wieder aufspielen..., da die Update auf 6.4.2.12 leider weder über Weboberfläche, noch über USB-Stick mit ISO File möglich ist, muss wohl bei der Version 6.4.1.12 bleiben, in der Hoffnung das Starface Support eine Lösung anbietet...

  • Hallo noch mal,

    da ich bis jetzt keine Update über Weboberfläche zum laufen bringen konnte, versuche jetzt auf mir schon bekannte Weise, über USB Stick mit ISO File.

    nun sieht das ganze wie folgt aus, den ganzen Tag versuche ISO Stick aus dem File Starface-06.04.02.12-20170509-171005_x86_64 zu erstellen, mit vorherigen Versionen, d.h. 6.4.1.12 klappte das problemlos, aber mit der Datei 6.4.2.12 geht das gar nicht, zu einem wird Stick unter Windows nicht immer erkannt, hier muss ich immer wieder über cmd formatieren, sonst keine Chance USB zum laufen zu bringen, zu anderem wenn ich doch hinbekomme die Datei zu entpacken und auf den Stick über USB Image Tool aufzuspielen, verhält sich Installation ganz anders, es kommt unter anderem Meldung (Error Downloading kickstart file) cdrom:/ks/ks_unatt.cfg wobei CD Rom habe ich nicht (Starface Light), somit versuchte weiter über Optionen die zum Auswahl stehen, z.Bsp. über Festplatte, und irgendwann nach dem man root Passwort neu vergibt, was bis jetzt nie der Fall war, brach die Installation doch ab, warum auch immer...

    nun habe ich keine Ahnung was hier falsch läuft, und werde lieber vorherige Version 6.4.1.12 wieder aufspielen..., da die Update auf 6.4.2.12 leider weder über Weboberfläche, noch über USB-Stick mit ISO File möglich ist, muss wohl bei der Version 6.4.1.12 bleiben, in der Hoffnung das Starface Support eine Lösung anbietet...

    Ich vermute, dass der Download des Updateservers zu lange dauert. Diese Vermutung würde sich bestätigen bzw widerlegen lassen indem man die Zeit zwischen Beginn und Ende von Update Step 3 (installUpdateServer) aus den Trace Log berechnet. Ist es genau 5 Minuten, dann ist die Internetanbindung der STARFACE zu langsam. Dieser Timeout ist ab 6.4.2 um einiges großzügiger.

  • Ich vermute, dass der Download des Updateservers zu lange dauert. Diese Vermutung würde sich bestätigen bzw widerlegen lassen indem man die Zeit zwischen Beginn und Ende von Update Step 3 (installUpdateServer) aus den Trace Log berechnet. Ist es genau 5 Minuten, dann ist die Internetanbindung der STARFACE zu langsam. Dieser Timeout ist ab 6.4.2 um einiges großzügiger.

    Hallo Tom,

    dass der Download des Updateservers zu lange dauert, ist nicht zu übersehen, mir wäre aber hilfreich zu wissen warum ist das so, wie kann man die Ursache finden und beseitigen, ich denke nicht das das bei allen der Fall ist... und das der Timeout ab 6.4.2 um einiges großzügiger ist, ist natürlich schön, aber mir hilft das wenig, wie ich bereits gischildert hatte, ich versuchte gestern den ganzen Tag diese Versio 6.4.2. aufzuspielen, alle meine Versuche blieben erfolglos, daher musste ich vorherige Version 6.4.1.12 wieder installieren und über Wiederherstellung letztes Backups die Anlage wieder zum laufen bringen.

    Versuchte jetzt noch mal über Weboberfläche Update gtrennt zu installieren, Download dauerte etwa 1 Stunde, danach versuchte zu installieren, und kam folgende Fehlermeldung, also ich weiß nicht wie das weiter gehen soll...Fehlermeldung Starface.jpg

    Edited once, last by rievik (May 16, 2017 at 10:30 AM).


  • nun sieht das ganze wie folgt aus, den ganzen Tag versuche ISO Stick aus dem File Starface-06.04.02.12-20170509-171005_x86_64 zu erstellen, mit vorherigen Versionen, d.h. 6.4.1.12 klappte das problemlos, aber mit der Datei 6.4.2.12 geht das gar nicht, zu einem wird Stick unter Windows nicht immer erkannt, hier muss ich immer wieder über cmd formatieren, sonst keine Chance USB zum laufen zu bringen, zu anderem wenn ich doch hinbekomme die Datei zu entpacken und auf den Stick über USB Image Tool aufzuspielen, verhält sich Installation ganz anders, es kommt unter anderem Meldung (Error Downloading kickstart file) cdrom:/ks/ks_unatt.cfg wobei CD Rom habe ich nicht (Starface Light), somit versuchte weiter über Optionen die zum Auswahl stehen, z.Bsp. über Festplatte, und irgendwann nach dem man root Passwort neu vergibt, was bis jetzt nie der Fall war, brach die Installation doch ab, warum auch immer...

    ISO von starface.de runterladen.

    Ich hatte es so in Erinnerung, dass der Stick mittels diskpart partitioniert werden sollte:

    - ISO-Datei mittels unetbootin auf den Stick schreiben lassen
    - anschließend die Ordner packages und repodata löschen
    - ISO-Datei auf den Stick kopieren

    Datei syslinux.cfg öffnen und wie folgt anpassen (das fettgeschriebene wird angepasst):


    Im Ordner \ks die ks_unatt.cfg öffnen und

    Wenn ich mich nicht irre, sollte es das gewesen sein. Der Stick müsste so jetzt booten und installieren. Habe das jetzt an einem alten Starface-Stick gesichtet (also die Config-Dateien) und entsprechend das Label auf SF64212 angepasst. Ich habe es nicht an einer Starface getestet - es müsste aber eigentlich funktionieren. Bitte aber erst an einer nicht produktiven Starface ausprobieren - sicher ist sicher.

    Viele Grüße,
    Christopher

    Edited 6 times, last by cmuschitz (September 11, 2017 at 11:31 AM).

  • Seid gegrüßt,

    ich habe gute Erfahrungen mit der neuen Stick-Erstell-Methode gemacht.

    https://knowledge.starface.de/pages/viewpage…?pageId=6129218

    Benötigt zwar einen 8GB Stick, aber man spart sich die einzelnen Steps, wie: Partitionierung, Ordner entpacken, kopieren, löschen, Config anpassen.
    Einfach Image (nicht die ISO!) downloaden, mittels dem Tool auf dem Stick wiederherstellen. Fertig.

    Ich drück dir die Daumen, dass das mit dem Update bei dir funktioniert. Hab jetzt auch einzelne Update-Odysseen hinter mir, wo lediglich die Stick-Installation noch erfolgreich war. Meist bei irgendwelchen Proxys, Firewall gedöns davor oder schlechten Bandbreiten.

  • Das ist sicher die bessere Methode: als das "eilige Sicherheitsupdate" jedoch rausgekommen ist, war dort das aktuelle Image noch nicht verfügbar. Auch so scheint es dort meist nach einem Release eine Weile zu dauern, bis dann dort ein Image bereitsteht. Aber grundsätzlich ist - sofern ein aktuelles Image bereitsteht - dies sicher der vorzuziehende Weg. Nicht zuletzt deshalb wurden scheinbar auch die alten Wiki-Seiten, wie ein Stick manuell erstellt wird, aus dem Netz genommen.

    Viele Grüße,
    Christopher

  • Seid gegrüßt,

    ich habe gute Erfahrungen mit der neuen Stick-Erstell-Methode gemacht.

    https://knowledge.starface.de/pages/viewpage…?pageId=6129218

    Benötigt zwar einen 8GB Stick, aber man spart sich die einzelnen Steps, wie: Partitionierung, Ordner entpacken, kopieren, löschen, Config anpassen.
    Einfach Image (nicht die ISO!) downloaden, mittels dem Tool auf dem Stick wiederherstellen. Fertig.

    Ich drück dir die Daumen, dass das mit dem Update bei dir funktioniert. Hab jetzt auch einzelne Update-Odysseen hinter mir, wo lediglich die Stick-Installation noch erfolgreich war. Meist bei irgendwelchen Proxys, Firewall gedöns davor oder schlechten Bandbreiten.

    Hallo Daniel,

    danke für deine Antwort, diese Prozedur hatte ich bereits hinter mir, die funkte bis Version 6.4.1. tadenlos, wobei hier muss ich anmerken, das bei mir Stick mit dem 8GB nicht reichte, das steht übrigens auch dort mit dem Hinweis das der Stcik Mindestens 8 GB groß sein soll, das hat bei mir nicht gereicht, daher lieber nächstmögliche Größe nehmen.

    Weiß nicht wie bei anderen, aber bei mir Version 6.4.2.12 das zur Verfügung steht, klappt nicht, so wie das bis jetzt mit diesem Tool klappte...

    Edited once, last by rievik (May 17, 2017 at 5:14 PM).

  • Hallo Christopher,

    danke für deine Antwort und Tipp, das sieht auf jeden Fall besser aus, wobei diskpart so wie du beschrieben hast, hatte ich genau so gemacht außer label=SF64212 -und assign...

    und das weitere Prozedere ist sicherlich eine Hürde für mich als Leie, werde also schritt für schritt befolgen und probieren, hoffentlich diesmal klappt es..., werde noch berichten!


    Vielen Dank noch Mal..!

  • Notfalls kann man den fertigen Stick auch bei Starface, bzw. beim Starface-Partner bestellen - kostet ein paar Euro, funktioniert aber garantiert. Alternative (außer bei der Compact) wäre auch, das ISO-File auf eine DVD zu ziehen und mitels eines externen DVD-Laufwerkes zu installieren - das klappt auch immer problemlos.

    An den selbst erstellten Sticks kann man je nachdem auch richtig Zeit investieren und erfolglos verzweifeln ... zumal sich gezeigt hat, dass auch mancher Stick (Hersteller) ansich als "sperrig" erwies :(

  • Hallo Christopher,
    danke für deine Antwort und Tipp, das sieht auf jeden Fall besser aus, wobei diskpart so wie du beschrieben hast, hatte ich genau so gemacht außer label=SF64212 -und assign...
    und das weitere Prozedere ist sicherlich eine Hürde für mich als Leie, werde also schritt für schritt befolgen und probieren, hoffentlich diesmal klappt es..., werde noch berichten!

    Das mit dem label ist auch nicht zwingend nötig, denke ich. Das label bezeichnet nur die Bezeichnung vom USB-Stick (der Stick wird dann also auch SF64212 genannt) und die entsprechende Anpassung dazu im syslinux.cfg verweist auf das Label um den Stick zu identifizieren. Vermutlich geht das auch ohne. Falls Du die Bezeichnung ändern möchtest, solltest Du nur darauf achten, dass die Benennung vom Stick zu der in der syslinux.cfg passen muss.

    assign kann man machen - muss man nicht immer. Es weist im Grunde nur einen Laufwerksbuchstaben zu. Teilweise geschieht das durch Windows aber auch schon automatisch. Wenn du nach dem Formatieren den Stick also im Explorer siehst, brauchst du das assignnicht mehr machen.

    Bitte, wie gesagt, den Stick an einer nicht produktiven Maschine zunächst testen. Ich habe die "Anleitung" so in Erinnerung gehabt (habe mich an die Starface-Anleitung erinnert), den Stick selbst aber noch nicht ausprobieren können, da im Moment keine Testanlage bereitsteht.


    EDITh sagt: Habe einen so (nach der Anleitung) erstellten Stick in der VM gerade mal getestet: Installation war erfolgreich.

    Viele Grüße,
    Christopher

    Edited 2 times, last by cmuschitz: Test von Stick in VM nach dieser Anleitung funktionierte (May 18, 2017 at 9:55 AM).

  • An den selbst erstellten Sticks kann man je nachdem auch richtig Zeit investieren und erfolglos verzweifeln ... zumal sich gezeigt hat, dass auch mancher Stick (Hersteller) an sich als "sperrig" erwies :(

    Hallo Ulf,

    danke für den Tipp,

    da hast du Recht, aber hier muss ich sagen, dass das nur mit der Image Datei für Version 6.4.2.12 passierte, da hatte ich wirklich ganzen Tag investiert und rum experimentiert, schließlich gab auf und erstellte mit Image Datei 6.4.1.12 auf dem selben Stick absolut problemlos notwendige ISO Datei, und auch problemlos erneut installiert und mit Backup Datei ursprünglicher Stand wiederhergestellt.

    Daher glaube ich nicht das das an Hersteller Stick liegt...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!