Telekom ALLIP Voice-Data S - eingehende Gespräche SPORADISCH ohne Ton

  • Hallo,


    ich habe bei einem Kunden auf ALL-Ip umgestellt und seitdem das im Titel genannte Phänomen.


    Topologie:


    VDSL-Modem--->Sophos-UTM---->Switch---->Starface-Pro-Appliance


    Ich habe das "Glück" gehabt, live bei so einem Vorfall anwesend zu sein und folgendes in der PBX Log gefunden:


    Anruf 1 war alles ok
    Anruf 2 war dann kein TON für beide Seiten zu hören


    Starface steht auf "hinter NAT" und die externe (Statische IP) der telekom ist eingetragen.




    Wie man sieht, feht beim Anruf 2, welcher kein TON hat die Zeile

    Code
    res_rtp_asterisk.c:        > 0x7fe87c1497c0 -- Probation passed - setting RTP source address to 217.0.4.167:29408


    kennt jemand das Phänomen ?


    Bin echt ratlos ...


    Danke und Grüße aus Karlsruhe,


    Chris

    Cheers - Chris


    STARFACE certified Partner
    Sophos certified Engineer
    schon mal was von MS-AD gehört ;)
    CISCO / HPE / ARUBA Networking

  • Hallo Chris,


    bitte prüfe einmal deine NAT Einstellungen.


    Zu den Ports gibt es folgenden Link:


    https://knowledge.starface.de/…age.action?pageId=6128345


    Wichtig für die Sprache sind hier die eingehenden Ports 10.000 - 20.000. Je nach verwendetem Router auch die ausgehenden Ports beachten. Die ausgehenden Ports können i.d.r bei "Privatkundenroutern" vernachlässigt werden da eh alles raus darf.


    Gerne auch mal in den Firewall-Logs nach drops schauen.


    Grüße, Jürgen

  • Hallo Jürgen,


    Wichtig für die Sprache sind hier die eingehenden Ports 10.000 - 20.000. Je nach verwendetem Router auch die ausgehenden Ports beachten. Die ausgehenden Ports können i.d.r bei "Privatkundenroutern" vernachlässigt werden da eh alles raus darf.


    Gerne auch mal in den Firewall-Logs nach drops schauen.


    danke für die schnelle Antwort... jedoch habe ich da jetzt ein paar Fragen:


    Wieso zur Hölle ist die liebe DTAG wiedermal der einzige Provider, bei welchem ich eingenden Ports freigeben muss ?


    QSC, Sipgate, etc. funktionieren alle ohne probleme. eben auch ohne die eingehenden Ports.
    Sowie ich dich oder einen Kollegen mal verstanden hatte, wird doch die SIP Session von der Starface initialisiert und dann mit Keep-Alive Packets aufrecht erhalten ?


    Wenn das der Fall ist, wieso brauche ich dann eine regel für eingehende Verbindungen ?
    ich meine - klar, SIp ist nicht RTP .. aber wieso geht's bei den anderen und bei der DTAG wieder mal nicht ?


    und was hat das ganze dann mit dem fehlenden Eintrag in den Logs zu tun ?


    Grüße,


    Chris

    Cheers - Chris


    STARFACE certified Partner
    Sophos certified Engineer
    schon mal was von MS-AD gehört ;)
    CISCO / HPE / ARUBA Networking

  • Hallo cbka,


    ich habe exakt das selbe Problem.
    Meine Konstellation sieht so aus:


    Fritzbox exposed Host -> Watchguard T30 -> Switch -> Starface Compact
    Die Telefone sind per POE am Switch angeschlossen.


    Telefonie funktioniert sporadisch, d.h. jemand ruft an, man hört beidseitig nichts. Beim nächsten oder übernächsten Anruf funktioniert es.
    Die Ports sind, sowohl nach innen, als auch nach aussen freigeschaltet.


    Kann mir jemand helfen?

  • Hallo cbka, hallo Yasin,


    ich würde euch beiden empfehlen tcpdumps zu erstellen in denen das Problem auftritt. Mein Gefühl sagt mir, das hier was im SDP nicht stimmt.


    tcpdump mit RTP:

    Code
    nohup tcpdump -w /tmp/telekom.pcap port 5060 or portrange 10000-20000 &


    Achtung: Gesprächsinhalte werden mitgeschnitten!


    tcpdump ohne RTP:

    Code
    nohup tcpdump -w /tmp/telekom.pcap port 5060 &


    Gesprächsinhalte werden nicht mitgeschnitten.


    Der dump läuft im Hintergrund weiter, ihr könnt die Konsole beenden.
    Wenn der Fehler aufgetreten ist beendet den Dump via

    Code
    killall tcpdump


    Bitte behandelt die Dumps vertraulich (mit oder ohne RTP) und stellt sie mir per PN zur Verfügung oder noch besser: erstellt ein Ticket bei uns.

    Viele Grüße
    Niklas


    - Ex STARFACE Support: 2014-2020 -

  • Hi Niklas,

    Hallo cbka, hallo Yasin,


    ich würde euch beiden empfehlen tcpdumps zu erstellen in denen das Problem auftritt. Mein Gefühl sagt mir, das hier was im SDP nicht stimmt.


    Das mit den TCPDUMPS ist generell eine feine Idee, sofern du diese auswerten magst.


    Ticket mache ich dann auf, sobald ich vom Kunden Rückmeldung bekomme, dass es wieder Probleme gab.


    Was allerdings komisch ist: Sporadisch müssen da auch Probleme im SIP selbst auftreten, da z.B. an den Telefonen laut log nur das RINGING kommt, aber trotz dem Abnehmen des Hörers durch den Benutzer kein ANSWER auftaucht ?!



    Yasin: Wenn du schon eine Fritzbox vorne dran hängen hast, würde ich dir empfehlen, zumindest als Workaround, an der Fritzbox direkt per ISDN in die Starface zu gehen, sofern du S0 (ISDN) Ausgänge(Ausgang) an der Fritzbox hast.



    Beste Grüße,


    Chris

    Cheers - Chris


    STARFACE certified Partner
    Sophos certified Engineer
    schon mal was von MS-AD gehört ;)
    CISCO / HPE / ARUBA Networking

  • Hallo,


    wir sind jetzt von der Fritzbox 7490 auf die 3490 gewechselt, da wir den tipp bekommen hatten, dass die Telefonie Funktion von der 7490 uns die Probleme machen würden und die 3490 keine Telefonie hat.
    Hat leider nichts gebracht.


    Chris, gibts bei dir schon was neues?
    Würde sehr ungern eine VOIP Anlage auf ISDN ändern. War schließlich die Idee, auf VOIP zu wechseln.

  • Hi Yasin,



    Chris, gibts bei dir schon was neues?
    Würde sehr ungern eine VOIP Anlage auf ISDN ändern. War schließlich die Idee, auf VOIP zu wechseln.


    Ja - es gibt tatsächlich was neues...


    Ich habe eine - jetzt - MultiWAN-Umgebung bei dem Kunden: UnityMedia BIZ + Telekom


    Nun hat sich herausgestellt, dass der bereits vorhandenen und damals auch extrem stabil laufende QSC Anschluss auch Probleme macht.


    Daraufhin habe ich mal etwas tiefer gegraben und probleme mit den SIP - Verbindungen festgestellt. Es sieht so aus, als wenn die NAT sessions nicht lange genug "offen" bleiben,
    damit die Verbindung zur Telekom resp. QSC nicht abbricht.
    Zudem wurde ein load-balancing über die beiden WANs betrieben, was natürlich auch noch Probleme gemacht hat.
    Habe daher nun eine Internal---->SIP--->Internet---->via Telekom Multipathregel angelegt. Siehe da, QSC geht zumindest wieder.


    Nun habe ich gelesen, dass der SIP Client, also die Starface eigentlich ein "Keepalive" schicken muss, damit die Verbindung und NAT Session eben nicht zusammen bricht, bevor sie erneuert wird.


    Wenn das richtig funktioniert, sollte man auch keine eingehenden Ports mit DNAT mehr benötigen, zumal die Verbindung ja schon besteht und nicht erneut aufgebaut werden muss!?! Niklas


    Noch was zum Thema NAT und SIP... Egal wo man im Internet nach liest, hat man eigentlich immer die selben Probleme. Am besten funktioniert das Ganze tatsächlich, wenn die Starface direkt am Internet hängt.


    Wenn ich das richtig verstanden habe, hast du ja auch noch "doppeltes" NAT ? Sprich zwei private Netze zwischen der Starface und der Telekom ?


    Fritzbox----192.168.178.X------Watchguard-----192.168.123.X----->Starface


    Könnte mir vorstellen, dass das zusätzlich Probleme macht. ...


    Grüße,


    Chris

    Cheers - Chris


    STARFACE certified Partner
    Sophos certified Engineer
    schon mal was von MS-AD gehört ;)
    CISCO / HPE / ARUBA Networking

    Edited once, last by cbka ().

  • Nun habe ich gelesen, dass der SIP Client, also die Starface eigentlich ein "Keepalive" schicken muss, damit die Verbindung und NAT Session eben nicht zusammen bricht, bevor sie erneuert wird.
    Wenn das richtig funktioniert, sollte man auch keine eingehenden Ports mit DNAT mehr benötigen, zumal die Verbindung ja schon besteht und nicht erneut aufgebaut werden muss!?! Niklas


    Wenn du der NAT-Implementierung deines Herstellers vertraust: ja.


    "Keepalive" ist im Asterisk als "qualify" bekannt:
    https://github.com/asterisk/as…les/sip.conf.sample#L1565


    Kannst du im Providerprofil aktivieren.
    Im Endeffekt werden "leere" SIP OPTION Pakete zum Peer geschickt, der diese dann beantwortet und so die Ports offen hält.


    Aber Achtung: Werden die Pakete nicht beantwortet geht der Peer in den Status "UNREACHABLE" und Asterisk wird keine Kommunikation zu dem Peer aufnehmen, bis die SIP OPTION Pakete wieder beantwortet werden.
    Das ist dann auch komplett unabhängig vom Registrierungsstatus etc.

    Viele Grüße
    Niklas


    - Ex STARFACE Support: 2014-2020 -

  • Meine Erfahrung ist, die FritzBox das Problem. Es ist mit der aktuellen Firmware 6.83 nicht mehr möglich, eine Portweiterleitung von 10000-20000 einzutragen. Es ist jetzt nur noch möglich eine Postrange von 255 (z.B. 10000 - 10255) einzutragen. Es reicht aber nicht, da für Sprache mehr Ports benötigt werden (10000-20000). Wird die Starface als Exposed Host eingetragen funktioniert es bei mir.


    Gruß
    Christian

  • Hallo Christian,


    ja das stimmt aber man kann mehrere Portweiterleitungen in der FritzBox einrichten. Ich habe das in 200er Schritten gemacht also


    1.Portfreigabe 10000 - 10200
    2.Portfreigabe 10201 - 10400
    3.Portfreigabe 10401 - 10600


    Ist zwar tierisch nervig und ich habe AVM diesbezüglich schon mal angefragt. Man wird es prüfen. Vielleicht sollten sich einfach noch ein paar Leute bei AVM beschweren.


    Aber es geht zumindest.


    Viele Grüße
    BIGAIRFOX


  • Wieso zur Hölle ist die liebe DTAG wiedermal der einzige Provider, bei welchem ich eingenden Ports freigeben muss ?


    QSC, Sipgate, etc. funktionieren alle ohne probleme. eben auch ohne die eingehenden Ports.
    Sowie ich dich oder einen Kollegen mal verstanden hatte, wird doch die SIP Session von der Starface initialisiert und dann mit Keep-Alive Packets aufrecht erhalten ?


    Mir ist unklar warum man hier immer wieder Port Forwarding machen will, qualify=yes und es geht auch ohne.
    Anders sieht es natürlich aus wenn man per SIP von extern auf die eigene Anlage zugreifen möchte...

  • Hallo BIGAIRFOX,
    ja bei AVM habe ich mich auch schon beschwert, gleiche Antwort, Man wird es prüfen.
    Aber die Portfreigaben in 200er Schritten einzutragen, ist wirklich nicht sinnvoll, sind immerhin 40 Einträge (von 10000 - 20000), weiß gar nicht, ob die FritzBox so viel unterstützt. Vor allem, hat es ja in der Vergangenheit schon funktioniert.


    Gruß
    Christian

  • Hallo Christian,


    die FirtzBox unterstützt so viele. Keine Frage es ist tierisch nervig.


    slu: Hab hier eine FritzBox 7490 die Telefonie ist dort eingetragen und in der Starface sind die Leitungen mit der Einzelnummer der FritzBox definiert über die internen Nummern der FritzBox z.B. 621,622). Bei mir musste ich die Ports freigeben, sonst ging nichts. Mit der Freigabe lief es dann. Aber vielleicht ist noch was anders falsch.


    Viele Grüße
    Jürgen

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!