Swisscom IB2 und Starface via interne Nummer von IB2

  • Hallo zusammen

    Ich habe von der Swisscom eine InternetBox 2 (IB2) welche lokale SIP Daten zu Verfügung stellt. Ich muss dort einen Benutzer und eine interne Nr sowie ein Passwort erstellen.
    Diese Anmeldedaten habe ich in der Starface unter Leitung konfiguriert, diese wird auch grün.

    Nur leider wenn ich einen Anruf erhalte passiert bei den Telefonen nichts, im Log finde ich jedoch diese Zeilen:

    Code
    [2018-06-12 11:05:06,808] [0022] ********* Call created ********* 
    [2018-06-12 11:05:06,808] [0022] Starting call routing : SIP/220-00000014|1528794306.20 dial number 220 CallerId 078*******  <004178*******> 
    [2018-06-12 11:05:06,853] [0022] Routing call "  <004178*******>" to number 220 over service UserService 
    [2018-06-12 11:05:06,853] [0022] CallLeg 6c070189-2cd5-4822-b4cf-6a03016eb68f 
    [2018-06-12 11:05:06,853] [0022] Got dialstatus DialReturnCodes(hc=CALL_REJECTED, ds=CHANUNAVAIL, cr=NOT_CONNECTED) 
    [2018-06-12 11:05:06,857] [0022] SIP/220-00000014 Hangup Cause: Subscriber absent 
    [2018-06-12 11:05:06,857] [0022] ********* Call finished *********

    Kann mir jemand helfen die Starface so zu konfigurieren damit es richtig funktioniert ?

    Bild von der IB2 mit den lokalen SIP Daten:
    Bildschirmfoto 2018-06-12 um 11.00.14.png

    Bild vom Providerprofil in der Starface:
    Bildschirmfoto 2018-06-12 um 11.11.22.png

    Bild von der Leitungskonfiguration:
    Bildschirmfoto 2018-06-12 um 11.11.44.png

  • Benutzer und alles ist angelegt. Mit einer anderen Nummer (externe Nummer) klappt alles einwandfrei.
    Jedoch benötige ich diese genau so ...

    Beim Benutzer habe ich die externe Nummer hinterlegt, weiss nicht wie ich da eine andere als die externe hinterlegen kann.
    Auch in der Leitungskonfiguration kann ich ja nur die externe hinterlegen (siehe Bild).

    Bildschirmfoto 2018-06-12 um 17.29.39.png

  • also spontan würde ich sagen, dass du der Starface die Nummer 220 geben musst, da die Starface von der IB2 als "Nebenstelle" gewertet wird, das bedeutet sie bekommt nur die 220 genau so als wenn du ein Sip-Telefon/Client anmeldest.

    Wenn die Starface die "öffentliche" Rufnummer hat und die 220 als Rufnummer nicht kennt, ist es klar das die SF nicht auf den Ruf reagiert und sich nix tut.

    Füge die 220 einfach mal als Einzelrufnummer unter Rufnummern bei der Leitung dazu, weise die Rufnummer auch dem Benutzer zu und probier es nochmal.

    Mit sonnigen Grüssen aus Bielefeld :)
    Sascha

    A bis Z TeleCom Partner GmbH
    Ludwig-Erhard-Allee 41
    33719 Bielefeld

    https://www.abisztelecom.de

  • Ich habe es nun soweit hingebracht dass eingehende Anrufe auf den Geräten ankommen, ist aber vermutlich nicht die richtige Lösung. Habe eine neue Rufnummer 00 41 71 220 hinzugefügt. Da auf der Swisscom Internetbox bei den lokalen SIP Daten eine interne Nr. 220 hinterlegt ist.
    Bildschirmfoto 2018-06-13 um 10.47.45.png
    Bildschirmfoto 2018-06-13 um 10.48.01.png

    Jedoch kann ich keine ausgehene Anrufe tätigen. Hier das Log wenn ich einen ausgehenden Anruf starte:

  • nur geraten...schmeiss mal auf der Leitung die "Ortsnetzrufnummer" raus und lass nur die 220 drin, die andere bringt dir in der SF eh nix.
    Kann sein das die IB2 mit dem Versuch des Clip No Screenings nicht klar kommt. Sieht zumindest so aus als wenn die Starface versucht deine Ortsrufnummer zu signalisieren oder mach den Haken bei Clip No Screening in der SF bei der Leitung raus.

    Gruss

    Mit sonnigen Grüssen aus Bielefeld :)
    Sascha

    A bis Z TeleCom Partner GmbH
    Ludwig-Erhard-Allee 41
    33719 Bielefeld

    https://www.abisztelecom.de

  • Habe die Festnetznummer bei Leitung mal rausgelöscht und probiert, leider ohne Erfolg.
    Haken bei Clip no Screening ist raus. bzw war schon raus.
    Bildschirmfoto 2018-06-13 um 16.48.08.png

    Logfile zeigt dies:

    Edited once, last by gizmoswizz (June 13, 2018 at 4:49 PM).

  • Soeben alles durchprobiert ohne Erfolg :P
    Trotzdem vielen Dank für die Hilfe und die Zeit.

    Swisscom ist wohl der falsche Partner für SIP Telefonie im Privat Bereich ...

  • Lustig ... habe jetzt einfach mal das Sipgate Trunking Profil kopiert und die IP's/Hosts durch die der InternetBox 2 ersetzt ... und alles funktioniert ... da ist wohl im Profil noch mehr hinterlegt als man sieht.

  • Leider doch zu früh gefreut ... am Anfang wenn sich die Leitung neu anmeldet klappt alles bestens.
    Jetzt klappen nur noch ausgehende Anrufe. Bei einem eingehenden ist wieder dies im Log:

    Code
    [Jun 15 15:09:38] VERBOSE[21851][C-0000001c] netsock2.c:   == Using SIP RTP TOS bits 184
    [Jun 15 15:09:38] VERBOSE[21851][C-0000001c] netsock2.c:   == Using SIP RTP CoS mark 5
    [Jun 15 15:09:38] VERBOSE[21851][C-0000001c] res_rtp_asterisk.c:        > 0x7f66a00cea10 -- Strict RTP learning after remote address set to: 172.16.1.1:10028
    [Jun 15 15:09:38] NOTICE[21851][C-0000001c] chan_sip.c: Call from '' (85.1.xxx.xxx:5060) to extension '220' rejected because extension not found in context 'default'.

    Wieso bringt er mir hier nun meine externe IP ins Spiel ? Sollte doch alles von der Internet Box 2 (172.16.1.1) kommen?

    Sobald ich aber das Providerprofil einmal wechsle und dann wieder auf das vorherige gehe klappt alles wieder ... da ist doch irgendwo ein Wurm drin.

    Edited once, last by gizmoswizz (June 15, 2018 at 3:15 PM).

  • warum terminierst Du die Leitungen auf der IB2 ?

    Ich würde die Telefoniefunktion der IB2 deaktivieren und die Leitungen direkt auf der STARFACE terminieren; die Zugangsdaten scheinst Du ja zu haben.

    Gruss
    Thomas

    hertli ¦ IT
    hertli Informatik+Treuhand

    eMail: mail ( a t ) hertli.ch
    Internet: https://www.hertli.ch

    Virtuelle Rechenzentren (IaaS, PaaS) mit Standorten in CH + DE, Managed Services, Security

  • Diese Zugangsdaten sind die lokalen nur für die Internetbox 2 von der Swisscom.
    Die SIP Daten für den direkten Zugriff auf die Swisscomserver habe ich auch, jedoch ist da die Leitung immer wieder tot nach einer gewissen Zeit und ich muss die Zugangsdaten erneut eingeben.
    Wieso auch immer ...

    Hat den jemand ein funktionierendes Profil für die IB2, oder die Lösung wie umbauen damit es mit den Lokalen SIP der IB2 funktioniert ?
    Oder noch besser wäre natürlich den direkten Zugriff auf die Swisscomserver. Aber auch hier happert es leider.

  • noch besser wäre auf Swisscom zu verzichten und einen "richtigen" VoIP-Anbieter zu verwenden, der bspw. auch auf siptrunk.de gelistet ist.

    Das mit den Monopolisten in DE+CH ist leider immer das selbe Problem; das macht einfach keinen Spass.

    Gruss
    Thomas

    hertli ¦ IT
    hertli Informatik+Treuhand

    eMail: mail ( a t ) hertli.ch
    Internet: https://www.hertli.ch

    Virtuelle Rechenzentren (IaaS, PaaS) mit Standorten in CH + DE, Managed Services, Security

  • mhm da stimm ich vollkommen zu ... nur leider im Moment nicht Möglich. Da ich umgezogen bin und nun ein Gesamtpaket habe von Swisscom, kann ich die Nr im Moment nicht migrieren.
    Aber es sollte doch auch mit der Swisscom zum laufen kommen :P oder sind da so viele Stolpersteine drinnen ?

  • Witzig ist ja auch ... sobald dann die Leitung tot ist ... habe ich folgende Meldung im Log:

    Code
    [Jun 18 14:08:44] WARNING[8494] chan_sip.c: Forbidden - wrong password on authentication for REGISTER for '220' to '220'

    Jedoch habe ich nichts mehr an den Daten verändert ... wieso sollte dann plötzlich das Passwort falsch sein ? Wenn ich nun das Leitungsprofil ändere, speichere und danach wieder auf das eigentlich funktionierende retourwechsele funktioniert alles wieder ... bis zum nächsten Ausfall ...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!