Posts by Gerald

    Hallo,

    ob dieses Verhalten von Firefox 39 nun ein Bug oder ein Feature ist, darüber kann man sich sicher streiten.

    Mit Firefox 39 ist es nun so, dass wenn der Server, auf den man sich per HTTPS verbindet, schwache Diffie-Hellmann Ciphern verwendet, dies mit der genannten Meldung abgebrochen wird (Stichwort: Logjam Attacke).

    Das mag für technisch versierte Leute wie Admins interessant sein, dem Benutzer bringt das aber nichts. Die Frage ist eher, warum Firefox 39 selbst noch die schwachen Diffie-Hellmann Ciphern zulässt und damit dann den Abbruch der Verbindung erzwingt.

    Wie schon von fwolf beschrieben kann man diese Ciphern im Firefox deaktivieren, indem man über about:config die Werte von

    * security.ssl3.dhe_rsa_aes_128_sha
    * security.ssl3.dhe_rsa_aes_256_sha

    auf false setzt, siehe z.B. auch unter http://techdows.com/2015/05/how-to…jam-attack.html, und was auch schon mit Firefox <=38 empfohlen wurde.

    Da findet man auch die schöne Bemerkung

    Quote

    We’re expecting Mozilla to ship Firefox 39 final by disabling the above preferences.


    was aber offensichtlich nicht gemacht wurde.

    Quote from slu

    Edit: Behebt Version 6.0.1.11 dieses Problem?
    "SSL deaktiviert und auf TLS mit starke Ciphern umgestellt"

    Nein. Da haben wir zwar schon kräftig ausgemistet, TLS_DHE_RSA_WITH_AES_128_CBC_SHA muss aber auch noch raus.

    Quote from fwolf

    Hierfür muß vermutlich das Java RE ausgetauscht bzw. aktualisiert werden.


    Nein. Man muss dem tomcat in der Konfigurationsdatei sagen, dass er die schwachen Diffie-Hellmann Ciphern nicht mehr verwenden soll, s.o.

    Das werden wir mit einer kommenden Version dann erledigen (>6.0.1.12).

    Schönes Wochenende!

    Wann erscheint der Kernel Panic? Beim Booten der Installation?

    Ich vermute auch, dass das BIOS nicht die 0542 ist.

    Systeme, die eine BIOS Version <= 0311 haben, müssen zuerst auf die 0400, und dann auf die 0542 aktualisiert werden.

    Quote from Intel


    - Die BIOS-Version 0311 (MOPNV10J.86A.0311.2010.0802.2346) ist die endgültige "10J" BIOS-Version für D510MO PC-Mainboards. Bei allen nachfolgenden BIOS-Versionen wird es sich um "10N" BIOS-Versionen handeln.

    - Die BIOS-Version 0400 (MOPNV10N.86A.0400.2010.0919.1014) ist das Übergangs-BIOS für Updates von 10J auf 10N. Um ein Update vom 10J-BIOS auf das 10N-BIOS vorzunehmen, aktualisieren Sie zuerst auf 0400. Aktualisieren Sie dann falls nötig von 0400 auf ein nachfolgendes 10N-BIOS.

    http://wiki.starface.de/index.php/BIOS…D510MO.2FD410PT

    Quote

    Gibts hier Pläne irgendwann z.B. VirtIO Treiber oder den e1000 von Intel aufzunehmen?

    In der aktuellen Version 5.0.0.14 ist der e1000-Treiber dabei. Oder meintest Du den e1000e-Treiber? Der ist ebenfalls dabei (v1.3.10a).

    Mit der kommenden Version 5.1 liefern wir die Treiber in der jeweils aktuellen Version aus:

    • e1000 8.0.35 - 2011-10-11
    • e1000e 1.11.3 - 2012-04-20 (wobei es da seit ein paar Tagen auch eine v2.0.0 gibt).
    Quote


    Beim Hochfahren der Starface Pro werden folgende Dienste als fehlgeschlagen angezeigt:

    - postgresql-Dienst
    - LCDd
    - LCDui

    LCDd & LCDui sind für die Ansteuerung eines Displays verantwortlich. Die Pro hat kein Display, deswegen schlägt das Starten der Dienste fehl. Da diese Meldungen immer wieder irreführend sind/waren werden die beiden Dienste ab STARFACE 5 nur noch gestartet, wenn ein Display vorhanden ist.

    Quote


    Ich habe die Anlage gebraucht erworben. Angeblich aus einem funktionierenden Betrieb abgenommen.

    Hat der Vorbesitzer vor dem Verkauf evtl. alle Datenbanktabellen gelöscht? Könnte ich verstehen...

    Quote


    --->
    HTTP Status 404 -

    type Status report

    message

    description The requested resource () is not available.
    Apache Tomcat/5.5.27
    <---

    Das ist ein Folgefehler. Ohne funktionierende Datenbank geht nichts.

    Versuch es mal mit einem

    Code
    yum clean headers


    und dann mit

    Code
    yum install gcc

    Wenn das dann immer noch nicht funktioniert, dann

    Code
    yum clean all

    HTH

    STARFACE basiert auf Fedora Core 4, d.h. Du kannst das Paket aus dem FC4 Update-Repository installieren:

    Code
    [root@localhost ~]# wget http://archives.fedoraproject.org/pub/archive/fedora/linux/core/updates/4/i386/mc-4.6.1a-6.fc4.i386.rpm
    [root@localhost ~]# yum install mc-4.6.1a-6.fc4.i386.rpm

    Installation auf eigene Gefahr. Wer tiefgreifende Änderungen am System vornimmt ist selbst dafür verantwortlich.

    Welche Version des Bootloaders ist auf den Telefonen installiert? Die Version wird bei den Systeminformationen angezeigt.

    Aktuell ist 1.1.3U. Durch das Einspielen des aktuellen Bootloaders haben wir hier schon einige zickige snoms besänftigt. ;)

    Den Bootloader bekommt man momentan nur über das Einspielen der Firmware 7.3.30 bf von http://wiki.snom.com/Firmware/V7/7_3 auf das Telefon.

    Das Downgrade macht ja aber nichts aus, da anschließend durch die Provisionierung wieder die 8.4.21 aufgespielt wird.

    Ab STARFACE 4.5 lässt sich der gcc mit allen Abhängigkeiten über das Update-Repository installieren.

    Dazu zunächst in /etc/yum.repos.d/starface.repo schauen, ob die URL zum Update-Repository richtig gesetzt ist. Beim Eintrag baserurl muss am Schluss die Versionsnummer der aktuell installierten Version stehen.

    Code
    baseurl=http://updates.starface.de/starface/updates/4.5.0.0

    Wurde noch nie ein Update installiert, dann fehlt die Versionssnummer und muss entsprechend ergänzt werden. Diese erhält man über

    Code
    cat /var/starface/fs-interface/version

    Installation des gcc nun mit:

    Code
    yum install gcc

    Installation des gcc auf eigene Gefahr. Wer tiefgreifende Änderungen am System vornimmt ist selbst dafür verantwortlich.

    Das sieht allerdings recht seltsam aus.

    Also nach einem Neustart/Kaltstart sollte STARFACE Advanced, http://www.starface.de,... im Display erscheinen. Ist das bei einem Neustart/Kaltstart so?

    Vor dem Update hat das Display funktioniert?

    Von welcher Version aus wurde aktualisiert?

    Ich habe gerade folgende Updates mit einer Starface Advanced getestet:
    3.5.0.12 -> 4.0.1.10: ok
    4.0.0.7 -> 4.0.1.10: ok

    Nach dem Update steht zwar das Display und es ist ein Neustart erforderlich, damit es wieder funktioniert (dieses Problem ist uns bekannt und wird demnächst behoben), aber ansonsten läuft es einwandfrei.

    Sitzt das USB-Anschlusskabel richtig auf dem Display & Mainboard?